summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLarry Hajali2015-06-11 14:29:14 -0700
committerLarry Hajali2015-06-11 14:29:14 -0700
commit5477b4b92c3de6da3853e98d7d0e4c043bb504fb (patch)
tree31217ce61b23e7c09328b605a907a24495f9f0e4
downloadaur-5477b4b92c3de6da3853e98d7d0e4c043bb504fb.tar.gz
Initial release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a230e2ae8c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by makepkg 4.2.1
+# Thu Jun 11 21:28:24 UTC 2015
+pkgbase = ndjbdns
+ pkgdesc = ndjbdns is a fork of djbdns
+ pkgver = 1.06
+ pkgrel = 1
+ url = http://pjp.dgplug.org/ndjbdns/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = systemd
+ source = http://pjp.dgplug.org/ndjbdns/ndjbdns-1.06.tar.gz
+ md5sums = 6996f803bb6c6fed5a02ad45690d62ad
+
+pkgname = ndjbdns
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..158bdce2888f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Larry Hajali <larryhaja [at] gmail [dot] com>
+
+pkgname=ndjbdns
+pkgver=1.06
+pkgrel=1
+pkgdesc="ndjbdns is a fork of djbdns"
+arch=('i686' 'x86_64')
+url="http://pjp.dgplug.org/ndjbdns/"
+license=('GPL2')
+depends=('systemd')
+source=("http://pjp.dgplug.org/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('6996f803bb6c6fed5a02ad45690d62ad')
+
+build()
+{
+ cd ${pkgname}-${pkgver}
+
+ ### Make sure root servers file is up to date.
+ _root_servers=$(curl -s http://www.internic.net/domain/named.root | grep ' A ' | awk '{print $4}')
+ if [ "${_root_servers}" != "" ]; then
+ echo ${_root_servers} | tr ' ' '\n' > etc/servers/dnsroots.global
+ fi
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-silent-rules
+ make
+}
+
+package()
+{
+ cd ${pkgname}-${pkgver}
+ make install DESTDIR="${pkgdir}"
+}