summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoah2020-07-15 22:01:34 -0500
committerNoah2020-07-15 22:01:34 -0500
commit7d5b440c30a721ed3d905666e50e643f3d508e41 (patch)
tree831a9d3a3057c8688d7b1129d66675847412678d
parentb0ce2182922a23d90109545637f87c7d5f9188ae (diff)
downloadaur-7d5b440c30a721ed3d905666e50e643f3d508e41.tar.gz
Update to newest ndless master
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
-rw-r--r--ndless-env.sh4
-rw-r--r--ndless-sdk-git.install11
-rw-r--r--ndless.patch105
5 files changed, 28 insertions, 111 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7693599f5d45..2eb0a646de37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = ndless-sdk-git
pkgdesc = SDK for programs targeting Ndless on the TI-Nspire
- pkgver = r451.edaa723
+ pkgver = r490.84b8b9f
pkgrel = 1
url = https://github.com/ndless-nspire/Ndless
+ install = ndless-sdk-git.install
arch = x86_64
license = MPL-1.1
makedepends = git
@@ -20,12 +21,14 @@ pkgbase = ndless-sdk-git
options = !strip
source = ndless::git+https://github.com/ndless-nspire/Ndless
source = ndless.patch
+ source = ndless-env.sh
source = nspire-io::git+https://github.com/Vogtinator/nspire-io.git
source = zlib::git+https://github.com/madler/zlib.git
source = git://git.sv.nongnu.org/freetype/freetype2.git
source = luna::git+https://github.com/ndless-nspire/luna.git
md5sums = SKIP
- md5sums = 85b0d2361dcb73ea6401972534c8a54d
+ md5sums = 9559c5c65d9e0956d78b0cf30dd40051
+ md5sums = e33970015b5fa585787e29f7966aaf82
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b20e15c5104f..0c578b53c65a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Noah (coolreader18)
pkgname=ndless-sdk-git
-pkgver=r451.edaa723
+pkgver=r490.84b8b9f
pkgrel=1
pkgdesc="SDK for programs targeting Ndless on the TI-Nspire"
arch=(x86_64)
@@ -14,11 +14,12 @@ conflicts=("${pkgname%-git}")
replaces=()
backup=()
options=('!strip')
-install=
-source=('ndless::git+https://github.com/ndless-nspire/Ndless' ndless.patch)
+install=$pkgname.install
+source=('ndless::git+https://github.com/ndless-nspire/Ndless' ndless.patch ndless-env.sh)
noextract=()
md5sums=('SKIP'
- '85b0d2361dcb73ea6401972534c8a54d'
+ '9559c5c65d9e0956d78b0cf30dd40051'
+ 'e33970015b5fa585787e29f7966aaf82'
'SKIP'
'SKIP'
'SKIP'
@@ -78,4 +79,7 @@ package() {
for exe in ../share/ndless-sdk/bin/*; do
[[ -x $exe ]] && ln -s "$exe" .
done
+ local profiled="$pkgdir"/etc/profile.d
+ mkdir -p "$profiled"
+ cp "$srcdir"/ndless-env.sh "$profiled"
}
diff --git a/ndless-env.sh b/ndless-env.sh
new file mode 100644
index 000000000000..547da6e945b1
--- /dev/null
+++ b/ndless-env.sh
@@ -0,0 +1,4 @@
+if [ -d /usr/share/ndless-sdk/ ]; then
+ export _NDLESS_TOOLCHAIN_PATH=/usr/share/ndless-sdk/bin
+ export _NDLESS_ZEHN_PATH=/usr/share/ndless-sdk/lib
+fi
diff --git a/ndless-sdk-git.install b/ndless-sdk-git.install
new file mode 100644
index 000000000000..019e69ce0876
--- /dev/null
+++ b/ndless-sdk-git.install
@@ -0,0 +1,11 @@
+installmsg() {
+ echo -e "\033[1mndless-sdk installed! make sure to relog or source /etc/profile.d/ndless-env.sh\033[0m"
+}
+
+post_install() {
+ installmsg
+}
+
+post_upgrade() {
+ installmsg
+}
diff --git a/ndless.patch b/ndless.patch
index b0c57f9681fc..aab832c7992f 100644
--- a/ndless.patch
+++ b/ndless.patch
@@ -1,108 +1,3 @@
-diff --git a/ndless-sdk/bin/arm-none-eabi-ld.gold b/ndless-sdk/bin/arm-none-eabi-ld.gold
-index 54cec85..5a56985 100755
---- a/ndless-sdk/bin/arm-none-eabi-ld.gold
-+++ b/ndless-sdk/bin/arm-none-eabi-ld.gold
-@@ -7,8 +7,8 @@ DIRNAME="$(dirname "$0")"
-
- # DIRNAME may not be in the toolchain directory if this script was symlinked.
- # try to find the symlink target
--which readlink >/dev/null 2>&1 && readlink "$0" >/dev/null 2>&1 && {
-- DIRNAME="$(dirname "$(readlink "$0")")"
-+which readlink >/dev/null 2>&1 && readlink -- "$0" >/dev/null 2>&1 && {
-+ DIRNAME="$(dirname "$(readlink -f -- "$0")")"
- }
-
- # Cygwin owns a dedicated command to find the symlink target
-diff --git a/ndless-sdk/bin/make-prg b/ndless-sdk/bin/make-prg
-index 7fa29c6..44beacd 100755
---- a/ndless-sdk/bin/make-prg
-+++ b/ndless-sdk/bin/make-prg
-@@ -6,8 +6,8 @@ DIRNAME="$(dirname "$0")"
-
- # DIRNAME may not be in the toolchain directory if this script was symlinked.
- # try to find the symlink target
--which readlink >/dev/null 2>&1 && readlink "$0" >/dev/null 2>&1 && {
-- DIRNAME="$(dirname "$(readlink "$0")")"
-+which readlink >/dev/null 2>&1 && readlink -- "$0" >/dev/null 2>&1 && {
-+ DIRNAME="$(dirname "$(readlink -f -- "$0")")"
- }
-
- # Cygwin owns a dedicated command to find the symlink target
-@@ -15,8 +15,6 @@ if [ "$UNAME" = "cygwin" ]; then
- DIRNAME="$(cygpath --path --windows "$DIRNAME")"
- fi
-
--MAKEFLAGS= make -C "${DIRNAME}/../tools/zehn_loader" -s all
--
- # Validate the Zehn file
- genzehn --info --input "$1" >/dev/null || exit 1 # genzehn prints an error for us
-
-@@ -24,4 +22,4 @@ genzehn --info --input "$1" >/dev/null || exit 1 # genzehn prints an error for u
- COMPRESSED=
- genzehn --info --input "$1" | grep compressed >/dev/null && COMPRESSED="_compressed"
-
--cat "${DIRNAME}/../tools/zehn_loader/zehn_loader${COMPRESSED}.tns" "$1" > "$2"
-+cat "${DIRNAME}/../lib/zehn_loader${COMPRESSED}.tns" "$1" > "$2"
-diff --git a/ndless-sdk/bin/nspire-as b/ndless-sdk/bin/nspire-as
-index cb37341..4516b3b 100755
---- a/ndless-sdk/bin/nspire-as
-+++ b/ndless-sdk/bin/nspire-as
-@@ -5,8 +5,8 @@ UNAME="$(uname -s | tr A-Z a-z)"
- DIRNAME="$(dirname "$0")"
- # DIRNAME may not be in the toolchain directory if this script was symlinked.
- # try to find the symlink target
--which readlink >/dev/null 2>&1 && readlink "$0" >/dev/null 2>&1 && {
-- SYMLINK="$(readlink "$0")"
-+which readlink >/dev/null 2>&1 && readlink -- "$0" >/dev/null 2>&1 && {
-+ SYMLINK="$(readlink -f -- "$0")"
-
- # On MacOS X, the readlink command hasn't the same behavior than the others operating systems based on Unix.
- if [ "$UNAME" = "darwin" ]; then
-diff --git a/ndless-sdk/bin/nspire-g++ b/ndless-sdk/bin/nspire-g++
-index 2beabf7..c4650c9 100755
---- a/ndless-sdk/bin/nspire-g++
-+++ b/ndless-sdk/bin/nspire-g++
-@@ -6,8 +6,8 @@ DIRNAME="$(dirname "$0")"
-
- # DIRNAME may not be in the toolchain directory if this script was symlinked.
- # try to find the symlink target
--which readlink >/dev/null 2>&1 && readlink "$0" >/dev/null 2>&1 && {
-- DIRNAME="$(dirname "$(readlink "$0")")"
-+which readlink >/dev/null 2>&1 && readlink -- "$0" >/dev/null 2>&1 && {
-+ DIRNAME="$(dirname "$(readlink -f -- "$0")")"
- }
-
- if [ "$UNAME" = "cygwin" ]; then
-diff --git a/ndless-sdk/bin/nspire-gcc b/ndless-sdk/bin/nspire-gcc
-index 381beac..d6dd72c 100755
---- a/ndless-sdk/bin/nspire-gcc
-+++ b/ndless-sdk/bin/nspire-gcc
-@@ -6,8 +6,8 @@ DIRNAME="$(dirname "$0")"
-
- # DIRNAME may not be in the toolchain directory if this script was symlinked.
- # try to find the symlink target
--which readlink >/dev/null 2>&1 && readlink "$0" >/dev/null 2>&1 && {
-- DIRNAME="$(dirname "$(readlink "$0")")"
-+which readlink >/dev/null 2>&1 && readlink -- "$0" >/dev/null 2>&1 && {
-+ DIRNAME="$(dirname "$(readlink -f -- "$0")")"
- }
-
- if [ "$UNAME" = "cygwin" ]; then
-diff --git a/ndless-sdk/bin/nspire-tools b/ndless-sdk/bin/nspire-tools
-index d023a0d..03d826c 100755
---- a/ndless-sdk/bin/nspire-tools
-+++ b/ndless-sdk/bin/nspire-tools
-@@ -12,8 +12,8 @@ DIRNAME="$(dirname "$0")"
-
- # DIRNAME may not be in the toolchain directory if this script was symlinked.
- # try to find the symlink target
--which readlink >/dev/null 2>&1 && readlink "$0" >/dev/null 2>&1 && {
-- SYMLINK="$(readlink "$0")"
-+which readlink >/dev/null 2>&1 && readlink -- "$0" >/dev/null 2>&1 && {
-+ SYMLINK="$(readlink -f -- "$0")"
-
- # On MacOS X, the readlink command hasn't the same behavior than the others operating systems based on Unix.
- if [ "$UNAME" == "darwin" ]; then
diff --git a/ndless-sdk/lib/zehn_loader.tns b/ndless-sdk/lib/zehn_loader.tns
new file mode 120000
index 0000000..64c36ae