summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilippo Berto2020-11-07 11:52:58 +0100
committerFilippo Berto2020-11-07 11:52:58 +0100
commit82f06063698b6bfc3518d3618f8c2671f27391f8 (patch)
treefdc9de0acb3f6334e1c5dc836af39ec63c546f88
downloadaur-82f06063698b6bfc3518d3618f8c2671f27391f8.tar.gz
Initial release
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD49
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a591640208e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ndn-cpp-git
+ pkgdesc = A new implementation of a Named Data Networking client library written in C++ and C. It is wire format compatible with the NDN-TLV encoding.
+ pkgver = v0.17.r66.g6d789adb
+ pkgrel = 1
+ url = https://github.com/named-data/ndn-cpp
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = python
+ depends = boost
+ depends = sqlite
+ depends = openssl>=1.0.2
+ provides = ndn-cpp
+ conflicts = ndn-cpp
+ source = git+https://github.com/named-data/ndn-cpp.git
+ sha256sums = SKIP
+
+pkgname = ndn-cpp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6fea53e944c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Filippo Berto <berto.f@protonmail.com>
+_reponame=ndn-cpp
+_pkgname=ndn-cpp
+pkgname=${_pkgname}-git
+pkgver=v0.17.r66.g6d789adb
+pkgrel=1
+# epoch=
+pkgdesc="A new implementation of a Named Data Networking client library written in C++ and C. It is wire format compatible with the NDN-TLV encoding."
+arch=('i686' 'x86_64')
+url="https://github.com/named-data/${_reponame}"
+license=('GPL')
+groups=()
+depends=('boost' 'sqlite' 'openssl>=1.0.2')
+makedepends=('git' 'python')
+checkdepends=()
+optdepends=()
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+replaces=()
+backup=()
+options=()
+install=
+source=("git+${url}.git")
+noextract=()
+sha256sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "${srcdir}/${_reponame}"
+ git describe --long | sed 's/^ndn.cxx.//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}/${_reponame}"
+ configure --prefix=/usr
+}
+
+build() {
+ cd "${srcdir}/${_reponame}"
+ make
+}
+
+#check() {
+#}
+
+package() {
+ cd "${srcdir}/${_reponame}"
+ DESTDIR=${pkgdir} make install
+}