summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilippo Berto2019-10-17 14:29:51 +0200
committerFilippo Berto2019-10-17 14:29:51 +0200
commitd5eaf4df068de927f1463fcba10de98476a45147 (patch)
tree465b139e6b1ecc6b4ec316dbace836bebee7fb1f
downloadaur-d5eaf4df068de927f1463fcba10de98476a45147.tar.gz
Initial release
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD41
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1fd5048f6c77
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = ndn-cxx
+ pkgdesc = Library implementing Named Data Networking (NDN) primitives that can be used to write various NDN applications
+ pkgver = 0.6.6
+ pkgrel = 1
+ url = https://github.com/named-data/ndn-cxx
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = gcc
+ makedepends = python
+ makedepends = pkgconf
+ makedepends = sqlite
+ makedepends = openssl>=1.0.2
+ depends = boost
+ provides = ndn-cxx
+ conflicts = ndn-cxx
+ source = https://github.com/named-data/ndn-cxx/archive/ndn-cxx-0.6.6.tar.gz
+ sha256sums = abadd5b7599a74dbe11a4491aefe30ea4a00fdecf477c1035d5eb82ce46b8f9b
+
+pkgname = ndn-cxx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc8241302082
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Filippo Berto <berto.f@protonmail.com>
+pkgname=ndn-cxx
+pkgver=0.6.6
+pkgrel=1
+# epoch=
+pkgdesc="Library implementing Named Data Networking (NDN) primitives that can be used to write various NDN applications"
+arch=("any")
+url="https://github.com/named-data/${pkgname}"
+license=('GPL')
+groups=()
+depends=('boost')
+makedepends=('git' 'gcc' 'python' 'pkgconf' 'sqlite' 'openssl>=1.0.2')
+checkdepends=()
+optdepends=()
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+replaces=()
+backup=()
+options=()
+install=
+source=(https://github.com/named-data/${pkgname}/archive/${pkgname}-${pkgver}.tar.gz)
+noextract=()
+sha256sums=('abadd5b7599a74dbe11a4491aefe30ea4a00fdecf477c1035d5eb82ce46b8f9b')
+validpgpkeys=()
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
+ ./waf configure
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
+ ./waf build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
+ ./waf install --destdir="${pkgdir}"
+
+ mv "${pkgdir}/usr/local/"* "${pkgdir}/usr"
+}