summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilippo Berto2020-04-18 23:55:09 +0200
committerFilippo Berto2020-04-18 23:55:09 +0200
commit18ad8cbc25d1765427e33671cf658b917bb95d99 (patch)
tree3dbfe71591bb7e45413d123c39bfa5af76a1bb0b
parent714049422d512903e6fbdaf3046cff1f541c0b08 (diff)
downloadaur-18ad8cbc25d1765427e33671cf658b917bb95d99.tar.gz
Update build script
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fd6b6b3b95d..5e3b5525c7bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ndn-cxx-git
pkgdesc = Library implementing Named Data Networking (NDN) primitives that can be used to write various NDN applications
pkgver = ndn.cxx.0.7.0.r13.g9603325b
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/named-data/ndn-cxx
arch = any
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index b16ff12bd30c..5d9ff83e130c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=ndn-cxx
pkgname=${_pkgname}-git
pkgver=ndn.cxx.0.7.0.r13.g9603325b
-pkgrel=1
+pkgrel=2
# epoch=
pkgdesc="Library implementing Named Data Networking (NDN) primitives that can be used to write various NDN applications"
arch=("any")
@@ -24,6 +24,11 @@ noextract=()
sha256sums=('SKIP')
validpgpkeys=()
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
prepare() {
cd "${srcdir}/${_pkgname}"
./waf configure --prefix=/usr