summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilippo Berto2019-10-04 13:59:40 +0200
committerFilippo Berto2019-10-04 13:59:40 +0200
commit2d45b991037d43168d2eaca23352de79fc3173cd (patch)
treebc16d92d7e83f361823ad9578df49701c2a57eb3
downloadaur-2d45b991037d43168d2eaca23352de79fc3173cd.tar.gz
First release
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD55
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d264cbdc66cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = ndn-cxx-git
+ pkgdesc = Library implementing Named Data Networking (NDN) primitives that can be used to write various NDN applications
+ pkgver = ndn.cxx.0.6.6.r46.g5e494c0c
+ pkgrel = 1
+ url = https://github.com/named-data/ndn-cxx
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = gcc
+ makedepends = python
+ makedepends = boost
+ makedepends = pkgconf
+ makedepends = sqlite
+ makedepends = openssl>=1.0.2
+ provides = ndn-cxx
+ conflicts = ndn-cxx
+ source = git+https://github.com/named-data/ndn-cxx.git
+ sha256sums = SKIP
+
+pkgname = ndn-cxx-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62fdced3f387
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Filippo Berto <berto.f@protonmail.com>
+_pkgname=ndn-cxx
+pkgname=${_pkgname}-git
+pkgver=ndn.cxx.0.6.6.r46.g5e494c0c
+pkgrel=1
+# epoch=
+pkgdesc="Library implementing Named Data Networking (NDN) primitives that can be used to write various NDN applications"
+arch=("any")
+url="https://github.com/named-data/${_pkgname}"
+license=('GPL')
+groups=()
+depends=()
+makedepends=('git' 'gcc' 'python' 'boost' 'pkgconf' 'sqlite' 'openssl>=1.0.2')
+checkdepends=()
+optdepends=()
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+replaces=()
+backup=()
+options=()
+install=
+source=("git+${url}.git")
+noextract=()
+sha256sums=('SKIP')
+validpgpkeys=()
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ git checkout `g describe --tags --abbrev=0`
+ # Run the initial configuration
+ ./waf configure
+}
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ # Build libraries and tools
+ ./waf build
+}
+
+# check() {
+# cd "${srcdir}/${_reponame}"
+# ./waf check
+# }
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ ./waf install --destdir="${pkgdir}"
+
+ mv "${pkgdir}/usr/local/"* "${pkgdir}/usr"
+}