summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilippo Berto2020-04-19 00:08:25 +0200
committerFilippo Berto2020-04-19 00:08:25 +0200
commit025a840d51a0f0f1ec60bdf2f0be4c8a1230914e (patch)
tree8468a6a872a00943bf94405e01f2d67c27bc49e6
parent51917597583ec81c8f155099b7bc0f875fd244cc (diff)
downloadaur-025a840d51a0f0f1ec60bdf2f0be4c8a1230914e.tar.gz
Update to 0.7.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
2 files changed, 22 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1444a57d1d7..2e106e932f43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ndn-nfd
pkgdesc = NFD is a network forwarder that implements and evolves together with the Named Data Networking (NDN) protocol
- pkgver = 0.6.6
+ pkgver = 0.7.0
pkgrel = 1
url = https://github.com/named-data/NFD
arch = any
@@ -15,11 +15,13 @@ pkgbase = ndn-nfd
depends = ndn-cxx
depends = boost
optdepends = valgrind: memory analysis
+ optdepends = doxygen: build documentation
+ optdepends = python-sphynx: build documentation
provides = ndn-nfd
conflicts = ndn-nfd
- source = https://github.com/named-data/NFD/archive/NFD-0.6.6.tar.gz
+ source = https://github.com/named-data/NFD/archive/NFD-0.7.0.tar.gz
source = https://github.com/cawka/websocketpp/archive/0.8.1-hotfix.tar.gz
- sha256sums = ff57d96d479c6b8a3c8814c360428dbf82b09a7d1c1de57135116607a7e1cfbd
+ sha256sums = dfe90e958b062b8beb90ebaa10d9a10c2165952c772aa03f170913666d602cce
sha256sums = a5f692a4a8304eccfb6506941ceeb97990f0aecfcbe045d7fe8b24a46e0ef671
pkgname = ndn-nfd
diff --git a/PKGBUILD b/PKGBUILD
index 3aaafbc6f346..ea3f9688fd16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Filippo Berto <berto.f@protonmail.com>
_reponame=NFD
-pkgname=ndn-nfd
-pkgver=0.6.6
+_pkgname=ndn-nfd
+pkgname=$_pkgname
+pkgver=0.7.0
pkgrel=1
# epoch=
pkgdesc="NFD is a network forwarder that implements and evolves together with the Named Data Networking (NDN) protocol"
@@ -12,9 +13,11 @@ groups=()
depends=('ndn-cxx' 'boost')
makedepends=('git' 'gcc' 'python' 'boost' 'pkgconf' 'sqlite' 'openssl>=1.0.2')
checkdepends=()
-optdepends=('valgrind: memory analysis')
-provides=("${pkgname}")
-conflicts=("${pkgname}")
+optdepends=('valgrind: memory analysis'
+ 'doxygen: build documentation'
+ 'python-sphynx: build documentation')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
replaces=()
backup=()
options=()
@@ -24,15 +27,21 @@ source=(
https://github.com/cawka/websocketpp/archive/0.8.1-hotfix.tar.gz
)
noextract=()
-sha256sums=('ff57d96d479c6b8a3c8814c360428dbf82b09a7d1c1de57135116607a7e1cfbd'
+sha256sums=('dfe90e958b062b8beb90ebaa10d9a10c2165952c772aa03f170913666d602cce'
'a5f692a4a8304eccfb6506941ceeb97990f0aecfcbe045d7fe8b24a46e0ef671')
validpgpkeys=()
prepare() {
+
+ # Linking websocketpp library
rmdir "${srcdir}/${_reponame}-${_reponame}-${pkgver}/websocketpp"
ln -vs "${srcdir}/websocketpp-0.8.1-hotfix" "${srcdir}/${_reponame}-${_reponame}-${pkgver}/websocketpp"
- cd "${srcdir}/${_reponame}-${_reponame}-${pkgver}"
- ./waf configure
+
+ cd "${srcdir}/${_reponame}-${_reponame}-${pkgver}"
+
+ ls -la
+
+ ./waf configure --prefix=/usr
}
build() {
@@ -43,5 +52,4 @@ build() {
package() {
cd "${srcdir}/${_reponame}-${_reponame}-${pkgver}"
./waf install --destdir="${pkgdir}"
- mv "${pkgdir}/usr/local/"* "${pkgdir}/usr"
}