summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilippo Berto2019-10-17 15:34:13 +0200
committerFilippo Berto2019-10-17 15:34:13 +0200
commit51917597583ec81c8f155099b7bc0f875fd244cc (patch)
tree326a7be6d6eb3acf3e197546666fe4a6869ce05c
downloadaur-51917597583ec81c8f155099b7bc0f875fd244cc.tar.gz
Initial release
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD47
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1444a57d1d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = ndn-nfd
+ pkgdesc = NFD is a network forwarder that implements and evolves together with the Named Data Networking (NDN) protocol
+ pkgver = 0.6.6
+ pkgrel = 1
+ url = https://github.com/named-data/NFD
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = gcc
+ makedepends = python
+ makedepends = boost
+ makedepends = pkgconf
+ makedepends = sqlite
+ makedepends = openssl>=1.0.2
+ depends = ndn-cxx
+ depends = boost
+ optdepends = valgrind: memory analysis
+ provides = ndn-nfd
+ conflicts = ndn-nfd
+ source = https://github.com/named-data/NFD/archive/NFD-0.6.6.tar.gz
+ source = https://github.com/cawka/websocketpp/archive/0.8.1-hotfix.tar.gz
+ sha256sums = ff57d96d479c6b8a3c8814c360428dbf82b09a7d1c1de57135116607a7e1cfbd
+ sha256sums = a5f692a4a8304eccfb6506941ceeb97990f0aecfcbe045d7fe8b24a46e0ef671
+
+pkgname = ndn-nfd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3aaafbc6f346
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Filippo Berto <berto.f@protonmail.com>
+_reponame=NFD
+pkgname=ndn-nfd
+pkgver=0.6.6
+pkgrel=1
+# epoch=
+pkgdesc="NFD is a network forwarder that implements and evolves together with the Named Data Networking (NDN) protocol"
+arch=("any")
+url="https://github.com/named-data/${_reponame}"
+license=('GPL')
+groups=()
+depends=('ndn-cxx' 'boost')
+makedepends=('git' 'gcc' 'python' 'boost' 'pkgconf' 'sqlite' 'openssl>=1.0.2')
+checkdepends=()
+optdepends=('valgrind: memory analysis')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+replaces=()
+backup=()
+options=()
+install=
+source=(
+ https://github.com/named-data/${_reponame}/archive/${_reponame}-${pkgver}.tar.gz
+ https://github.com/cawka/websocketpp/archive/0.8.1-hotfix.tar.gz
+)
+noextract=()
+sha256sums=('ff57d96d479c6b8a3c8814c360428dbf82b09a7d1c1de57135116607a7e1cfbd'
+ 'a5f692a4a8304eccfb6506941ceeb97990f0aecfcbe045d7fe8b24a46e0ef671')
+validpgpkeys=()
+
+prepare() {
+ rmdir "${srcdir}/${_reponame}-${_reponame}-${pkgver}/websocketpp"
+ ln -vs "${srcdir}/websocketpp-0.8.1-hotfix" "${srcdir}/${_reponame}-${_reponame}-${pkgver}/websocketpp"
+ cd "${srcdir}/${_reponame}-${_reponame}-${pkgver}"
+ ./waf configure
+}
+
+build() {
+ cd "${srcdir}/${_reponame}-${_reponame}-${pkgver}"
+ ./waf build
+}
+
+package() {
+ cd "${srcdir}/${_reponame}-${_reponame}-${pkgver}"
+ ./waf install --destdir="${pkgdir}"
+ mv "${pkgdir}/usr/local/"* "${pkgdir}/usr"
+}