summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilippo Berto2020-08-07 18:04:00 +0200
committerFilippo Berto2020-08-07 18:04:00 +0200
commit01ec6632208914cd93eeb66635225f0ec0f8d754 (patch)
tree4424a31cf47b094213727049bec2fc7a194696c9
downloadaur-01ec6632208914cd93eeb66635225f0ec0f8d754.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD47
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..442d5dc51bd9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = ndn-nlsr
+ pkgdesc = Named Data Link State Routing Protocol
+ pkgver = 0.5.2
+ pkgrel = 1
+ url = https://github.com/named-data/NLSR
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = gcc
+ makedepends = python
+ makedepends = boost
+ makedepends = pkgconf
+ makedepends = sqlite
+ makedepends = openssl>=1.0.2
+ depends = ndn-cxx
+ depends = boost
+ optdepends = valgrind: memory analysis
+ optdepends = doxygen: build documentation
+ optdepends = python-sphinx: build documentation
+ provides = ndn-nlsr
+ conflicts = ndn-nlsr
+ source = https://github.com/named-data/NLSR/archive/NLSR-0.5.2.tar.gz
+ sha256sums = 27d8672784c63f815ff519f807e94fbb66f1a8da3674fe907cea762f465d55de
+
+pkgname = ndn-nlsr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebba018d2e24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Filippo Berto <berto.f@protonmail.com>
+_reponame=NLSR
+_pkgname=ndn-nlsr
+pkgname=$_pkgname
+pkgver=0.5.2
+pkgrel=1
+# epoch=
+pkgdesc="Named Data Link State Routing Protocol"
+arch=('i686' 'x86_64')
+url="https://github.com/named-data/${_reponame}"
+license=('GPL')
+groups=()
+depends=('ndn-cxx' 'boost')
+makedepends=('git' 'gcc' 'python' 'boost' 'pkgconf' 'sqlite' 'openssl>=1.0.2')
+checkdepends=()
+optdepends=('valgrind: memory analysis'
+ 'doxygen: build documentation'
+ 'python-sphinx: build documentation')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+replaces=()
+backup=()
+options=()
+install=
+source=(https://github.com/named-data/${_reponame}/archive/${_reponame}-${pkgver}.tar.gz)
+noextract=()
+sha256sums=('27d8672784c63f815ff519f807e94fbb66f1a8da3674fe907cea762f465d55de')
+validpgpkeys=()
+
+prepare() {
+ cd "${srcdir}/${_reponame}-${_reponame}-${pkgver}"
+
+ # Patch missing includes
+ sed -i '26i#include <ostream>' src/statistics.hpp
+
+ ./waf configure --prefix=/usr
+}
+
+build() {
+ cd "${srcdir}/${_reponame}-${_reponame}-${pkgver}"
+ ./waf build
+}
+
+package() {
+ cd "${srcdir}/${_reponame}-${_reponame}-${pkgver}"
+ ./waf install --destdir="${pkgdir}"
+}