summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilippo Berto2020-08-07 13:26:46 +0200
committerFilippo Berto2020-08-07 13:26:46 +0200
commit17b9eba126af55274b21ee428ab05d262b14de65 (patch)
tree70e437e1cb1b8cecaea49317705b372946ef059d
parenta34496b7ceceff3fba42d6f8d707ba12422e43c4 (diff)
downloadaur-17b9eba126af55274b21ee428ab05d262b14de65.tar.gz
Standardized package versioning
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 152bfb00f6e4..ed0019781943 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = ndn-psync-git
pkgdesc = Library implementing Named Data Networking (NDN) primitives that can be used to write various NDN applications
pkgver = 0.2.0.r8.g042dfb3
- pkgrel = 3
- url = https://github.com/named-data/psync
+ pkgrel = 4
+ url = https://github.com/named-data/PSync
arch = i686
arch = x86_64
license = GPL
@@ -16,7 +16,7 @@ pkgbase = ndn-psync-git
depends = ndn-cxx
provides = ndn-psync
conflicts = ndn-psync
- source = git+https://github.com/named-data/psync.git
+ source = git+https://github.com/named-data/PSync.git
sha256sums = SKIP
pkgname = ndn-psync-git
diff --git a/PKGBUILD b/PKGBUILD
index 8363c3c2913e..f57202ede65d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: Filippo Berto <berto.f@protonmail.com>
-_pkgname=psync
-pkgname=ndn-${_pkgname}-git
+_reponame=PSync
+_pkgname=ndn-psync
+pkgname=${_pkgname}-git
pkgver=0.2.0.r8.g042dfb3
-pkgrel=3
+pkgrel=4
# epoch=
pkgdesc="Library implementing Named Data Networking (NDN) primitives that can be used to write various NDN applications"
arch=('i686' 'x86_64')
-url="https://github.com/named-data/${_pkgname}"
+url="https://github.com/named-data/${_reponame}"
license=('GPL')
groups=()
depends=('boost' 'ndn-cxx')
makedepends=('git' 'gcc' 'python' 'pkgconf' 'sqlite' 'openssl>=1.0.2')
checkdepends=()
optdepends=()
-provides=("ndn-${_pkgname}")
-conflicts=("ndn-${_pkgname}")
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
replaces=()
backup=()
options=()
@@ -25,26 +26,26 @@ sha256sums=('SKIP')
validpgpkeys=()
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_reponame}"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_reponame}"
./waf configure --prefix=/usr --with-tests
}
build() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_reponame}"
./waf build
}
check() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_reponame}"
./build/unit-tests
}
package() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_reponame}"
./waf install --destdir="${pkgdir}"
}