summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:00:08 +0200
committerM0Rf302015-06-17 16:00:08 +0200
commitd17d1230ae65d171836e54f9208ee95b5c22493a (patch)
treec583270d0f39e43899445d838184a74f494863e6
downloadaur-d17d1230ae65d171836e54f9208ee95b5c22493a.tar.gz
Initial import
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
3 files changed, 53 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..db3e41672e71
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = ndpi
+ pkgdesc = Open and Extensible GPLv3 Deep Packet Inspection Library
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = http://www.ntop.org/products/ndpi/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ conflicts = ndpi-svn
+ source = http://ftp.de.debian.org/debian/pool/main/n/ndpi/ndpi_1.5.0.orig.tar.gz
+ md5sums = d6659045aab8d5cfe0778605bf408d00
+
+pkgname = ndpi
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db3e41672e71
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ndpi
+ pkgdesc = Open and Extensible GPLv3 Deep Packet Inspection Library
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = http://www.ntop.org/products/ndpi/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ conflicts = ndpi-svn
+ source = http://ftp.de.debian.org/debian/pool/main/n/ndpi/ndpi_1.5.0.orig.tar.gz
+ md5sums = d6659045aab8d5cfe0778605bf408d00
+
+pkgname = ndpi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf962c5f8249
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: M0Rf30
+
+pkgname=ndpi
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="Open and Extensible GPLv3 Deep Packet Inspection Library"
+arch=('i686' 'x86_64')
+url="http://www.ntop.org/products/ndpi/"
+license=('GPL3')
+conflicts=('ndpi-svn')
+
+source=("http://ftp.de.debian.org/debian/pool/main/n/ndpi/ndpi_$pkgver.orig.tar.gz")
+
+build() {
+ cd ${srcdir}/libndpi-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/libndpi-$pkgver
+ make DESTDIR="${pkgdir}/" install
+}
+
+md5sums=('d6659045aab8d5cfe0778605bf408d00')