summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHexhu2020-06-09 02:40:28 -0700
committerHexhu2020-06-09 02:40:28 -0700
commitafbb5bf2f6c68e7f8574519fa6554849fbbf230d (patch)
treeaae13d992e0634b96aa1d55667e4271bac218f6a
parent5919a6fbe4059cde55d4dfae9908752511ee88b7 (diff)
downloadaur-afbb5bf2f6c68e7f8574519fa6554849fbbf230d.tar.gz
systemd complained about legacy PID path, so update systemd unit file
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--ndppd.service12
3 files changed, 21 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed8761047422..c9824e1f3028 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ndppd-git
pkgdesc = NDP Proxy Daemon, version 0.x (git version)
pkgver = r116.e01d67a
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/DanielAdolfsson/ndppd
arch = x86_64
license = GPL3
@@ -10,7 +10,9 @@ pkgbase = ndppd-git
conflicts = ndppd
backup = etc/ndppd.conf
source = git+https://github.com/DanielAdolfsson/ndppd
+ source = ndppd.service
md5sums = SKIP
+ md5sums = 4658734163b92421e4e4fea4cbb4f7d9
pkgname = ndppd-git
diff --git a/PKGBUILD b/PKGBUILD
index 7b92413e3f7e..9e6db7473b5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ndppd-git
pkgver=r116.e01d67a
-pkgrel=2
+pkgrel=3
pkgdesc="NDP Proxy Daemon, version 0.x (git version)"
arch=('x86_64')
url="https://github.com/DanielAdolfsson/ndppd"
@@ -13,9 +13,10 @@ makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
backup=('etc/ndppd.conf')
-source=('git+https://github.com/DanielAdolfsson/ndppd')
-noextract=()
-md5sums=('SKIP')
+source=('git+https://github.com/DanielAdolfsson/ndppd'
+ 'ndppd.service')
+md5sums=('SKIP'
+ '4658734163b92421e4e4fea4cbb4f7d9')
pkgver() {
cd "${srcdir}/${pkgname%-git}"
@@ -36,6 +37,6 @@ build() {
package() {
cd "${srcdir}/${pkgname%-git}"
make PREFIX=/usr SBINDIR=/${pkgdir}/usr/bin DESTDIR=${pkgdir} install
- install -D -m 644 "ndppd.service" "${pkgdir}/usr/lib/systemd/system/ndppd.service"
+ install -D -m 644 "${srcdir}/ndppd.service" "${pkgdir}/usr/lib/systemd/system/ndppd.service"
install -D -m 644 "ndppd.conf-dist" "${pkgdir}/etc/ndppd.conf"
}
diff --git a/ndppd.service b/ndppd.service
new file mode 100644
index 000000000000..53f3a9688bb0
--- /dev/null
+++ b/ndppd.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=NDP Proxy Daemon
+Wants=network.target
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/ndppd
+StandardOutput=journal
+StandardError=journal
+
+[Install]
+WantedBy=multi-user.target