summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorshtrom2010-02-17 00:31:10 +0000
committershtrom2010-02-17 00:31:10 +0000
commita75d94c498b20bc8a64a3ca74cb75b37b67de0da (patch)
tree892a51854ce9ed946d10b829ff74082efbe384a8
downloadaur-a75d94c498b20bc8a64a3ca74cb75b37b67de0da.tar.gz
[ndt] Package builds and install without complaining. Net sure if it fully works
yot. though. git-svn-id: svn+ssh://scm.narf.ssji.net/svn/archlinux-packages@228 df209809-8e4a-0410-9a64-c169741eb0fc
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore0
-rw-r--r--PKGBUILD35
-rw-r--r--fix_JAnalyze_Makefile_target.patch13
-rw-r--r--fix_configure_include_paths.patch22
5 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d01be47154c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ndt
+ pkgdesc = The Network Diagnostic Tool (NDT) is a client/server program that provides network configuration and performance testing
+ pkgver = 3.6.0
+ pkgrel = 1
+ url = http://www.internet2.edu/performance/ndt/index.html
+ arch = x86_64
+ license = BSD
+ depends = web100-utils
+ depends = jopenchart
+ source = http://software.internet2.edu/sources/ndt/ndt-3.6.0.tar.gz
+ source = fix_configure_include_paths.patch
+ source = fix_JAnalyze_Makefile_target.patch
+ md5sums = 93230f7e6ef94a19b6f1fbd8219794ad
+ md5sums = ec3e388b9a54094216af62cab7bb07d7
+ md5sums = 90838b71a45f9e7e8432c4077b0259ca
+
+pkgname = ndt
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84641b383f13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Olivier Mehani <shtrom-aur@ssji.net>
+# $Id$
+pkgname=ndt
+pkgver=3.6.0
+pkgrel=1
+pkgdesc="The Network Diagnostic Tool (NDT) is a client/server program that provides network configuration and performance testing"
+arch=('x86_64')
+url="http://www.internet2.edu/performance/ndt/index.html"
+license=('BSD')
+depends=('web100-utils' 'jopenchart')
+source=(http://software.internet2.edu/sources/ndt/$pkgname-$pkgver.tar.gz
+ fix_configure_include_paths.patch
+ fix_JAnalyze_Makefile_target.patch)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ patch -p1 < $srcdir/fix_configure_include_paths.patch
+ patch -p1 < $srcdir/fix_JAnalyze_Makefile_target.patch
+
+ ./configure --prefix=/usr
+ # XXX: The CLASSPATH specification looks bodgey...
+ make ndtdir="/usr/share/java/ndt" CLASSPATH_ENV="CLASSPATH=/usr/share/java/jopenchart/charting-0.94.jar" || return 1
+ make ndtdir="$pkgdir/usr/share/java/ndt" prefix="$pkgdir/usr" install
+
+ # Avoid collision with hunspell
+ mv $pkgdir/usr/bin/analyze $pkgdir/usr/bin/ndt-analyze
+ mv $pkgdir/usr/man/man1/analyze.1 $pkgdir/usr/man/man1/ndt-analyze.1
+ sed -i "s/analyze[^r]/ndt-&/" $pkgdir/usr/man/man1/ndt-analyze.1
+}
+
+# vim:set ts=2 sw=2 et:
+md5sums=('93230f7e6ef94a19b6f1fbd8219794ad'
+ 'ec3e388b9a54094216af62cab7bb07d7'
+ '90838b71a45f9e7e8432c4077b0259ca')
diff --git a/fix_JAnalyze_Makefile_target.patch b/fix_JAnalyze_Makefile_target.patch
new file mode 100644
index 000000000000..001660fa4cd8
--- /dev/null
+++ b/fix_JAnalyze_Makefile_target.patch
@@ -0,0 +1,13 @@
+Index: janalyze/Makefile.in
+===================================================================
+--- ndt-3.6.0/janalyze.orig/Makefile.in
++++ ndt-3.6.0/janalyze/Makefile.in
+@@ -715,7 +715,7 @@ distdir: $(DISTFILES)
+ done
+ check-am: all-am
+ check: check-am
+-all-am: Makefile $(PROGRAMS) classJAnalyze.stamp $(DATA)
++all-am: Makefile $(PROGRAMS) $(DATA)
+ installdirs:
+ for dir in "$(DESTDIR)$(JAnalyzedir)" "$(DESTDIR)$(ndtdir)"; do \
+ test -z "$$dir" || $(mkdir_p) "$$dir"; \
diff --git a/fix_configure_include_paths.patch b/fix_configure_include_paths.patch
new file mode 100644
index 000000000000..816eaa134e37
--- /dev/null
+++ b/fix_configure_include_paths.patch
@@ -0,0 +1,22 @@
+Index: ndt-3.6.0/configure
+===================================================================
+--- ndt-3.6.0.orig/configure
++++ ndt-3.6.0/configure
+@@ -3063,7 +3063,7 @@ echo "${ECHO_T}$ac_cv_lib_web100_web100_
+ if test $ac_cv_lib_web100_web100_snap = yes; then
+
+ LINKED_WEB100LIB="-lweb100"
+- INCLUDED_WEB100LIB="-I/usr/local/include/web100"
++ INCLUDED_WEB100LIB="-I/usr/include/web100"
+
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_LIBWEB100 1
+@@ -4197,7 +4197,7 @@ fi
+
+
+ NDTINCDIR='$(INCLUDED_WEB100LIB) $(INCLUDED_PCAPLIB)'
+-NDTLIBDIR=/usr/local/lib
++NDTLIBDIR=/usr/lib
+ NDTLDFLAGS='-L$(NDTLIBDIR) -Wl,-rpath,$(NDTLIBDIR)'
+ NDTLIBS='$(LINKED_WEB100LIB) $(LINKED_PCAPLIB) $(LINKED_ODBCLIB) -lm'
+ NDTINCS='-I$(NDTINCDIR)'