summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author10sr2015-06-30 00:18:45 +0900
committer10sr2015-06-30 00:18:45 +0900
commit9627451ad16d3ea21b065b250485d97fc67b8700 (patch)
tree09adf312e268be1ca0b731c8b3819a8ba5caccec
downloadaur-9627451ad16d3ea21b065b250485d97fc67b8700.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
-rw-r--r--neap.desktop13
-rw-r--r--neap.install3
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c5d95ad405f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = neap-hotkey
+ pkgdesc = A simple pager that runs in the notification area / systray with hotkey support
+ pkgver = 0.8.4
+ pkgrel = 1
+ url = https://github.com/10sr/neap
+ install = neap.install
+ arch = any
+ license = custom:BSD-new
+ depends = pygtk
+ depends = python2-xlib
+ optdepends = python2-keybinder2: For hotkeys
+ provides = neap=0.8.3
+ source = neap-0.8.4.tar.gz::https://github.com/10sr/neap/archive/v0.8.4.tar.gz
+ source = neap.desktop
+ md5sums = 3eb6b00f34debba2a6f2b9a9e1474acf
+ md5sums = bd49e0a8c8b5e84d85401c9ab3b9c2dd
+
+pkgname = neap-hotkey
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dad624301ff3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: 10sr <8slashes+arch [at] gmail [dot] com>
+# Contributor: Krzysztof Wloch <wloszekk [at] gmail [dot] com>
+# Contributor: Dries De Smet <driesdesmet at gmail dot com>
+
+pkgname=neap-hotkey
+#_pkgname=neap
+pkgver=0.8.4
+pkgrel=1
+pkgdesc="A simple pager that runs in the notification area / systray with hotkey support"
+arch=(any)
+url="https://github.com/10sr/neap"
+license=('custom:BSD-new')
+depends=('pygtk' 'python2-xlib')
+optdepends=('python2-keybinder2: For hotkeys')
+provides=('neap=0.8.3')
+#conflicts=('neap')
+install="neap.install"
+source=("neap-$pkgver.tar.gz::https://github.com/10sr/neap/archive/v$pkgver.tar.gz"
+ "neap.desktop")
+
+md5sums=('3eb6b00f34debba2a6f2b9a9e1474acf'
+ 'bd49e0a8c8b5e84d85401c9ab3b9c2dd')
+
+package() {
+ install -D -m 644 neap.desktop ${pkgdir}/usr/share/applications/$pkgname.desktop
+
+ cd ${srcdir}/neap-$pkgver
+
+ install -D -m 644 License.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -D -m 644 README ${pkgdir}/usr/share/${pkgname}/README
+ install -D -m 644 ChangeLog ${pkgdir}/usr/share/${pkgname}/ChangeLog
+
+ sed -i 's/python$/python2/g' neap
+ install -D -m 755 neap ${pkgdir}/usr/bin/${pkgname}
+}
diff --git a/neap.desktop b/neap.desktop
new file mode 100644
index 000000000000..cb3fb87d7cbf
--- /dev/null
+++ b/neap.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Neap
+Name[fr]=Neap
+Comment=A simple pager/desktop switcher
+Comment[fr]=Un pager/changeur de bureau simple
+Exec=neap
+TryExec=neap
+Icon=workspace-switcher
+StartupNotify=true
+Categories=GTK;Utility;
+Terminal=false
diff --git a/neap.install b/neap.install
new file mode 100644
index 000000000000..c635093289ee
--- /dev/null
+++ b/neap.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "==> Config file can be found at ~/.neaprc"
+}