summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvcalv2025-03-17 07:02:42 +0900
committervcalv2025-03-17 07:02:42 +0900
commit91560d03641ced08e6850da47ca41d9bfb9222ae (patch)
tree28753537f67e075525551ffd0388b1d8682d9b67
parent3c9c6f4a11ec7bfc9d2079eae9b28852b48c8cea (diff)
downloadaur-91560d03641ced08e6850da47ca41d9bfb9222ae.tar.gz
Major update to 9.2.3
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD37
2 files changed, 38 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bce090f95278..92a8669151fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,32 +1,26 @@
pkgbase = neatimage
- pkgdesc = Best noise reduction fro digital cameras and scanners
- pkgver = 8.6
- pkgrel = 2
+ pkgdesc = Best noise reduction for digital cameras and scanners
+ pkgver = 9.2.3
+ pkgrel = 1
url = https://ni.neatvideo.com/
arch = x86_64
license = custom
- depends = bzip2
- depends = expat
+ depends = libxcb
+ depends = xcb-util-image
+ depends = xcb-util-keysyms
+ depends = xcb-util-wm
+ depends = xcb-util-renderutil
+ depends = libxkbcommon
+ depends = libxkbcommon-x11
depends = fontconfig
depends = freetype2
- depends = gcc-libs
- depends = glib2
- depends = glibc
- depends = graphite
- depends = harfbuzz
- depends = libpng
- depends = libutil-linux
depends = libx11
+ depends = libsm
+ depends = libice
depends = libxau
- depends = libxcb
depends = libxdmcp
- depends = libxext
- depends = libxi
- depends = pcre
- depends = zlib
- source = https://ni.neatvideo.com/demo/ni8/sld/NeatImageSL.Demo.Intel64.tgz
- sha512sums = e002e5f90d3b7d9fe6569ed143b93f0f9931090b8e85fc1d9a14d4d0da219f9ad29ce41c892a9c214237a1eb1de094b01439e87bc46a4ae5c229c667b470aac9
- b2sums = bcef671427333de0925e66ecc233e01ff57a219d8c0a85871cf2e9dc3f6df24618d2d90afcb6ae3e95bea27d8eba6d198db126b57eac0f7bdba6cc6b589358c1
+ depends = xcb-util
+ source = neatimage-9.2.3.tar.gz::https://ni.neatvideo.com/demo/ni9/sld/NeatImage9SL.Demo.Intel64.tgz
+ sha512sums = 6b7308b2dcddbc4cbebc7785630fcf817950467ccaac2fd53c7b06d26df42bb8550afa733f6c67f832207816851d3d517d9c286e8616d36993434aadcd09416e
pkgname = neatimage
-
diff --git a/PKGBUILD b/PKGBUILD
index 0ee1d3de6651..2ce8acb888fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,40 @@
-# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
-# shellcheck disable=SC2034
+# Maintainer : VCalV
pkgname=neatimage
-pkgver=8.6
-pkgrel=2
-pkgdesc="Best noise reduction fro digital cameras and scanners"
+pkgver=9.2.3
+pkgrel=1
+pkgdesc="Best noise reduction for digital cameras and scanners"
arch=('x86_64')
url="https://ni.neatvideo.com/"
license=('custom')
-depends=(bzip2 expat fontconfig freetype2 gcc-libs glib2 glibc graphite harfbuzz libpng libutil-linux libx11 libxau libxcb libxdmcp libxext libxi pcre zlib)
-source=('https://ni.neatvideo.com/demo/ni8/sld/NeatImageSL.Demo.Intel64.tgz')
-sha512sums=('e002e5f90d3b7d9fe6569ed143b93f0f9931090b8e85fc1d9a14d4d0da219f9ad29ce41c892a9c214237a1eb1de094b01439e87bc46a4ae5c229c667b470aac9')
-b2sums=('bcef671427333de0925e66ecc233e01ff57a219d8c0a85871cf2e9dc3f6df24618d2d90afcb6ae3e95bea27d8eba6d198db126b57eac0f7bdba6cc6b589358c1')
+depends=(libxcb xcb-util-image xcb-util-keysyms xcb-util-wm xcb-util-renderutil libxkbcommon libxkbcommon-x11 fontconfig freetype2 libx11 libsm libice libxau libxdmcp xcb-util)
+makedepends=()
+source=($pkgname-$pkgver.tar.gz::https://ni.neatvideo.com/demo/ni9/sld/NeatImage9SL.Demo.Intel64.tgz)
+sha512sums=(6b7308b2dcddbc4cbebc7785630fcf817950467ccaac2fd53c7b06d26df42bb8550afa733f6c67f832207816851d3d517d9c286e8616d36993434aadcd09416e)
package() {
- echo | # “True” silent mode does not appear to do anything…
- ./NeatImageSL.Demo.Intel64.run --prefix "$pkgdir"/opt/NeatImage --mode console \
+ ./NeatImage9SL.Demo.Intel64.run --prefix "$pkgdir"/opt/NeatImage --mode silent \
|| true # … and the installer returns 1 when it succeeds.
rm "$pkgdir"/opt/NeatImage/uninstall
- install -Dm644 "$pkgdir"/opt/NeatImage/Legal.txt "$pkgdir"/usr/share/licenses/"$pkgname"/Legal.txt
+ mkdir -p "$pkgdir"/usr/share/licenses/"$pkgname"
+ mkdir -p "$pkgdir"/usr/share/doc/"$pkgname"
+
+ ln -s /opt/NeatImage/Legal.txt "$pkgdir"/usr/share/licenses/"$pkgname"/Legal.txt
+ ln -s /opt/NeatImage/NeatImage.pdf "$pkgdir"/usr/share/doc/"$pkgname"/NeatImage.pdf
+ ln -s /opt/NeatImage/Compatibility.txt "$pkgdir"/usr/share/doc/"$pkgname"/Compatibility.txt
+ ln -s /opt/NeatImage/ReadMe.txt "$pkgdir"/usr/share/doc/"$pkgname"/ReadMe.txt
+ ln -s /opt/NeatImage/WhatsNew.txt "$pkgdir"/usr/share/doc/"$pkgname"/WhatsNew.txt
# install -Dm755 neatimage "$pkgdir"/usr/bin/neatimage
mkdir -p "$pkgdir"/usr/bin
- cat > "$pkgdir"/usr/bin/NeatImage <<<'#!/bin/bash
+ cat > "$pkgdir"/usr/bin/NeatImage <<<'#!/bin/sh
cd /opt/NeatImage/ && ./NeatImage "$@"'
- cat > "$pkgdir"/usr/bin/NeatImageCL <<<'#!/bin/bash
+ cat > "$pkgdir"/usr/bin/NeatImageCL <<<'#!/bin/sh
cd /opt/NeatImage/ && ./NeatImageCL "$@"'
chmod +x "$pkgdir"/usr/bin/NeatImage{,CL}
+
+ cd "$pkgdir"/opt/NeatImage/
+ ln -s NeatImage9 NeatImage
+ ln -s NeatImage9CL NeatImageCL
}