summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-06 22:02:38 +0100
committerBartłomiej Piotrowski2018-01-06 22:02:38 +0100
commit33a4805b4dfc4981a8190c1bc711e448d3b10d9c (patch)
treeb57ba8d1bd832fcd29289efec79c325563500bcd
downloadaur-33a4805b4dfc4981a8190c1bc711e448d3b10d9c.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
-rw-r--r--constants.archlinux.patch42
-rw-r--r--neatx.install17
4 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5300881c0e7f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = neatx
+ pkgdesc = A free NX server by google
+ pkgver = 0.3.1
+ pkgrel = 15
+ url = https://code.google.com/archive/p/neatx/
+ install = neatx.install
+ arch = x86_64
+ license = GPL
+ makedepends = docutils
+ depends = python2-pexpect
+ depends = python2-simplejson
+ depends = netcat
+ depends = pygtk
+ optdepends = xorg-xdm: if you want to use KDE or GNOME session
+ optdepends = xorg-fonts-misc: to use default font
+ optdepends = xterm: if you want console session
+ source = https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/neatx/neatx-0.3.1.tar.gz
+ source = constants.archlinux.patch
+ md5sums = 5748656738d5f04fef1af01b9fe5ef20
+ md5sums = a5ca4aa399cc25fa8435280e8b03c5a3
+
+pkgname = neatx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..620333ef6484
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# $Id: PKGBUILD 276332 2017-12-28 05:13:56Z eschwartz $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Nicolas Doualot <packages@slubman.info>
+
+pkgname=neatx
+pkgver=0.3.1
+pkgrel=15
+pkgdesc="A free NX server by google"
+arch=('x86_64')
+url="https://code.google.com/archive/p/neatx/"
+license=('GPL')
+depends=('python2-pexpect' 'python2-simplejson' 'netcat' 'pygtk')
+makedepends=('docutils')
+optdepends=('xorg-xdm: if you want to use KDE or GNOME session'
+ 'xorg-fonts-misc: to use default font'
+ 'xterm: if you want console session')
+install=neatx.install
+source=(https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/neatx/$pkgname-$pkgver.tar.gz
+ constants.archlinux.patch)
+md5sums=('5748656738d5f04fef1af01b9fe5ef20'
+ 'a5ca4aa399cc25fa8435280e8b03c5a3')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -i "$srcdir/constants.archlinux.patch" -p2
+
+ ./configure --prefix=/usr --localstatedir=/var RST2HTML=/usr/bin/rst2html2
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+ chmod 777 "$pkgdir/var/lib/neatx/sessions"
+
+ install -d -m755 "$pkgdir"/etc/ld.so.conf.d/
+ echo -e '/usr/lib\n/opt/NX/lib' > "$pkgdir"/etc/ld.so.conf.d/neatx.conf
+}
diff --git a/constants.archlinux.patch b/constants.archlinux.patch
new file mode 100644
index 000000000000..dff5e24156c2
--- /dev/null
+++ b/constants.archlinux.patch
@@ -0,0 +1,42 @@
+--- a/neatx-0.3.1/lib/constants.py 2009-06-24 21:19:55.000000000 +0200
++++ b/neatx-0.3.1/lib/constants.py 2009-07-08 10:50:30.000000000 +0200
+@@ -25,19 +25,19 @@
+ from neatx import _autoconf
+
+
+-NXDIR = "/usr/lib/nx"
++NXDIR = "/opt/NX/bin"
+
+ SYSLOG_ADDRESS = "/dev/log"
+ BASH = "/bin/bash"
+-NETCAT = "/bin/netcat"
++NETCAT = "/usr/bin/netcat"
+ XRDB = "/usr/bin/xrdb"
+ SU = "/bin/su"
+ SSH = "/usr/bin/ssh"
+ XAUTH = "/usr/bin/xauth"
+-XSESSION = "/etc/X11/Xsession"
++XSESSION = "/etc/X11/xdm/Xsession"
+
+ START_CONSOLE_COMMAND = "/usr/bin/xterm"
+-START_KDE_COMMAND = XSESSION + " startkde"
++START_KDE_COMMAND = " startkde"
+ START_GNOME_COMMAND = XSESSION + " gnome-session"
+
+ NXUSER = "nx"
+@@ -47,12 +47,13 @@
+ NXNC = _autoconf.PKGLIBDIR + "/nxnc"
+ NXDIALOG = _autoconf.PKGLIBDIR + "/nxdialog"
+ NXAGENT = NXDIR + "/nxagent"
+-NXAGENT_PKGNAME = "nxagent"
++#NXAGENT_PKGNAME = "nxagent"
++NXAGENT_PKGNAME = "nxserver"
+ FDCOPY = _autoconf.PKGLIBDIR + "/fdcopy"
+ TTYSETUP = _autoconf.PKGLIBDIR + "/ttysetup"
+
+ # Extract nxagent version using the following command.
+-NXAGENT_VERSION_COMMAND = ("dpkg-query -W --showformat='${Version}' %s" %
++NXAGENT_VERSION_COMMAND = ("pacman -Qi %s | grep Version | awk '{print $3}'" %
+ NXAGENT_PKGNAME)
+ NXAGENT_VERSION_SEP = ".-~"
+
diff --git a/neatx.install b/neatx.install
new file mode 100644
index 000000000000..20f6d589b225
--- /dev/null
+++ b/neatx.install
@@ -0,0 +1,17 @@
+post_install() {
+ useradd -r -d /opt/NX/home/nx -s /usr/lib/neatx/nxserver-login-wrapper nx &> /dev/null
+ mkdir -p ~nx/.ssh
+ cp /usr/share/neatx/authorized_keys.nomachine ~nx/.ssh/authorized_keys
+ chmod 600 ~nx/.ssh/authorized_keys
+ chown -R nx ~nx
+ post_remove
+}
+
+pre_remove() {
+ rm -rf ~nx
+}
+
+post_remove() {
+ sed -e '/\/opt\/NX\/lib/d' -i etc/ld.so.conf
+ ldconfig
+}