summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaume Delclòs Coll2016-12-08 16:51:10 +0100
committerJaume Delclòs Coll2016-12-08 16:51:10 +0100
commitc0295ece7ed3a3bb84096c155cdb7ade37fc9078 (patch)
treeff951511df1155cb5d822626a507ecc6ac80098c
downloadaur-neet-git.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7d0ea288723
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = neet-git
+ pkgdesc = A script to easily play and manage your anime/drama/series
+ pkgver = r63.87d4719
+ pkgrel = 1
+ url = https://github.com/onodera-punpun/neet
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = fish
+ optdepends = mpv: default media player
+ provides = neet
+ conflicts = neet
+ source = neet::git+https://github.com/onodera-punpun/neet.git
+ md5sums = SKIP
+
+pkgname = neet-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9dcb0bc3884b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jaume Delclòs <jaume@delclos.com>
+pkgname=neet-git
+pkgver=r63.87d4719
+pkgrel=1
+pkgdesc="A script to easily play and manage your anime/drama/series"
+arch=(any)
+url="https://github.com/onodera-punpun/neet"
+license=('GPL')
+depends=(fish )
+makedepends=('git')
+optdepends=('mpv: default media player')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('neet::git+https://github.com/onodera-punpun/neet.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+}