summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvideah2017-11-14 04:40:26 +0000
committervideah2017-11-14 04:40:26 +0000
commitabe17171798d3979fd417c1004eff47536c3043d (patch)
tree077402fe8354e825cd1f4f7ac7a7aabedcb0e29a
downloadaur-abe17171798d3979fd417c1004eff47536c3043d.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
-rw-r--r--nekojishi.desktop9
-rw-r--r--nekojishi.install10
-rw-r--r--nekojishi.pngbin0 -> 54929 bytes
-rwxr-xr-xnekojishi.sh2
6 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c3cb933d4a1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = nekojishi
+ pkgdesc = A free furry/kemono visual novel
+ pkgver = 1.01
+ pkgrel = 1
+ url = https://nekojishi.tw/en-index.html
+ install = nekojishi.install
+ arch = any
+ license = custom:freeware
+ depends = sh
+ options = !strip
+ source = https://cdn.nekojishi.tw/Nekojishi_Standard1.01-pc.zip
+ source = nekojishi.sh
+ source = nekojishi.desktop
+ source = nekojishi.png
+ md5sums = 107768d7cc8a55c36c2b6635a03fb89c
+ md5sums = 049aca1f2158f12f3923e0da7a32bb60
+ md5sums = 852ba4bfcaff46021157f49529099720
+ md5sums = 9c553c00bdb9f1e97504b9f53fe678db
+
+pkgname = nekojishi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af2d4a9513ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: videah <videah at selfish dot systems>
+pkgname=nekojishi
+pkgver=1.01
+pkgdesc='A free furry/kemono visual novel'
+pkgrel=1
+arch=('any')
+url='https://nekojishi.tw/en-index.html'
+license=('custom:freeware')
+depends=('sh')
+install=${pkgname}.install
+options=(!strip)
+
+source=("https://cdn.nekojishi.tw/Nekojishi_Standard${pkgver}-pc.zip"
+ "${pkgname}.sh"
+ "${pkgname}.desktop"
+ "${pkgname}.png")
+
+md5sums=('107768d7cc8a55c36c2b6635a03fb89c'
+ '049aca1f2158f12f3923e0da7a32bb60'
+ '852ba4bfcaff46021157f49529099720'
+ '9c553c00bdb9f1e97504b9f53fe678db')
+
+package() {
+
+ # install game files
+ install -dm755 "${pkgdir}/usr/share/${pkgname}"
+ cp -r Nekojishi-pc/. "${pkgdir}/usr/share/${pkgname}"
+ install -m644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/${pkgname}/icon.png"
+
+ # copy sh
+ install -D -m755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+
+ # setup .desktop
+ install -D -m644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -D -m644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+
+}
diff --git a/nekojishi.desktop b/nekojishi.desktop
new file mode 100644
index 000000000000..d6240436324a
--- /dev/null
+++ b/nekojishi.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=1.01
+Name=Nekojishi
+Comment=A free furry/kemono visual novel
+Icon=nekojishi.png
+Exec=/usr/bin/nekojishi
+Terminal=false
+Categories=Application;Game;
diff --git a/nekojishi.install b/nekojishi.install
new file mode 100644
index 000000000000..ad99a8a3f917
--- /dev/null
+++ b/nekojishi.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo
+ echo "==> To launch game type:"
+ echo "==> nekojishi"
+ echo
+}
+
+post_upgrade() {
+ post_install $1
+}
diff --git a/nekojishi.png b/nekojishi.png
new file mode 100644
index 000000000000..8b22515323a1
--- /dev/null
+++ b/nekojishi.png
Binary files differ
diff --git a/nekojishi.sh b/nekojishi.sh
new file mode 100755
index 000000000000..1b8bb717a73f
--- /dev/null
+++ b/nekojishi.sh
@@ -0,0 +1,2 @@
+#!/usr/bin/env sh
+exec /usr/share/nekojishi/Nekojishi.sh