summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAyush Jha2022-03-08 18:54:58 +0545
committerAyush Jha2022-03-08 18:56:31 +0545
commitb5acd037bdc06ed3a09ac15f79ba27b9829f22d6 (patch)
treefaf8e2e974272cc9a456c3cb593ea7dc79af5d5a
downloadaur-b5acd037bdc06ed3a09ac15f79ba27b9829f22d6.tar.gz
starting project: nekuvi-git
changed srcinfo
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD48
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77e02fc0a384
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = nekuvi-git
+ pkgdesc = नेपाली कुन्जीपेटि विन्यास A better layout for Nepali Keyboards based for xkb system
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://gitlab.com/ayys/nekuvi
+ arch = any
+ license = GPL
+ depends = xkeyboard-config
+ source = https://gitlab.com/saprasorg/nekuvi/-/raw/master/install.sh
+ source = https://gitlab.com/saprasorg/nekuvi/-/raw/master/uninstall.sh
+ source = https://gitlab.com/saprasorg/nekuvi/-/raw/master/Makefile
+ source = https://gitlab.com/saprasorg/nekuvi/-/raw/master/level3_np
+ source = https://gitlab.com/saprasorg/nekuvi/-/raw/master/np
+ source = https://gitlab.com/saprasorg/nekuvi/-/raw/master/layout-evdev-install.hook
+ source = https://gitlab.com/saprasorg/nekuvi/-/raw/master/layout-evdev-remove.hook
+ sha256sums = 27bd5a76ef85a97a95248a5530446c3362064aab2146f8d7ceefdf8969a7a7c7
+ sha256sums = 0614ff1b4abd4fe0fb07cf95ebb60dee90180dadf19232b8e5fc94d75d67e555
+ sha256sums = aa67ed7c7c2bfdbce0b98789628f24efc5876708026a3e3c3e74125164a661ee
+ sha256sums = d5965a2ad14b8d9f6bed0bfdd37282dc1a67938577fa7fbe53d56be305583688
+ sha256sums = 819c86fecd6ec4a9ec57308fb00b13ffb040b238b29cf9564934d23692d4a917
+ sha256sums = 978abf768110916b04c10c3fd7690370b3e55d98090a5a411faf586ca8e48756
+ sha256sums = 3ec3ebb0324103f747b0e1ef7828664596b5db87ab82202a8213ed743025115b
+
+pkgname = nekuvi-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..226bb2779b90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Ayush Jha <ayushjha@pm.me>
+pkgname=nekuvi-git
+pkgver=0.1
+pkgrel=1
+epoch=
+pkgdesc="नेपाली कुन्जीपेटि विन्यास A better layout for Nepali Keyboards based for xkb system"
+arch=("any")
+url="https://gitlab.com/ayys/nekuvi"
+license=('GPL')
+groups=()
+depends=("xkeyboard-config")
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://gitlab.com/saprasorg/nekuvi/-/raw/master/install.sh" "https://gitlab.com/saprasorg/nekuvi/-/raw/master/uninstall.sh" "https://gitlab.com/saprasorg/nekuvi/-/raw/master/Makefile" "https://gitlab.com/saprasorg/nekuvi/-/raw/master/level3_np" "https://gitlab.com/saprasorg/nekuvi/-/raw/master/np" "https://gitlab.com/saprasorg/nekuvi/-/raw/master/layout-evdev-install.hook" "https://gitlab.com/saprasorg/nekuvi/-/raw/master/layout-evdev-remove.hook")
+sha256sums=('27bd5a76ef85a97a95248a5530446c3362064aab2146f8d7ceefdf8969a7a7c7'
+ '0614ff1b4abd4fe0fb07cf95ebb60dee90180dadf19232b8e5fc94d75d67e555'
+ 'aa67ed7c7c2bfdbce0b98789628f24efc5876708026a3e3c3e74125164a661ee'
+ 'd5965a2ad14b8d9f6bed0bfdd37282dc1a67938577fa7fbe53d56be305583688'
+ '819c86fecd6ec4a9ec57308fb00b13ffb040b238b29cf9564934d23692d4a917'
+ '978abf768110916b04c10c3fd7690370b3e55d98090a5a411faf586ca8e48756'
+ '3ec3ebb0324103f747b0e1ef7828664596b5db87ab82202a8213ed743025115b')
+
+
+noextract=()
+validpgpkeys=()
+
+package() {
+ set -euxo pipefail
+ echo $pkgdir
+
+ mkdir -p "$pkgdir"/usr/share/X11/xkb/symbols/
+ mkdir -p "$pkgdir"/usr/share/X11/xkb/rules/
+ cp level3_np "$pkgdir"/usr/share/X11/xkb/symbols/
+ cp np "$pkgdir"/usr/share/X11/xkb/symbols/np_prog
+
+ install -Dm 755 "${srcdir}"/install.sh "${pkgdir}/usr/share/libalpm/scripts/install-nekuvi-layout"
+ install -Dm 755 "${srcdir}"/uninstall.sh "${pkgdir}/usr/share/libalpm/scripts/uninstall-nekuvi-layout"
+ install -Dm 644 "${srcdir}"/layout-evdev-install.hook "${pkgdir}"/usr/share/libalpm/hooks/nekuvi-layout-evdev-install.hook
+ install -Dm 644 "${srcdir}"/layout-evdev-remove.hook "${pkgdir}"/usr/share/libalpm/hooks/nekuvi-layout-evdev-remove.hook
+}