summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-01-21 09:35:03 -0700
committerMark Wagie2024-01-21 09:35:03 -0700
commit38cdea9a776963db6e25eddc790af328e15cfce8 (patch)
tree055a40805d2246785e8fd481cfcdc1c28c0ae95e
parent119b6a21663ba8611229f934e38b25fc10ccf8b7 (diff)
downloadaur-nemo-ext-git-git.tar.gz
use SPDX license identifier
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 13 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 820ac47db7d2..5c6f92993207 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,18 +3,17 @@ pkgbase = nemo-ext-git-git
pkgver = 1.3.r16.g5389549
pkgrel = 6
url = https://github.com/bilelmoussaoui/nautilus-git
- arch = i686
arch = x86_64
- license = GPL3
+ license = GPL-3.0-or-later
makedepends = meson
depends = git
depends = gtk3
depends = gtksourceview3
depends = nemo-python
- provides = nemo-ext-git=1.3
- provides = nautilus-git=1.3
- conflicts = nemo-ext-git-1.3
- conflicts = nautilus-git=1.3
+ provides = nemo-ext-git
+ provides = nautilus-git
+ conflicts = nemo-ext-git
+ conflicts = nautilus-git
conflicts = nemo-folder-icons
source = nemo-ext-git::git+https://github.com/bilelmoussaoui/nautilus-git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ae8d78b5c2e6..5e1a2f73422c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,31 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=nemo-ext-git-git
pkgver=1.3.r16.g5389549
pkgrel=6
pkgdesc="Nemo extension to add important information about the current git directory"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://github.com/bilelmoussaoui/nautilus-git"
-license=('GPL3')
+license=('GPL-3.0-or-later')
depends=('git' 'gtk3' 'gtksourceview3' 'nemo-python')
makedepends=('meson')
-provides=("${pkgname%-git}=1.3" 'nautilus-git=1.3')
-conflicts=("${pkgname%-git}-1.3" 'nautilus-git=1.3' 'nemo-folder-icons')
+provides=("${pkgname%-git}" 'nautilus-git')
+conflicts=("${pkgname%-git}" 'nautilus-git' 'nemo-folder-icons')
# See https://github.com/bilelmoussaoui/nautilus-folder-icons/issues/34
source=("${pkgname%-git}::git+https://github.com/bilelmoussaoui/nautilus-git")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
# Disable post_install, not available in meson-options
sed -i '37,38d' meson.build
+ # Use Python 3
find . -type f -exec sed -i 's|python2|python|g' {} \;
}
@@ -33,11 +34,6 @@ build() {
meson compile -C build
}
-# No tests defined
-#check() {
-# meson test -C build --print-errorlogs
-#}
-
package() {
meson install -C build --destdir "$pkgdir"
}