summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-12-24 13:01:21 -0700
committeryochananmarqos2019-12-24 13:01:21 -0700
commit83c1077e1f1add716e66a088d25dd0e99546fb98 (patch)
tree74cbf8eb9b7ea050eeaabe610a23e7dbe98d0f9a
parent219d68a0163b68dd91e19758be83084a6d2ba880 (diff)
downloadaur-83c1077e1f1add716e66a088d25dd0e99546fb98.tar.gz
disable post_install
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb3395c77ad3..ab3a5b713ee2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nemo-ext-git-git
pkgdesc = Nemo extension to add important information about the current git directory
pkgver = 1.3.r16.g5389549
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/bilelmoussaoui/nautilus-git
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 25f7e1da0007..f12be0ec2921 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=nemo-ext-git-git
pkgver=1.3.r16.g5389549
-pkgrel=1
+pkgrel=2
pkgdesc="Nemo extension to add important information about the current git directory"
arch=('i686' 'x86_64')
url="https://github.com/bilelmoussaoui/nautilus-git"
@@ -13,6 +13,13 @@ conflicts=("${pkgname%-git}" 'nemo-git=1.3')
source=("${pkgname%-git}::git+https://github.com/bilelmoussaoui/nautilus-git")
sha256sums=('SKIP')
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+
+ # Disable post_install, not available in meson-options
+ sed -i '37,38d' meson.build
+}
+
pkgver() {
cd "$srcdir/${pkgname%-git}"
printf "%s" "$(git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g')"
@@ -20,7 +27,7 @@ pkgver() {
build() {
cd "$srcdir/${pkgname%-git}"
- arch-meson builddir -Dpost_install=false -Dfile_manager=nemo
+ arch-meson builddir -Dfile_manager=nemo
ninja -C builddir
}