summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-07-21 08:22:03 -0600
committeryochananmarqos2019-07-21 08:22:03 -0600
commit36394bcb3fa8c36f8dfdfc1f93d0ab24b5d7b8a4 (patch)
treea6e369e9444b075b7ca25e7918ece3f81549bc7b
downloadaur-36394bcb3fa8c36f8dfdfc1f93d0ab24b5d7b8a4.tar.gz
split from nautilus-folder-icons pkgbase
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD24
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed1ba8d78a20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = nemo-folder-icons
+ pkgdesc = Nemo extension that makes changing folders icons easy!
+ pkgver = 3.0
+ pkgrel = 2
+ url = https://github.com/bilelmoussaoui/nautilus-folder-icons
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = gnome-common
+ makedepends = meson
+ makedepends = appstream-glib
+ depends = gobject-introspection
+ depends = gtk3
+ depends = nemo-python
+ options = !emptydirs
+ source = nemo-folder-icons-3.0.tar.gz::https://github.com/bil-elmoussaoui/nautilus-folder-icons/archive/3.0.tar.gz
+ sha256sums = 25fa6f164f50ed84ee6fa6d7a6004cb5190051847a5c3895f41bf1b426ad2565
+
+pkgname = nemo-folder-icons
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ca431f6b837
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
+# Contributor: ELmoussaoui Bilal <bil dot elmoussaoui at gmail.com>
+pkgname=nemo-folder-icons
+pkgver=3.0
+pkgrel=2
+pkgdesc='Nemo extension that makes changing folders icons easy!'
+arch=('i686' 'x86_64')
+license=('GPL3')
+url="https://github.com/bilelmoussaoui/nautilus-folder-icons"
+depends=('gobject-introspection' 'gtk3' 'nemo-python')
+makedepends=('gnome-common' 'meson' 'appstream-glib')
+options=('!emptydirs')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/bil-elmoussaoui/nautilus-folder-icons/archive/$pkgver.tar.gz")
+sha256sums=('25fa6f164f50ed84ee6fa6d7a6004cb5190051847a5c3895f41bf1b426ad2565')
+
+build() {
+ cd "nautilus-folder-icons-$pkgver"
+ meson builddir --prefix=/usr -Dfile_manager=nemo
+}
+
+package() {
+ cd "nautilus-folder-icons-$pkgver"
+ DESTDIR="$pkgdir" ninja -C builddir install
+}