summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-07-11 17:34:39 -0600
committerMark Wagie2020-07-11 17:34:39 -0600
commit4cddfb8fbdf2a18d83a398061f9dcbed70d6d981 (patch)
tree705d3ed02ad424d7d453f2e31d6721d6e52b724b
parent1043d26cb1dbe61cde410f2a0fb2c336b7b357bb (diff)
downloadaur-4cddfb8fbdf2a18d83a398061f9dcbed70d6d981.tar.gz
adjust conflicts()
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
2 files changed, 7 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a15063becb94..d6e65ac3db6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nemo-folder-icons
pkgdesc = Nemo extension that makes changing folders icons easy!
pkgver = 3.0
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/bilelmoussaoui/nautilus-folder-icons
arch = i686
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = nemo-folder-icons
depends = gtk3
depends = nemo-python
conflicts = nemo-ext-git
- options = !emptydirs
+ conflicts = nemo-compare
source = nemo-folder-icons-3.0.tar.gz::https://github.com/bilelmoussaoui/nautilus-folder-icons/archive/3.0.tar.gz
sha256sums = 25fa6f164f50ed84ee6fa6d7a6004cb5190051847a5c3895f41bf1b426ad2565
diff --git a/PKGBUILD b/PKGBUILD
index 8ca299224d32..e7ef6971a458 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,15 @@
pkgname=nemo-folder-icons
_gitname=nautilus-folder-icons
pkgver=3.0
-pkgrel=6
+pkgrel=7
pkgdesc='Nemo extension that makes changing folders icons easy!'
arch=('i686' 'x86_64')
license=('GPL3')
url="https://github.com/bilelmoussaoui/nautilus-folder-icons"
depends=('gobject-introspection' 'gtk3' 'nemo-python')
makedepends=('gnome-common' 'meson')
-#checkdepends=('appstream')
-conflicts=('nemo-ext-git')
+conflicts=('nemo-ext-git' 'nemo-compare')
# See https://github.com/bilelmoussaoui/nautilus-folder-icons/issues/34
-options=('!emptydirs')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha256sums=('25fa6f164f50ed84ee6fa6d7a6004cb5190051847a5c3895f41bf1b426ad2565')
@@ -23,17 +21,10 @@ prepare() {
}
build() {
- cd "$_gitname-$pkgver"
- arch-meson builddir -Dfile_manager=nemo
- ninja -C builddir
+ arch-meson "$_gitname-$pkgver" build -Dfile_manager=nemo
+ meson compile -C build
}
-#check() {
-# cd "$pkgname-$pkgver"
-# ninja test -C builddir
-#}
-
package() {
- cd "$_gitname-$pkgver"
- DESTDIR="$pkgdir" ninja -C builddir install
+ DESTDIR="$pkgdir" meson install -C build
}