summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2020-01-21 19:58:21 -0700
committeryochananmarqos2020-01-21 19:58:21 -0700
commitee73d83e8d800ed023f0c41c891bf8e8fd5608d2 (patch)
tree08d833cbf838244f786da4c980b43dfbf5d752a2
parentb5dae2f65a4a6da5fc59dde1283c8a345843c8df (diff)
downloadaur-ee73d83e8d800ed023f0c41c891bf8e8fd5608d2.tar.gz
build adjustment, PKGBUILD tweaks
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40bafc0bb74c..6eb504cdceb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nemo-folder-icons
pkgdesc = Nemo extension that makes changing folders icons easy!
pkgver = 3.0
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/bilelmoussaoui/nautilus-folder-icons
arch = i686
arch = x86_64
@@ -13,7 +13,7 @@ pkgbase = nemo-folder-icons
depends = gtk3
depends = nemo-python
options = !emptydirs
- source = nemo-folder-icons-3.0.tar.gz::https://github.com/bil-elmoussaoui/nautilus-folder-icons/archive/3.0.tar.gz
+ source = nemo-folder-icons-3.0.tar.gz::https://github.com/bilelmoussaoui/nautilus-folder-icons/archive/3.0.tar.gz
sha256sums = 25fa6f164f50ed84ee6fa6d7a6004cb5190051847a5c3895f41bf1b426ad2565
pkgname = nemo-folder-icons
diff --git a/PKGBUILD b/PKGBUILD
index 1702ac908f28..073d877dd520 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: ELmoussaoui Bilal <bil dot elmoussaoui at gmail.com>
pkgname=nemo-folder-icons
+_gitname=nautilus-folder-icons
pkgver=3.0
-pkgrel=4
+pkgrel=5
pkgdesc='Nemo extension that makes changing folders icons easy!'
arch=('i686' 'x86_64')
license=('GPL3')
@@ -10,20 +11,21 @@ url="https://github.com/bilelmoussaoui/nautilus-folder-icons"
depends=('gobject-introspection' 'gtk3' 'nemo-python')
makedepends=('gnome-common' 'meson' 'appstream-glib')
options=('!emptydirs')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/bil-elmoussaoui/nautilus-folder-icons/archive/$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha256sums=('25fa6f164f50ed84ee6fa6d7a6004cb5190051847a5c3895f41bf1b426ad2565')
prepare() {
- cd "nautilus-folder-icons-$pkgver"
- find . -type f -exec sed -i 's%#!/usr/bin/python2%#!/usr/bin/python%g' {} \;
+ cd "$_gitname-$pkgver"
+ find . -type f -exec sed -i 's|#!/usr/bin/python2|#!/usr/bin/python|g' {} \;
}
build() {
- cd "nautilus-folder-icons-$pkgver"
+ cd "$_gitname-$pkgver"
arch-meson builddir -Dfile_manager=nemo
+ ninja -C builddir
}
package() {
- cd "nautilus-folder-icons-$pkgver"
+ cd "$_gitname-$pkgver"
DESTDIR="$pkgdir" ninja -C builddir install
}