summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPival812016-07-22 16:42:55 +0200
committerPival812016-07-22 16:42:55 +0200
commitd58efbb182f34070e06c83d935ac44a6dd101e40 (patch)
tree084d6523566f86e25ebe6736494fb1258235f344
parentca0358f2ba4d1c0d80311ee0188b3584685670c8 (diff)
downloadaur-d58efbb182f34070e06c83d935ac44a6dd101e40.tar.gz
yet another commit
-rw-r--r--PKGBUILD38
-rw-r--r--nemo-megasync.install22
2 files changed, 47 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e58acb3ad59..bc103242c17e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,33 @@
pkgname=nemo-megasync
-pkgver=1.0.29
+pkgver=2.9.2
pkgrel=1
pkgdesc="MEGASync extension for the Nemo file browser"
arch=('x86_64' 'i686')
-url="http://www.webupd8.org/2014/09/unofficial-megasync-nemo-extension.html"
+url="https://github.com/Pival81/nemo-megasync"
license=('custom')
depends=('nemo' 'megasync')
-if [ "$CARCH" = "x86_64" ]; then
- source=(https://github.com/hotice/webupd8/raw/master/nemo-megasync_${pkgver}-0~webupd8~0_amd64.deb)
- md5sums=('89f4ac0edbc2118f5c543c10d40a3327')
-else
- source=(https://github.com/hotice/webupd8/raw/master/nemo-megasync_${pkgver}-0~webupd8~0_i386.deb)
- md5sums=('a8a16be4c6572e33870e34d2d87c1f16')
-fi
+install=nemo-megasync.install
+source=("https://github.com/Pival81/nemo-megasync/archive/2.9.2.tar.gz")
+md5sums=("bb98b774bd1871ac1baaeeaa7edb6d1b")
-package()
-{
- msg "Extracting"
- tar -xf ${srcdir}/data.tar.xz -C ${pkgdir}
+prepare() {
+ export DESKTOP_DESTDIR=$pkgdir/usr
+}
+
+build() {
+ cd nemo-megasync-2.9.2
+ qmake-qt4
+ make
+}
+
+package() {
+ cd nemo-megasync-2.9.2
+ make install
+ mkdir -p $pkgdir/usr/lib/nemo/extensions-3.0
+ install libMEGAShellExtNemo.so.1.0.0 -D $pkgdir/usr/lib/nemo/extensions-3.0/
+ cd $pkgdir/usr/lib/nemo/extensions-3.0/
+ ln -s libMEGAShellExtNemo.so.1.0.0 libMEGAShellExtNemo.so
+ ln -s libMEGAShellExtNemo.so.1.0.0 libMEGAShellExtNemo.so.1
+ ln -s libMEGAShellExtNemo.so.1.0.0 libMEGAShellExtNemo.so.1.0
+ rm -fr $pkgdir/usr/share/icons/hicolor/icon-theme.cache
}
diff --git a/nemo-megasync.install b/nemo-megasync.install
new file mode 100644
index 000000000000..fe5169f95972
--- /dev/null
+++ b/nemo-megasync.install
@@ -0,0 +1,22 @@
+
+post_install() {
+ UPDATENOTIFIERDIR=/var/lib/update-notifier/user.d
+echo "Please restart all running instances of Nemo."
+
+if [ -d $UPDATENOTIFIERDIR ] ; then
+ cat > $UPDATENOTIFIERDIR/megasync-install-notify <<DATA
+Name: Nemo Restart Required
+Priority: High
+Terminal: False
+Command: nemo -q
+DontShowAfterReboot: True
+ButtonText: _Restart Nemo
+DisplayIf: pgrep -x nemo -U \$(id -u) > /dev/null
+OnlyAdminUsers: False
+Description:
+ MEGAsync requires Nemo to be restarted to function properly.
+DATA
+fi
+}
+
+