summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2018-11-04 20:10:52 -0500
committerTed Alff2018-11-04 20:10:52 -0500
commitbf6253337cd2a53f97039e11f333893b08b3b947 (patch)
tree99b35056f28df7d551a4ca0c9bdf5fd94ecef4ce
parent0c46b586ecee4a2277180b2247ea8e803fad74d4 (diff)
downloadaur-bf6253337cd2a53f97039e11f333893b08b3b947.tar.gz
Version bump 4.0.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 14 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04b70e614fc0..44d5141123da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
# Generated by mksrcinfo v8
-# Wed May 9 00:11:30 UTC 2018
+# Mon Nov 5 01:10:43 UTC 2018
pkgbase = nemo-pastebin
pkgdesc = Pastebin upload context menu in Nemo
- pkgver = 3.8.0
+ pkgver = 4.0.0
pkgrel = 1
url = https://github.com/linuxmint/nemo-extensions
arch = any
license = GPL2
- makedepends = python2-distutils-extra
- depends = nemo-python
+ makedepends = python-distutils-extra
depends = pastebinit
- depends = libnotify
+ depends = nemo-python>=3.9.0
+ optdepends = libnotify
options = !emptydirs
- source = nemo-extensions-3.8.0.tar.gz::https://github.com/linuxmint/nemo-extensions/archive/3.8.0.tar.gz
- sha256sums = 15855cf7880290c8e9956f894d8e3c6fb0bee996783b2af63ae66dc019e739a8
+ source = nemo-extensions-4.0.0.tar.gz::https://github.com/linuxmint/nemo-extensions/archive/4.0.0.tar.gz
+ sha256sums = 4bee7336554fd3c6e87371bc4683e5bee989a67030582b89a050aad5874a04de
pkgname = nemo-pastebin
diff --git a/PKGBUILD b/PKGBUILD
index 1550012ae9a4..884f864aeae5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,25 @@
# Maintainer: twa022 <twa022 at gmail dot com>
pkgname='nemo-pastebin'
-pkgver=3.8.0
+pkgver=4.0.0
_mintrel='betsy'
pkgrel=1
pkgdesc="Pastebin upload context menu in Nemo"
arch=('any')
license=('GPL2')
url="https://github.com/linuxmint/nemo-extensions"
-depends=('nemo-python' 'pastebinit' 'libnotify')
-makedepends=('python2-distutils-extra')
+depends=('pastebinit' 'nemo-python>=3.9.0')
+optdepends=('libnotify')
+makedepends=('python-distutils-extra')
options=('!emptydirs')
#source=("${pkgname}-${pkgver}.tar.gz::http://packages.linuxmint.com/pool/main/${pkgname:0:1}/${pkgname}/${pkgname}_${pkgver}.tar.gz")
source=("nemo-extensions-$pkgver.tar.gz::https://github.com/linuxmint/nemo-extensions/archive/$pkgver.tar.gz")
-sha256sums=('15855cf7880290c8e9956f894d8e3c6fb0bee996783b2af63ae66dc019e739a8')
-
-prepare() {
- #cd ${pkgname}-${pkgver}+${_mintrel}
- cd "${srcdir}/nemo-extensions-${pkgver}/${pkgname}"
-
- # Python2 fix
- find -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
-}
+sha256sums=('4bee7336554fd3c6e87371bc4683e5bee989a67030582b89a050aad5874a04de')
package() {
#cd ${pkgname}-${pkgver}+${_mintrel}
cd "${srcdir}/nemo-extensions-${pkgver}/${pkgname}"
- python2 ./setup.py install --prefix=/usr --root=${pkgdir}
-
- # The setup script is doing some weird stuff...
- mv "${pkgdir}"/usr/bin/nemo-pastebin{.py,-configurator.py} "${pkgdir}/usr/share/${pkgname}/"
-
- cd "${pkgdir}"/usr/bin/
- ln -s ../share/"${pkgname}"/nemo-pastebin-configurator.py nemo-pastebin-configurator
-
- mkdir -p "${pkgdir}"/usr/share/nemo-python/extensions
-
- cd "${pkgdir}"/usr/share/nemo-python/extensions
- ln -s ../../"${pkgname}"/nemo-pastebin.py .
+ python ./setup.py install --prefix=/usr --root="${pkgdir}" \
+ --no-compile -O0
}