summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2023-05-05 20:42:37 -0400
committeréclairevoyant2023-05-05 20:42:37 -0400
commit156ac98a8e95ae6a776e0335558fbb9e0010f208 (patch)
tree7e44cbf4eeb9b518e81d7fb39ade9ff42a89199b
parentfb74da7fbf1db36f59827c6bbe53e917fd2eb52f (diff)
downloadaur-156ac98a8e95ae6a776e0335558fbb9e0010f208.tar.gz
nemo-qml-plugin-dbus: upgpkg 2.1.32; fix source, license
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD19
3 files changed, 17 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1708eaccb5cb..7a3e5fcc5e46 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = nemo-qml-plugin-dbus
pkgdesc = Provides types to access D-Bus from QML
- pkgver = 2.1.28
+ pkgver = 2.1.32
pkgrel = 1
url = https://github.com/sailfishos/nemo-qml-plugin-dbus
arch = x86_64
arch = aarch64
- license = LGPL-2.1-only
- depends = qt5-base
+ license = LGPL2.1
depends = qt5-declarative
- source = https://github.com/sailfishos/nemo-qml-plugin-dbus/archive/refs/tags/2.1.28.tar.gz
- sha256sums = 7b93a5d2a537bd5a2afec48cb3877ee7f690e09667a940261e663a5ca7b3f858
+ source = nemo-qml-plugin-dbus-2.1.32.tar.gz::https://github.com/sailfishos/nemo-qml-plugin-dbus/archive/refs/tags/2.1.32.tar.gz
+ b2sums = 86d581de452d2abf749e7e81de2ec154c2fc4f0a130954915acdb75fd4cf45403ef1c70928d68ad0e567b5cdca97c78333d29d1f8220ae32e8d378ee580a7b36
pkgname = nemo-qml-plugin-dbus
diff --git a/.gitignore b/.gitignore
index 9267f0a6a7fa..713f6f80aff8 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-*.pkg.*
-*.tar.gz
-/pkg
-/src
+/*
+!/.gitignore
+!/.SRCINFO
+!/PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 4a0a15f9d2c1..12939cb2882f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,20 @@
pkgname=nemo-qml-plugin-dbus
-pkgver=2.1.28
+pkgver=2.1.32
pkgrel=1
pkgdesc="Provides types to access D-Bus from QML"
-url="https://github.com/sailfishos/nemo-qml-plugin-dbus"
-arch=("x86_64" "aarch64")
-source=("https://github.com/sailfishos/nemo-qml-plugin-dbus/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=('7b93a5d2a537bd5a2afec48cb3877ee7f690e09667a940261e663a5ca7b3f858')
-depends=("qt5-base" "qt5-declarative")
-license=("LGPL-2.1-only")
+arch=(x86_64 aarch64)
+url="https://github.com/sailfishos/$pkgname"
+license=(LGPL2.1)
+depends=(qt5-declarative)
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
+b2sums=('86d581de452d2abf749e7e81de2ec154c2fc4f0a130954915acdb75fd4cf45403ef1c70928d68ad0e567b5cdca97c78333d29d1f8220ae32e8d378ee580a7b36')
build() {
- cd "$pkgname-$pkgver"
+ cd $pkgname-$pkgver
qmake src
make
}
package() {
- cd "$pkgname-$pkgver"
- make INSTALL_ROOT="$pkgdir/" install
+ make -C $pkgname-$pkgver INSTALL_ROOT="$pkgdir" install
}