summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcel Campello Ferreira2015-12-26 22:13:12 -0200
committerMarcel Campello Ferreira2015-12-26 22:13:12 -0200
commit074c178d52e11a41763b6144b3e5e68ab93cb086 (patch)
tree33e18a194b33830a06c865cd948cd50b4770afc5
parent3489738c8284e1639e9896bc577ed996f956251c (diff)
downloadaur-074c178d52e11a41763b6144b3e5e68ab93cb086.tar.gz
Version 2.1.3-1.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD58
-rw-r--r--bin.patch156
-rw-r--r--conf.patch75
4 files changed, 140 insertions, 163 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df271722d44e..fbaf101c2f05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sun Dec 27 00:03:52 UTC 2015
pkgbase = neo4j
pkgdesc = A fully transactional graph database implemented in Java
- pkgver = 2.2.1
+ pkgver = 2.3.1
pkgrel = 1
url = http://neo4j.org/
install = neo4j.install
@@ -11,21 +13,19 @@ pkgbase = neo4j
depends = lsof
depends = java-runtime-headless
options = !strip
- backup = etc/neo4j/custom-logback.xml
- backup = etc/neo4j/logging.properties
backup = etc/neo4j/neo4j-http-logging.xml
backup = etc/neo4j/neo4j-server.properties
backup = etc/neo4j/neo4j-wrapper.conf
backup = etc/neo4j/neo4j.properties
- source = http://dist.neo4j.org/neo4j-community-2.2.1-unix.tar.gz
+ source = http://dist.neo4j.org/neo4j-community-2.3.1-unix.tar.gz
source = bin.patch
source = conf.patch
source = neo4j.install
source = neo4j.service
source = neo4j-tmpfile.conf
- sha256sums = a5116c47a2fb2a209ba6a381e57b580fe6e912e8835edb32dbf66d9b16b3d367
- sha256sums = d161c1b0397843a78c16cf06f3087ca52f01efb300749874d52013fde87d26f8
- sha256sums = bb9ea8ae8a684e9981a24ca7bb242a4c2aaa8fdacb820abf8da7f56f413d1e5f
+ sha256sums = 7b2f30d73af107eacd9a3a619475ef448a08eecb2cdb42ab1f8a38d091c70ecb
+ sha256sums = 14d7f2046f0333b99c6b689c8aaa2f67d89d4a5fcfed34cb1c72ecf5e074aa6d
+ sha256sums = 8182f2717a1fb887413fad592e4ba298e7a0a5ec31092220ca68af22b2a5c4bd
sha256sums = 3c4f3daea1623a5bc4c56d87ff4d76ff4737722eb730e2f9b65a0980bf3633a3
sha256sums = ee451a5b4ac3f733ab725bb3babeefc4d852115fe24ee29a3060922716212ad7
sha256sums = e9ecbf86072ca92129ab1889b5f91e2494b86e84248bd15a37681a3997892d7d
diff --git a/PKGBUILD b/PKGBUILD
index 9e086f1da342..e75f171057e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Marcel Campello Ferreira <marcel@prafrentex.com.br>
pkgname=neo4j
-pkgver=2.2.1
+pkgver=2.3.1
pkgrel=1
pkgdesc="A fully transactional graph database implemented in Java"
arch=(any)
@@ -8,9 +8,7 @@ url="http://neo4j.org/"
license=(GPL)
makedepends=(patch)
depends=(bash lsof java-runtime-headless)
-backup=(etc/neo4j/custom-logback.xml
- etc/neo4j/logging.properties
- etc/neo4j/neo4j-http-logging.xml
+backup=(etc/neo4j/neo4j-http-logging.xml
etc/neo4j/neo4j-server.properties
etc/neo4j/neo4j-wrapper.conf
etc/neo4j/neo4j.properties)
@@ -22,9 +20,9 @@ source=(http://dist.neo4j.org/neo4j-community-$pkgver-unix.tar.gz
neo4j.install
neo4j.service
neo4j-tmpfile.conf)
-sha256sums=('a5116c47a2fb2a209ba6a381e57b580fe6e912e8835edb32dbf66d9b16b3d367'
- 'd161c1b0397843a78c16cf06f3087ca52f01efb300749874d52013fde87d26f8'
- 'bb9ea8ae8a684e9981a24ca7bb242a4c2aaa8fdacb820abf8da7f56f413d1e5f'
+sha256sums=('7b2f30d73af107eacd9a3a619475ef448a08eecb2cdb42ab1f8a38d091c70ecb'
+ '14d7f2046f0333b99c6b689c8aaa2f67d89d4a5fcfed34cb1c72ecf5e074aa6d'
+ '8182f2717a1fb887413fad592e4ba298e7a0a5ec31092220ca68af22b2a5c4bd'
'3c4f3daea1623a5bc4c56d87ff4d76ff4737722eb730e2f9b65a0980bf3633a3'
'ee451a5b4ac3f733ab725bb3babeefc4d852115fe24ee29a3060922716212ad7'
'e9ecbf86072ca92129ab1889b5f91e2494b86e84248bd15a37681a3997892d7d')
@@ -33,8 +31,8 @@ prepare() {
cd $srcdir/neo4j-community-$pkgver
- rm conf/windows-wrapper-logging.properties
rm bin/neo4j-installer
+ rm -rf bin/Neo4j-Management
rm -rf system/resources
# Adjust configuration to match new directory structure
@@ -44,32 +42,46 @@ prepare() {
package() {
+ NEO4J_HOME=usr/share/java/neo4j
+ NEO4J_INSTANCE=var/lib/neo4j
+ NEO4J_CONFIG=etc/neo4j
+ NEO4J_LOG=var/log/neo4j
+ NEO4J_SHARE=usr/share/neo4j
+ NEO4J_RUNDIR=run/neo4j
+ NEO4J_PIDFILE=${NEO4J_RUNDIR}/neo4j-service.pid
+
cd $srcdir/neo4j-community-$pkgver
# Config files
- install -dm755 $pkgdir/etc/neo4j
- cp -r conf/* $pkgdir/etc/neo4j
+ install -dm755 $pkgdir/$NEO4J_CONFIG
+ cp -r conf/* $pkgdir/$NEO4J_CONFIG
# Copy JARs in lib, system and plugins
- install -dm755 $pkgdir/usr/share/java/neo4j
- cp -r lib/* $pkgdir/usr/share/java/neo4j
- install -dm755 $pkgdir/usr/share/java/neo4j/system
- cp -r system/* $pkgdir/usr/share/java/neo4j/system
- install -dm755 $pkgdir/usr/share/java/neo4j/plugins
- cp -r plugins/* $pkgdir/usr/share/java/neo4j/plugins
+ install -dm755 $pkgdir/$NEO4J_HOME
+ cp -r lib/* $pkgdir/$NEO4J_HOME
+
+ install -dm755 $pkgdir/$NEO4J_HOME/system
+ cp -r system/* $pkgdir/$NEO4J_HOME/system
+
+ install -dm755 $pkgdir/$NEO4J_HOME/plugins
+ cp -r plugins/* $pkgdir/$NEO4J_HOME/plugins
# Executable files
- install -dm755 $pkgdir/usr/share/neo4j/bin
- cp -r bin/* $pkgdir/usr/share/neo4j/bin
+ install -dm755 $pkgdir/$NEO4J_SHARE/bin
+ cp -r bin/* $pkgdir/$NEO4J_SHARE/bin
install -dm755 $pkgdir/usr/bin
- ln -s /usr/share/neo4j/bin/neo4j $pkgdir/usr/bin/neo4j
- ln -s /usr/share/neo4j/bin/neo4j-shell $pkgdir/usr/bin/neo4j-shell
- ln -s /usr/share/neo4j/bin/neo4j-import $pkgdir/usr/bin/neo4j-import
+ ln -s /$NEO4J_SHARE/bin/neo4j $pkgdir/usr/bin/neo4j
+ ln -s /$NEO4J_SHARE/bin/neo4j-import $pkgdir/usr/bin/neo4j-import
+ ln -s /$NEO4J_SHARE/bin/neo4j-shell $pkgdir/usr/bin/neo4j-shell
# Data and log files
- install -dm755 $pkgdir/var/lib/neo4j/data
- install -dm755 $pkgdir/var/log/neo4j
+ install -dm755 $pkgdir/$NEO4J_LOG
+ cp -r data/log/* $pkgdir/$NEO4J_LOG
+
+ install -dm755 $pkgdir/$NEO4J_INSTANCE/data
+ rm -rf data/log
+ cp -r data/* $pkgdir/$NEO4J_INSTANCE/data
# Documentation
install -dm755 $pkgdir/usr/share/doc/neo4j
diff --git a/bin.patch b/bin.patch
index 1b0ca10873b8..0e7923515434 100644
--- a/bin.patch
+++ b/bin.patch
@@ -1,7 +1,7 @@
-diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/bin/neo4j neo4j-community-2.2.0-mod/bin/neo4j
---- neo4j-community-2.2.0-orig/bin/neo4j 2015-03-24 09:59:49.000000000 -0300
-+++ neo4j-community-2.2.0-mod/bin/neo4j 2015-03-31 10:50:57.546565829 -0300
-@@ -33,23 +33,12 @@
+diff -U 3 -H -d -r -N -- neo4j-community-2.3.1-orig/bin/neo4j neo4j-community-2.3.1-mod/bin/neo4j
+--- neo4j-community-2.3.1-orig/bin/neo4j 2015-11-10 10:15:38.000000000 -0200
++++ neo4j-community-2.3.1-mod/bin/neo4j 2015-12-26 21:48:05.787841796 -0200
+@@ -33,24 +33,13 @@
LAUNCHD_NAME="org.neo4j.server"
function findBaseDirAndCdThere {
@@ -20,18 +20,20 @@ diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/bin/neo4j neo4j-community-2.
- done
- NEO4J_HOME=`cd $( dirname "$SCRIPT" )/.. && dirs -l +0`
- NEO4J_INSTANCE=$NEO4J_HOME
-- NEO4J_CONFIG=$NEO4J_INSTANCE/conf
-- NEO4J_LOG=$NEO4J_INSTANCE/data/log
+- [ -n "$NEO4J_CONFIG" ] || NEO4J_CONFIG=$NEO4J_HOME/conf
+- [ -n "$NEO4J_LOG" ] || NEO4J_LOG=$NEO4J_HOME/data/log
+- [ -n "$NEO4J_PIDFILE" ] || NEO4J_PIDFILE=$NEO4J_HOME/data/neo4j-service.pid
+ NEO4J_HOME=/usr/share/java/neo4j
-+ NEO4J_INSTANCE=/var/lib/neo4j
++ NEO4J_SHARE=/usr/share/neo4j
+ NEO4J_CONFIG=/etc/neo4j
++ NEO4J_INSTANCE=/var/lib/neo4j
+ NEO4J_LOG=/var/log/neo4j
-+ NEO4J_SHARE=/usr/share/neo4j
+ NEO4J_RUNDIR=/run/neo4j
++ NEO4J_PIDFILE=${NEO4J_RUNDIR}/neo4j-service.pid
cd "$NEO4J_HOME"
}
-@@ -67,14 +56,14 @@
+@@ -68,7 +57,7 @@
}
findBaseDirAndCdThere
@@ -40,15 +42,7 @@ diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/bin/neo4j neo4j-community-2.
parseConfig
JAVA_OPTS="-server -XX:+DisableExplicitGC ${wrapper_java_additional}"
- [ -z "${wrapper_java_initmemory}" ] || JAVA_OPTS="$JAVA_OPTS -Xms${wrapper_java_initmemory}m"
- [ -z "${wrapper_java_maxmemory}" ] || JAVA_OPTS="$JAVA_OPTS -Xmx${wrapper_java_maxmemory}m"
-
--#NEO4J_SERVER_PORT=`( egrep "^org.neo4j.server.webserver.port" $NEO4J_INSTANCE/conf/neo4j-server.properties || echo 7474 ) | sed -e 's/.*=//'`
-+#NEO4J_SERVER_PORT=`( egrep "^org.neo4j.server.webserver.port" $NEO4J_CONFIG/neo4j-server.properties || echo 7474 ) | sed -e 's/.*=//'`
- NEO4J_SERVER_PORT=${org_neo4j_server_webserver_port:=7474}
-
- LAUNCHD_NAME="${LAUNCHD_NAME}.${NEO4J_SERVER_PORT}"
-@@ -90,16 +79,16 @@
+@@ -91,7 +80,7 @@
# Username to propose for neo4j user, can be overridden by -u USERNAME option
DEFAULT_USER='neo4j'
@@ -57,10 +51,8 @@ diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/bin/neo4j neo4j-community-2.
SERVICE_NAME=${wrapper_ntservice_name:=neo4j-service}
LAUNCHD_DIR=~/Library/LaunchAgents/
- TIMEOUT=120
-
--PID_FILE=${NEO4J_INSTANCE}/data/neo4j-service.pid
-+PID_FILE=${NEO4J_RUNDIR}/neo4j-service.pid
+@@ -100,7 +89,7 @@
+ PID_FILE=${NEO4J_PIDFILE}
buildclasspath() {
# confirm library jars
- LIBDIR="$NEO4J_HOME"/lib
@@ -68,87 +60,69 @@ diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/bin/neo4j neo4j-community-2.
if [ ! -e "$LIBDIR" ] ; then
echo "Error: missing Neo4j Library, expected at $LIBDIR"
exit 1
-@@ -134,7 +123,7 @@
- CLASSPATH=${ALL_JARS}
-
- # add useful conf stuff to classpath - always a good idea
-- CLASSPATH="$CLASSPATH":"$NEO4J_HOME"/conf/
-+ CLASSPATH="$CLASSPATH":"$NEO4J_CONFIG"
- }
-
- detectrunning() {
-@@ -144,7 +133,7 @@
- else
- ## This could be achieved with filtering using -sTCP:LISTEN but this option is not available
- ## on lsof v4.78 which is the one bundled with some distros. So we have to do this grep below
-- newpid=$(lsof -i :$NEO4J_SERVER_PORT -F T -Ts | grep -i "TST=LISTEN" -B1 | head -n1)
-+ newpid=$(lsof -i :$NEO4J_SERVER_PORT -F p | grep "p")
- newpid=${newpid:1}
- fi
- }
-@@ -287,16 +276,16 @@
- # pass in "true" for created to mark that the user was created (instead than pre-existing)
- modify_user_config() {
- created=${2:-"false"}
-- if `grep -q "wrapper\.user=" "$NEO4J_INSTANCE/conf/neo4j-wrapper.conf"` ; then
-- sed -i -e "s/^.*wrapper\.user=.*$/wrapper\.user=$1/" "$NEO4J_INSTANCE/conf/neo4j-wrapper.conf"
-+ if `grep -q "wrapper\.user=" "$NEO4J_CONFIG/neo4j-wrapper.conf"` ; then
-+ sed -i -e "s/^.*wrapper\.user=.*$/wrapper\.user=$1/" "$NEO4J_CONFIG/neo4j-wrapper.conf"
- else
-- echo "wrapper.user=$1" >> "$NEO4J_INSTANCE/conf/neo4j-wrapper.conf"
-+ echo "wrapper.user=$1" >> "$NEO4J_CONFIG/neo4j-wrapper.conf"
- fi
-
-- if `grep -q "wrapper\.user\.created=" "$NEO4J_INSTANCE/conf/neo4j-wrapper.conf"` ; then
-- sed -i -e "s/^.*wrapper\.user\.created=.*$/wrapper\.user\.created=${created}/" "$NEO4J_INSTANCE/conf/neo4j-wrapper.conf"
-+ if `grep -q "wrapper\.user\.created=" "$NEO4J_CONFIG/neo4j-wrapper.conf"` ; then
-+ sed -i -e "s/^.*wrapper\.user\.created=.*$/wrapper\.user\.created=${created}/" "$NEO4J_CONFIG/neo4j-wrapper.conf"
- else
-- echo "wrapper.user.created=${created}" >> "$NEO4J_INSTANCE/conf/neo4j-wrapper.conf"
-+ echo "wrapper.user.created=${created}" >> "$NEO4J_CONFIG/neo4j-wrapper.conf"
- fi
- }
+diff -U 3 -H -d -r -N -- neo4j-community-2.3.1-orig/bin/neo4j-import neo4j-community-2.3.1-mod/bin/neo4j-import
+--- neo4j-community-2.3.1-orig/bin/neo4j-import 2015-11-10 10:15:38.000000000 -0200
++++ neo4j-community-2.3.1-mod/bin/neo4j-import 2015-12-26 20:25:21.546530977 -0200
+@@ -21,19 +21,7 @@
+ #Remember where we started from so that working dir is set correctly
+ RUN_FROM=`pwd`
+
+-SCRIPT_LOCATION="$0"
+-
+-cd "`dirname "$SCRIPT_LOCATION"`"
+-SCRIPT_LOCATION=`basename "$SCRIPT_LOCATION"`
+-
+-while [ -L "$SCRIPT_LOCATION" ]
+-do
+- SCRIPT_LOCATION=$( readlink $SCRIPT_LOCATION )
+- cd "`dirname "$SCRIPT_LOCATION"`"
+- SCRIPT_LOCATION="`basename "$SCRIPT_LOCATION"`"
+-done
+-
+-BASEDIR=`cd "$( dirname $SCRIPT_LOCATION )"/.. && dirs -l +0`
++BASEDIR=/usr/share/java/neo4j
-diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/bin/neo4j-import neo4j-community-2.2.0-mod/bin/neo4j-import
---- neo4j-community-2.2.0-orig/bin/neo4j-import 2015-03-24 09:59:49.000000000 -0300
-+++ neo4j-community-2.2.0-mod/bin/neo4j-import 2015-03-31 10:51:08.903232004 -0300
-@@ -86,7 +86,7 @@
+ # OS specific support. $var _must_ be set to either true or false.
+ cygwin=false;
+@@ -86,7 +74,7 @@
if [ -z "$REPO" ]
then
- REPO="$BASEDIR"/lib
-+ REPO=/usr/share/java/neo4j
++ REPO="$BASEDIR"
fi
LIBRARY_JARS=""
-diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/bin/neo4j-shell neo4j-community-2.2.0-mod/bin/neo4j-shell
---- neo4j-community-2.2.0-orig/bin/neo4j-shell 2015-03-24 09:59:49.000000000 -0300
-+++ neo4j-community-2.2.0-mod/bin/neo4j-shell 2015-03-31 10:51:20.503231501 -0300
-@@ -86,7 +86,7 @@
+diff -U 3 -H -d -r -N -- neo4j-community-2.3.1-orig/bin/neo4j-shell neo4j-community-2.3.1-mod/bin/neo4j-shell
+--- neo4j-community-2.3.1-orig/bin/neo4j-shell 2015-11-10 10:15:38.000000000 -0200
++++ neo4j-community-2.3.1-mod/bin/neo4j-shell 2015-12-26 20:27:40.619567323 -0200
+@@ -21,19 +21,7 @@
+ #Remember where we started from so that working dir is set correctly
+ RUN_FROM=`pwd`
+
+-SHELL_SCRIPT="$0"
+-
+-cd "`dirname "$SHELL_SCRIPT"`"
+-SHELL_SCRIPT=`basename "$SHELL_SCRIPT"`
+-
+-while [ -L "$SHELL_SCRIPT" ]
+-do
+- SHELL_SCRIPT=$( readlink $SHELL_SCRIPT )
+- cd "`dirname "$SHELL_SCRIPT"`"
+- SHELL_SCRIPT="`basename "$SHELL_SCRIPT"`"
+-done
+-
+-BASEDIR=`cd "$( dirname $SHELL_SCRIPT )"/.. && dirs -l +0`
++BASEDIR=/usr/share/java/neo4j
+
+ # OS specific support. $var _must_ be set to either true or false.
+ cygwin=false;
+@@ -86,7 +74,7 @@
if [ -z "$REPO" ]
then
- REPO="$BASEDIR"/lib
-+ REPO=/usr/share/java/neo4j
++ REPO="$BASEDIR"
fi
LIBRARY_JARS=""
-diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/bin/utils neo4j-community-2.2.0-mod/bin/utils
---- neo4j-community-2.2.0-orig/bin/utils 2015-03-24 09:59:49.000000000 -0300
-+++ neo4j-community-2.2.0-mod/bin/utils 2015-03-31 10:55:24.576554252 -0300
-@@ -324,11 +324,11 @@
- # in place.
- checkandrepairenv() {
- # Create data/log if missing, change owner if created.
-- if [ ! -d "$NEO4J_HOME"/data/log ]; then
-- echo "${NEO4J_HOME}/data/log was missing, recreating..."
-- mkdir "$NEO4J_HOME"/data/log
-+ if [ ! -d "$NEO4J_LOG" ]; then
-+ echo "${NEO4J_LOG} was missing, recreating..."
-+ mkdir "$NEO4J_LOG"
- if [ $UID == 0 ] ; then
-- chown $NEO4J_USER "$NEO4J_HOME"/data/log
-+ chown $NEO4J_USER "$NEO4J_LOG"
- fi
- fi
- }
diff --git a/conf.patch b/conf.patch
index e949e5c8799d..6f566ec0e6b7 100644
--- a/conf.patch
+++ b/conf.patch
@@ -1,18 +1,6 @@
-diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/conf/logging.properties neo4j-community-2.2.0-mod/conf/logging.properties
---- neo4j-community-2.2.0-orig/conf/logging.properties 2015-03-24 09:59:49.000000000 -0300
-+++ neo4j-community-2.2.0-mod/conf/logging.properties 2015-03-31 11:05:19.973195104 -0300
-@@ -51,7 +51,7 @@
- # "%g" the generation number to distinguish rotated logs
- # "%u" a unique number to resolve conflicts
- # "%%" translates to a single percent sign "%"
--java.util.logging.FileHandler.pattern=data/log/neo4j.%u.%g.log
-+java.util.logging.FileHandler.pattern=/var/log/neo4j/neo4j.%u.%g.log
-
- # Specifies whether the FileHandler should append onto any existing files
- # (defaults to false):
-diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/conf/neo4j-http-logging.xml neo4j-community-2.2.0-mod/conf/neo4j-http-logging.xml
---- neo4j-community-2.2.0-orig/conf/neo4j-http-logging.xml 2015-03-24 09:59:49.000000000 -0300
-+++ neo4j-community-2.2.0-mod/conf/neo4j-http-logging.xml 2015-03-31 11:06:24.753192294 -0300
+diff -U 3 -H -d -r -N -- neo4j-community-2.3.1-orig/conf/neo4j-http-logging.xml neo4j-community-2.3.1-mod/conf/neo4j-http-logging.xml
+--- neo4j-community-2.3.1-orig/conf/neo4j-http-logging.xml 2015-11-10 10:15:38.000000000 -0200
++++ neo4j-community-2.3.1-mod/conf/neo4j-http-logging.xml 2015-12-26 21:16:12.078406814 -0200
@@ -21,9 +21,9 @@
-->
<configuration>
@@ -25,9 +13,23 @@ diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/conf/neo4j-http-logging.xml
<maxHistory>7</maxHistory>
</rollingPolicy>
-diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/conf/neo4j-server.properties neo4j-community-2.2.0-mod/conf/neo4j-server.properties
---- neo4j-community-2.2.0-orig/conf/neo4j-server.properties 2015-03-24 09:59:49.000000000 -0300
-+++ neo4j-community-2.2.0-mod/conf/neo4j-server.properties 2015-04-15 09:52:34.556610762 -0300
+diff -U 3 -H -d -r -N -- neo4j-community-2.3.1-orig/conf/neo4j.properties neo4j-community-2.3.1-mod/conf/neo4j.properties
+--- neo4j-community-2.3.1-orig/conf/neo4j.properties 2015-11-10 10:15:38.000000000 -0200
++++ neo4j-community-2.3.1-mod/conf/neo4j.properties 2015-12-26 21:35:25.395504168 -0200
+@@ -24,8 +24,8 @@
+ # Set the root directory for use with file URLs (`file:///`) in LOAD CSV.
+ # If enabled, file URLs will refer to locations inside the `data/import`
+ # directory. I.e. `file:///movies/actors.csv` will load from the file
+-# `data/import/movies/actors.csv`.
+-#dbms.security.load_csv_file_url_root=data/import
++# `/var/lib/neo4j/data/import/movies/actors.csv`.
++#dbms.security.load_csv_file_url_root=/var/lib/neo4j/data/import
+
+ # Keep logical logs, helps debugging but uses more disk space, enabled for
+ # legacy reasons To limit space needed to store historical logs use values such
+diff -U 3 -H -d -r -N -- neo4j-community-2.3.1-orig/conf/neo4j-server.properties neo4j-community-2.3.1-mod/conf/neo4j-server.properties
+--- neo4j-community-2.3.1-orig/conf/neo4j-server.properties 2015-11-10 10:15:38.000000000 -0200
++++ neo4j-community-2.3.1-mod/conf/neo4j-server.properties 2015-12-26 21:31:19.899361740 -0200
@@ -10,10 +10,10 @@
#***************************************************************
@@ -55,12 +57,12 @@ diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/conf/neo4j-server.properties
org.neo4j.server.webserver.https.port=7473
# Certificate location (auto generated if the file does not exist)
--org.neo4j.server.webserver.https.cert.location=conf/ssl/snakeoil.cert
-+org.neo4j.server.webserver.https.cert.location=/etc/neo4j/ssl/snakeoil.cert
+-dbms.security.tls_certificate_file=conf/ssl/snakeoil.cert
++dbms.security.tls_certificate_file=/etc/neo4j/ssl/snakeoil.cert
# Private key location (auto generated if the file does not exist)
--org.neo4j.server.webserver.https.key.location=conf/ssl/snakeoil.key
-+org.neo4j.server.webserver.https.key.location=/etc/neo4j/ssl/snakeoil.key
+-dbms.security.tls_key_file=conf/ssl/snakeoil.key
++dbms.security.tls_key_file=/etc/neo4j/ssl/snakeoil.key
# Internally generated keystore (don't try to put your own
# keystore there, it will get deleted when the server starts)
@@ -78,48 +80,37 @@ diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/conf/neo4j-server.properties
#*****************************************************************
-@@ -82,4 +85,4 @@
+@@ -82,5 +85,5 @@
# - absolute path like /var/rrd
# - path relative to the server working directory like data/rrd
# - commented out, will default to the database data directory.
-org.neo4j.server.webadmin.rrdb.location=data/rrd
+org.neo4j.server.webadmin.rrdb.location=/var/lib/neo4j/data/rrd
-diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/conf/neo4j-wrapper.conf neo4j-community-2.2.0-mod/conf/neo4j-wrapper.conf
---- neo4j-community-2.2.0-orig/conf/neo4j-wrapper.conf 2015-03-24 09:59:49.000000000 -0300
-+++ neo4j-community-2.2.0-mod/conf/neo4j-wrapper.conf 2015-03-31 12:28:30.216312067 -0300
-@@ -2,9 +2,9 @@
+
+diff -U 3 -H -d -r -N -- neo4j-community-2.3.1-orig/conf/neo4j-wrapper.conf neo4j-community-2.3.1-mod/conf/neo4j-wrapper.conf
+--- neo4j-community-2.3.1-orig/conf/neo4j-wrapper.conf 2015-11-10 10:15:38.000000000 -0200
++++ neo4j-community-2.3.1-mod/conf/neo4j-wrapper.conf 2015-12-26 21:33:58.755689184 -0200
+@@ -2,8 +2,8 @@
# Property file references
#********************************************************************
-wrapper.java.additional=-Dorg.neo4j.server.properties=conf/neo4j-server.properties
--wrapper.java.additional=-Djava.util.logging.config.file=conf/logging.properties
-wrapper.java.additional=-Dlog4j.configuration=file:conf/log4j.properties
+wrapper.java.additional=-Dorg.neo4j.server.properties=/etc/neo4j/neo4j-server.properties
-+wrapper.java.additional=-Djava.util.logging.config.file=/etc/neo4j/logging.properties
+wrapper.java.additional=-Dlog4j.configuration=file:/etc/neo4j/log4j.properties
#********************************************************************
# JVM Parameters
-@@ -16,7 +16,7 @@
- wrapper.java.additional=-XX:hashCode=5
-
- # Uncomment the following lines to enable garbage collection logging
--#wrapper.java.additional=-Xloggc:data/log/neo4j-gc.log
-+#wrapper.java.additional=-Xloggc:/var/log/neo4j/neo4j-gc.log
- #wrapper.java.additional=-XX:+PrintGCDetails
- #wrapper.java.additional=-XX:+PrintGCDateStamps
- #wrapper.java.additional=-XX:+PrintGCApplicationStoppedTime
-@@ -33,8 +33,7 @@
- #********************************************************************
+@@ -32,7 +32,7 @@
# Wrapper settings
#********************************************************************
--# path is relative to the bin dir
+ # path is relative to the bin dir
-wrapper.pidfile=../data/neo4j-server.pid
+wrapper.pidfile=/run/neo4j/neo4j-server.pid
#********************************************************************
# Wrapper Windows NT/2000/XP Service Properties
-@@ -49,7 +48,7 @@
+@@ -47,7 +47,7 @@
# User account to be used for linux installs. Will default to current
# user if not set.