summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcel Campello Ferreira2015-04-15 10:30:16 -0300
committerMarcel Campello Ferreira2015-04-15 10:32:28 -0300
commitce1cbd934365ef8310ec9c8191c9d012291fad71 (patch)
tree6ea42ce2f062d170ab25717188939b60b67697df
parent25c0d5332579033141954227760e38b9bc491885 (diff)
downloadaur-ce1cbd934365ef8310ec9c8191c9d012291fad71.tar.gz
Version 2.2.0-1.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
-rw-r--r--bin.patch33
-rw-r--r--conf.patch97
-rw-r--r--neo4j.install36
5 files changed, 93 insertions, 102 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c06629702bf..81dbbbc848ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = neo4j
pkgdesc = A fully transactional graph database implemented in Java
- pkgver = 2.1.7
+ pkgver = 2.2.0
pkgrel = 1
url = http://neo4j.org/
install = neo4j.install
@@ -17,16 +17,16 @@ pkgbase = neo4j
backup = etc/neo4j/neo4j-server.properties
backup = etc/neo4j/neo4j-wrapper.conf
backup = etc/neo4j/neo4j.properties
- source = http://dist.neo4j.org/neo4j-community-2.1.7-unix.tar.gz
+ source = http://dist.neo4j.org/neo4j-community-2.2.0-unix.tar.gz
source = bin.patch
source = conf.patch
source = neo4j.install
source = neo4j.service
source = neo4j-tmpfile.conf
- sha256sums = a71e1d31f288a03187d9e18890bee2924f8aa3ab1e740ab8be920ad68dbb3209
- sha256sums = e52e0f353ce80e09fe74662e77223f5ff35a36f874653795ad173aa8a6bd5525
- sha256sums = 63426ed3ee522c2ce5f1505b15502742187156c9f09b3b1e8b2eff2379fa2a89
- sha256sums = b39e3a898328bc98723245bef7f467cd1cb3636a2d750e4b0d7a17d671d0a1e7
+ sha256sums = 86c5366f99bd8d97131110c52b231352ea07e39093bbfd7960b2f0f211b35def
+ sha256sums = d161c1b0397843a78c16cf06f3087ca52f01efb300749874d52013fde87d26f8
+ sha256sums = bb9ea8ae8a684e9981a24ca7bb242a4c2aaa8fdacb820abf8da7f56f413d1e5f
+ sha256sums = 3c4f3daea1623a5bc4c56d87ff4d76ff4737722eb730e2f9b65a0980bf3633a3
sha256sums = ee451a5b4ac3f733ab725bb3babeefc4d852115fe24ee29a3060922716212ad7
sha256sums = e9ecbf86072ca92129ab1889b5f91e2494b86e84248bd15a37681a3997892d7d
diff --git a/PKGBUILD b/PKGBUILD
index ad8edbf0b7ce..826c9f52122d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Marcel Campello Ferreira <marcel@prafrentex.com.br>
pkgname=neo4j
-pkgver=2.1.7
+pkgver=2.2.0
pkgrel=1
pkgdesc="A fully transactional graph database implemented in Java"
arch=(any)
@@ -22,10 +22,10 @@ source=(http://dist.neo4j.org/neo4j-community-$pkgver-unix.tar.gz
neo4j.install
neo4j.service
neo4j-tmpfile.conf)
-sha256sums=('a71e1d31f288a03187d9e18890bee2924f8aa3ab1e740ab8be920ad68dbb3209'
- 'e52e0f353ce80e09fe74662e77223f5ff35a36f874653795ad173aa8a6bd5525'
- '63426ed3ee522c2ce5f1505b15502742187156c9f09b3b1e8b2eff2379fa2a89'
- 'b39e3a898328bc98723245bef7f467cd1cb3636a2d750e4b0d7a17d671d0a1e7'
+sha256sums=('86c5366f99bd8d97131110c52b231352ea07e39093bbfd7960b2f0f211b35def'
+ 'd161c1b0397843a78c16cf06f3087ca52f01efb300749874d52013fde87d26f8'
+ 'bb9ea8ae8a684e9981a24ca7bb242a4c2aaa8fdacb820abf8da7f56f413d1e5f'
+ '3c4f3daea1623a5bc4c56d87ff4d76ff4737722eb730e2f9b65a0980bf3633a3'
'ee451a5b4ac3f733ab725bb3babeefc4d852115fe24ee29a3060922716212ad7'
'e9ecbf86072ca92129ab1889b5f91e2494b86e84248bd15a37681a3997892d7d')
@@ -35,7 +35,7 @@ prepare() {
rm conf/windows-wrapper-logging.properties
rm bin/neo4j-installer
- rm bin/org.neo4j.server.plist
+ rm -rf system/resources
# Adjust configuration to match new directory structure
patch -Np1 -i ../conf.patch
@@ -65,11 +65,16 @@ package() {
install -dm755 $pkgdir/usr/bin
ln -s /usr/share/neo4j/bin/neo4j $pkgdir/usr/bin/neo4j
ln -s /usr/share/neo4j/bin/neo4j-shell $pkgdir/usr/bin/neo4j-shell
+ ln -s /usr/share/neo4j/bin/neo4j-import $pkgdir/usr/bin/neo4j-import
# Data and log files
install -dm755 $pkgdir/var/lib/neo4j/data
install -dm755 $pkgdir/var/log/neo4j
+ # Documentation
+ install -dm755 $pkgdir/usr/share/doc/neo4j
+ cp CHANGES.txt README.txt UPGRADE.txt $pkgdir/usr/share/doc/neo4j
+
# License files
install -dm755 $pkgdir/usr/share/licenses/neo4j
cp LICENSE.txt LICENSES.txt NOTICE.txt $pkgdir/usr/share/licenses/neo4j
diff --git a/bin.patch b/bin.patch
index ed3fbd7c7c10..1b0ca10873b8 100644
--- a/bin.patch
+++ b/bin.patch
@@ -1,6 +1,6 @@
-diff -U 3 -H -d -r -N -- neo4j-community-2.1.5-orig/bin/neo4j neo4j-community-2.1.5-mod/bin/neo4j
---- neo4j-community-2.1.5-orig/bin/neo4j 2014-09-30 03:35:40.000000000 -0300
-+++ neo4j-community-2.1.5-mod/bin/neo4j 2014-11-05 07:57:26.549286965 -0200
+diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/bin/neo4j neo4j-community-2.2.0-mod/bin/neo4j
+--- neo4j-community-2.2.0-orig/bin/neo4j 2015-03-24 09:59:49.000000000 -0300
++++ neo4j-community-2.2.0-mod/bin/neo4j 2015-03-31 10:50:57.546565829 -0300
@@ -33,23 +33,12 @@
LAUNCHD_NAME="org.neo4j.server"
@@ -86,7 +86,7 @@ diff -U 3 -H -d -r -N -- neo4j-community-2.1.5-orig/bin/neo4j neo4j-community-2.
newpid=${newpid:1}
fi
}
-@@ -289,15 +278,15 @@
+@@ -287,16 +276,16 @@
# pass in "true" for created to mark that the user was created (instead than pre-existing)
modify_user_config() {
created=${2:-"false"}
@@ -108,9 +108,22 @@ diff -U 3 -H -d -r -N -- neo4j-community-2.1.5-orig/bin/neo4j neo4j-community-2.
+ echo "wrapper.user.created=${created}" >> "$NEO4J_CONFIG/neo4j-wrapper.conf"
fi
}
-diff -U 3 -H -d -r -N -- neo4j-community-2.1.5-orig/bin/neo4j-shell neo4j-community-2.1.5-mod/bin/neo4j-shell
---- neo4j-community-2.1.5-orig/bin/neo4j-shell 2014-09-30 03:35:40.000000000 -0300
-+++ neo4j-community-2.1.5-mod/bin/neo4j-shell 2014-11-05 07:39:00.153752030 -0200
+
+diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/bin/neo4j-import neo4j-community-2.2.0-mod/bin/neo4j-import
+--- neo4j-community-2.2.0-orig/bin/neo4j-import 2015-03-24 09:59:49.000000000 -0300
++++ neo4j-community-2.2.0-mod/bin/neo4j-import 2015-03-31 10:51:08.903232004 -0300
+@@ -86,7 +86,7 @@
+
+ if [ -z "$REPO" ]
+ then
+- REPO="$BASEDIR"/lib
++ REPO=/usr/share/java/neo4j
+ fi
+
+ LIBRARY_JARS=""
+diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/bin/neo4j-shell neo4j-community-2.2.0-mod/bin/neo4j-shell
+--- neo4j-community-2.2.0-orig/bin/neo4j-shell 2015-03-24 09:59:49.000000000 -0300
++++ neo4j-community-2.2.0-mod/bin/neo4j-shell 2015-03-31 10:51:20.503231501 -0300
@@ -86,7 +86,7 @@
if [ -z "$REPO" ]
@@ -120,9 +133,9 @@ diff -U 3 -H -d -r -N -- neo4j-community-2.1.5-orig/bin/neo4j-shell neo4j-commun
fi
LIBRARY_JARS=""
-diff -U 3 -H -d -r -N -- neo4j-community-2.1.5-orig/bin/utils neo4j-community-2.1.5-mod/bin/utils
---- neo4j-community-2.1.5-orig/bin/utils 2014-09-30 03:35:40.000000000 -0300
-+++ neo4j-community-2.1.5-mod/bin/utils 2014-11-05 07:39:00.153752030 -0200
+diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/bin/utils neo4j-community-2.2.0-mod/bin/utils
+--- neo4j-community-2.2.0-orig/bin/utils 2015-03-24 09:59:49.000000000 -0300
++++ neo4j-community-2.2.0-mod/bin/utils 2015-03-31 10:55:24.576554252 -0300
@@ -324,11 +324,11 @@
# in place.
checkandrepairenv() {
diff --git a/conf.patch b/conf.patch
index 6897895a81bb..e949e5c8799d 100644
--- a/conf.patch
+++ b/conf.patch
@@ -1,6 +1,6 @@
-diff -U 3 -H -d -r -N -- neo4j-community-2.1.5-orig/conf/logging.properties neo4j-community-2.1.5-mod/conf/logging.properties
---- neo4j-community-2.1.5-orig/conf/logging.properties 2014-09-30 03:35:40.000000000 -0300
-+++ neo4j-community-2.1.5-mod/conf/logging.properties 2014-11-05 07:38:53.457072034 -0200
+diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/conf/logging.properties neo4j-community-2.2.0-mod/conf/logging.properties
+--- neo4j-community-2.2.0-orig/conf/logging.properties 2015-03-24 09:59:49.000000000 -0300
++++ neo4j-community-2.2.0-mod/conf/logging.properties 2015-03-31 11:05:19.973195104 -0300
@@ -51,7 +51,7 @@
# "%g" the generation number to distinguish rotated logs
# "%u" a unique number to resolve conflicts
@@ -10,9 +10,9 @@ diff -U 3 -H -d -r -N -- neo4j-community-2.1.5-orig/conf/logging.properties neo4
# Specifies whether the FileHandler should append onto any existing files
# (defaults to false):
-diff -U 3 -H -d -r -N -- neo4j-community-2.1.5-orig/conf/neo4j-http-logging.xml neo4j-community-2.1.5-mod/conf/neo4j-http-logging.xml
---- neo4j-community-2.1.5-orig/conf/neo4j-http-logging.xml 2014-09-30 03:35:40.000000000 -0300
-+++ neo4j-community-2.1.5-mod/conf/neo4j-http-logging.xml 2014-11-05 07:38:53.457072034 -0200
+diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/conf/neo4j-http-logging.xml neo4j-community-2.2.0-mod/conf/neo4j-http-logging.xml
+--- neo4j-community-2.2.0-orig/conf/neo4j-http-logging.xml 2015-03-24 09:59:49.000000000 -0300
++++ neo4j-community-2.2.0-mod/conf/neo4j-http-logging.xml 2015-03-31 11:06:24.753192294 -0300
@@ -21,9 +21,9 @@
-->
<configuration>
@@ -20,24 +20,38 @@ diff -U 3 -H -d -r -N -- neo4j-community-2.1.5-orig/conf/neo4j-http-logging.xml
- <file>data/log/http.log</file>
+ <file>/var/log/neo4j/http.log</file>
<rollingPolicy class="ch.qos.logback.core.rolling.TimeBasedRollingPolicy">
-- <fileNamePattern>data/log/http.%d{yyyy-MM-dd_HH}.log</fileNamePattern>
-+ <fileNamePattern>/var/log/neo4j/http.%d{yyyy-MM-dd_HH}.log</fileNamePattern>
- <maxHistory>30</maxHistory>
+- <fileNamePattern>data/log/http.%d{yyyy-MM-dd}.log</fileNamePattern>
++ <fileNamePattern>/var/log/neo4j/http.%d{yyyy-MM-dd}.log</fileNamePattern>
+ <maxHistory>7</maxHistory>
</rollingPolicy>
-diff -U 3 -H -d -r -N -- neo4j-community-2.1.5-orig/conf/neo4j-server.properties neo4j-community-2.1.5-mod/conf/neo4j-server.properties
---- neo4j-community-2.1.5-orig/conf/neo4j-server.properties 2014-09-30 03:35:40.000000000 -0300
-+++ neo4j-community-2.1.5-mod/conf/neo4j-server.properties 2014-11-05 07:38:53.457072034 -0200
-@@ -8,7 +8,7 @@
+diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/conf/neo4j-server.properties neo4j-community-2.2.0-mod/conf/neo4j-server.properties
+--- neo4j-community-2.2.0-orig/conf/neo4j-server.properties 2015-03-24 09:59:49.000000000 -0300
++++ neo4j-community-2.2.0-mod/conf/neo4j-server.properties 2015-04-15 09:52:34.556610762 -0300
+@@ -10,10 +10,10 @@
#***************************************************************
- # location of the database directory
+ # location of the database directory
-org.neo4j.server.database.location=data/graph.db
+org.neo4j.server.database.location=/var/lib/neo4j/data/graph.db
+ # Low-level graph engine tuning file
+-org.neo4j.server.db.tuning.properties=conf/neo4j.properties
++org.neo4j.server.db.tuning.properties=/etc/neo4j/neo4j.properties
+
# Let the webserver only listen on the specified IP. Default is localhost (only
# accept local connections). Uncomment to allow any connection. Please see the
-@@ -33,14 +33,14 @@
+@@ -23,6 +23,9 @@
+ # Require (or disable the requirement of) auth to access Neo4j
+ dbms.security.auth_enabled=true
+
++# User auth data directory
++dbms.security.auth_store.location=/var/lib/neo4j/data/dbms/auth
++
+ #
+ # HTTP Connector
+ #
+@@ -41,14 +44,14 @@
org.neo4j.server.webserver.https.port=7473
# Certificate location (auto generated if the file does not exist)
@@ -53,37 +67,30 @@ diff -U 3 -H -d -r -N -- neo4j-community-2.1.5-orig/conf/neo4j-server.properties
-org.neo4j.server.webserver.https.keystore.location=data/keystore
+org.neo4j.server.webserver.https.keystore.location=/var/lib/neo4j/data/keystore
+ # Comma separated list of JAX-RS packages containing JAX-RS resources, one
+ # package name for each mountpoint. The listed package names will be loaded
+@@ -71,7 +74,7 @@
+ # archived. Note: changing the rollover and retention policy is sensible, but
+ # changing the output format is less so, since it is configured to use the
+ # ubiquitous common log format
+-org.neo4j.server.http.log.config=conf/neo4j-http-logging.xml
++org.neo4j.server.http.log.config=/etc/neo4j/neo4j-http-logging.xml
+
+
#*****************************************************************
- # Administration client configuration
-@@ -50,7 +50,7 @@
+@@ -82,4 +85,4 @@
# - absolute path like /var/rrd
# - path relative to the server working directory like data/rrd
# - commented out, will default to the database data directory.
-org.neo4j.server.webadmin.rrdb.location=data/rrd
+org.neo4j.server.webadmin.rrdb.location=/var/lib/neo4j/data/rrd
+diff -U 3 -H -d -r -N -- neo4j-community-2.2.0-orig/conf/neo4j-wrapper.conf neo4j-community-2.2.0-mod/conf/neo4j-wrapper.conf
+--- neo4j-community-2.2.0-orig/conf/neo4j-wrapper.conf 2015-03-24 09:59:49.000000000 -0300
++++ neo4j-community-2.2.0-mod/conf/neo4j-wrapper.conf 2015-03-31 12:28:30.216312067 -0300
+@@ -2,9 +2,9 @@
+ # Property file references
+ #********************************************************************
- # REST endpoint for the data API
- # Note the / in the end is mandatory
-@@ -60,7 +60,7 @@
- org.neo4j.server.webadmin.management.uri=/db/manage/
-
- # Low-level graph engine tuning file
--org.neo4j.server.db.tuning.properties=conf/neo4j.properties
-+org.neo4j.server.db.tuning.properties=/etc/neo4j/neo4j.properties
-
- # The console services to be enabled
- org.neo4j.server.manage.console_engines=shell
-@@ -87,5 +87,5 @@
- # archived. Note: changing the rollover and retention policy is sensible, but
- # changing the output format is less so, since it is configured to use the
- # ubiquitous common log format
--org.neo4j.server.http.log.config=conf/neo4j-http-logging.xml
-+org.neo4j.server.http.log.config=/etc/neo4j/neo4j-http-logging.xml
-
-diff -U 3 -H -d -r -N -- neo4j-community-2.1.5-orig/conf/neo4j-wrapper.conf neo4j-community-2.1.5-mod/conf/neo4j-wrapper.conf
---- neo4j-community-2.1.5-orig/conf/neo4j-wrapper.conf 2014-09-30 03:35:40.000000000 -0300
-+++ neo4j-community-2.1.5-mod/conf/neo4j-wrapper.conf 2014-11-05 07:38:53.457072034 -0200
-@@ -1,6 +1,6 @@
-wrapper.java.additional=-Dorg.neo4j.server.properties=conf/neo4j-server.properties
-wrapper.java.additional=-Djava.util.logging.config.file=conf/logging.properties
-wrapper.java.additional=-Dlog4j.configuration=file:conf/log4j.properties
@@ -93,8 +100,8 @@ diff -U 3 -H -d -r -N -- neo4j-community-2.1.5-orig/conf/neo4j-wrapper.conf neo4
#********************************************************************
# JVM Parameters
-@@ -10,7 +10,7 @@
- wrapper.java.additional=-XX:+CMSClassUnloadingEnabled
+@@ -16,7 +16,7 @@
+ wrapper.java.additional=-XX:hashCode=5
# Uncomment the following lines to enable garbage collection logging
-#wrapper.java.additional=-Xloggc:data/log/neo4j-gc.log
@@ -102,20 +109,22 @@ diff -U 3 -H -d -r -N -- neo4j-community-2.1.5-orig/conf/neo4j-wrapper.conf neo4
#wrapper.java.additional=-XX:+PrintGCDetails
#wrapper.java.additional=-XX:+PrintGCDateStamps
#wrapper.java.additional=-XX:+PrintGCApplicationStoppedTime
-@@ -27,8 +27,7 @@
+@@ -33,8 +33,7 @@
#********************************************************************
# Wrapper settings
#********************************************************************
-# path is relative to the bin dir
-wrapper.pidfile=../data/neo4j-server.pid
-+wrapper.pidfile=/var/lib/neo4j/data/neo4j-server.pid
++wrapper.pidfile=/run/neo4j/neo4j-server.pid
#********************************************************************
# Wrapper Windows NT/2000/XP Service Properties
-@@ -43,5 +42,5 @@
+@@ -49,7 +48,7 @@
# User account to be used for linux installs. Will default to current
# user if not set.
-wrapper.user=
+wrapper.user=neo4j
+ #********************************************************************
+ # Other Neo4j system properties
diff --git a/neo4j.install b/neo4j.install
index be0733cf027a..b6ceecd0f58d 100644
--- a/neo4j.install
+++ b/neo4j.install
@@ -6,13 +6,10 @@ post_install() {
chown -R neo4j.neo4j /etc/neo4j
/usr/bin/systemd-tmpfiles --create neo4j.conf
-
- warn_about_java_home
}
post_upgrade() {
assert_user_and_group_exist
- warn_about_java_home
}
post_remove() {
@@ -32,36 +29,3 @@ assert_user_and_group_exist() {
useradd --system -g neo4j -d /var/lib/neo4j -s /bin/false neo4j
fi
}
-
-warn_about_java_home() {
- echo "---------------"
- echo "--- HOORAY!! --"
- echo "---------------"
- echo "If it is the first time you install Neo4j in your"
- echo "Arch box, that's it, you are done. Enjoy your graphs"
- echo "and please disregard all that is said from now on..."
- echo ""
- echo "If you are upgrading Neo4j from a previous version and"
- echo "were given the following advice:"
- echo ""
- echo " >> ------------------------------"
- echo " >> --- ACHTUNG ACHTUNG ALARM! ---"
- echo " >> ------------------------------"
- echo " >> Before starting the Neo4j service, create this file"
- echo " >> "
- echo " >> /etc/systemd/system/neo4j.service.d/java_home.conf"
- echo " >> "
- echo " >> with the following content:"
- echo " >> "
- echo " >> [Service]"
- echo " >> Environment=JAVA_HOME=/your/java/home/path"
- echo " >> "
- echo " >> changing '/your/java/home/path' to your actual JAVA_HOME path."
- echo ""
- echo "then now you are free to delete that file. Actually,"
- echo "pursuant to the new Arch's Java Way of Life"
- echo "(https://wiki.archlinux.org/index.php/Java#Former_.22One_time_setup.22_trick)"
- echo "you shall delete it. Thereupon, enjoy your graphs."
- echo ""
- echo "This message will self-destruct in 1 s̶e̶c̶o̶n̶d̶ release..."
-}