summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Liebkies2017-10-10 16:55:18 +0200
committerMax Liebkies2017-10-10 16:56:31 +0200
commite1aefd6a4c5dbc6dc5d16796a9043aacd90628ac (patch)
tree80366561f8075e1f6271f31a568cff7c8c647739
parent8da74d11e8693d812891d02fbadcfa187f32e818 (diff)
downloadaur-e1aefd6a4c5dbc6dc5d16796a9043aacd90628ac.tar.gz
Update to 3.2.6
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD33
-rw-r--r--bin.patch21
-rw-r--r--conf.patch14
-rw-r--r--neo4j.conf318
-rw-r--r--neo4j.install13
7 files changed, 346 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d5afbe499df..bd7f79d63052 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,24 @@
pkgbase = neo4j-community
pkgdesc = A fully transactional graph database implemented in Java
- pkgver = 3.0.6
+ pkgver = 3.2.6
pkgrel = 1
url = http://neo4j.org/
install = neo4j.install
arch = any
license = custom
makedepends = patch
- depends = bash
depends = java-runtime-headless>=8
conflicts = neo4j-enterprise
options = !strip
- backup = etc/neo4j/neo4j-wrapper.conf
backup = etc/neo4j/neo4j.conf
- source = http://dist.neo4j.org/neo4j-community-3.0.6-unix.tar.gz
- source = bin.patch
- source = conf.patch
+ source = http://dist.neo4j.org/neo4j-community-3.2.6-unix.tar.gz
+ source = neo4j.conf
source = neo4j.install
source = neo4j.service
source = neo4j-tmpfile.conf
- sha256sums = efeab41183e9e5fa94a2d396c65ea93a24e9f105cb3b5f0d0a8e42fb709f4660
- sha256sums = dc94f5d51ed73fdb4fbbc32b5d479dd22de40fb0fcca7e9a8cc5e864e3d8f7fc
- sha256sums = 71ef1d3c9d981cb27c95aa9f0d59e7adca0c6b7431a0e5a39540625a977fe18f
- sha256sums = 3c4f3daea1623a5bc4c56d87ff4d76ff4737722eb730e2f9b65a0980bf3633a3
+ sha256sums = 6d68363595c9288dc734301de6d8f935b7a0febcb59b88ff77676b95cd0a8950
+ sha256sums = f3ad973ba00f14980bb6ece9a619cb4775c0084a5eaf19f76f74675eea4803e8
+ sha256sums = f95936abc4a519b01d2cd987cd38a253003cf4cd39bfab29948708e82d98de66
sha256sums = cf3148bd65ddc06f5ca8cf2ad37013d2e1aa561c5759e4b295f361465e603928
sha256sums = e1311352e05b1e698599b91883141b938ceb418abd7e6bc11cc964854f0a21e1
diff --git a/.gitignore b/.gitignore
index feb3346f2035..8ab503be0037 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,4 @@
neo4j-community-*-any.pkg.tar.xz
neo4j-community-*-unix.tar.gz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 8a964c716d07..b6072d9fe2e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,36 @@
# Maintainer: Marcel Campello Ferreira <marcel.campello.ferreira@gmail.com>
pkgname=neo4j-community
-pkgver=3.0.6
+pkgver=3.2.6
pkgrel=1
pkgdesc='A fully transactional graph database implemented in Java'
arch=(any)
url=http://neo4j.org/
license=(custom)
makedepends=(patch)
-depends=(bash 'java-runtime-headless>=8')
+depends=('java-runtime-headless>=8')
conflicts=(neo4j-enterprise)
-backup=(etc/neo4j/neo4j-wrapper.conf
- etc/neo4j/neo4j.conf)
+backup=(etc/neo4j/neo4j.conf)
options=(!strip)
install=neo4j.install
source=(http://dist.neo4j.org/neo4j-community-$pkgver-unix.tar.gz
- bin.patch
- conf.patch
+ neo4j.conf
neo4j.install
neo4j.service
neo4j-tmpfile.conf)
-sha256sums=('efeab41183e9e5fa94a2d396c65ea93a24e9f105cb3b5f0d0a8e42fb709f4660'
- 'dc94f5d51ed73fdb4fbbc32b5d479dd22de40fb0fcca7e9a8cc5e864e3d8f7fc'
- '71ef1d3c9d981cb27c95aa9f0d59e7adca0c6b7431a0e5a39540625a977fe18f'
- '3c4f3daea1623a5bc4c56d87ff4d76ff4737722eb730e2f9b65a0980bf3633a3'
+sha256sums=('6d68363595c9288dc734301de6d8f935b7a0febcb59b88ff77676b95cd0a8950'
+ 'f3ad973ba00f14980bb6ece9a619cb4775c0084a5eaf19f76f74675eea4803e8'
+ 'f95936abc4a519b01d2cd987cd38a253003cf4cd39bfab29948708e82d98de66'
'cf3148bd65ddc06f5ca8cf2ad37013d2e1aa561c5759e4b295f361465e603928'
'e1311352e05b1e698599b91883141b938ceb418abd7e6bc11cc964854f0a21e1')
-prepare() {
-
- cd $srcdir/neo4j-community-$pkgver
- patch -Np1 -i ../bin.patch
- patch -Np1 -i ../conf.patch
-}
-
package() {
-
cd $srcdir/neo4j-community-$pkgver
# Config files
CONFIG_DIR=etc/neo4j
install -dm755 $pkgdir/$CONFIG_DIR
- [[ $(ls -A conf/* 2>/dev/null) ]] && cp -r conf/* $pkgdir/$CONFIG_DIR
+ install -dm700 $pkgdir/$CONFIG_DIR/certificates
+ install -Dm644 $srcdir/neo4j.conf $pkgdir/etc/neo4j/neo4j.conf
# Data, import and log files
DATA_DIR=var/lib/neo4j/data
@@ -87,9 +77,8 @@ package() {
cp LICENSE.txt LICENSES.txt NOTICE.txt $pkgdir/$LICENSES_DIR
# Service definition files
- cd $srcdir
- install -Dm644 neo4j.service $pkgdir/usr/lib/systemd/system/neo4j.service
+ install -Dm644 $srcdir/neo4j.service $pkgdir/usr/lib/systemd/system/neo4j.service
# Runtime files
- install -Dm644 neo4j-tmpfile.conf $pkgdir/usr/lib/tmpfiles.d/neo4j.conf
+ install -Dm644 $srcdir/neo4j-tmpfile.conf $pkgdir/usr/lib/tmpfiles.d/neo4j.conf
}
diff --git a/bin.patch b/bin.patch
deleted file mode 100644
index ca0f1505e650..000000000000
--- a/bin.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -au0r neo4j-community-3.0.6-orig/bin/neo4j-admin neo4j-community-3.0.6-mod/bin/neo4j-admin
---- neo4j-community-3.0.6-orig/bin/neo4j-admin 2016-09-14 11:15:28.000000000 -0300
-+++ neo4j-community-3.0.6-mod/bin/neo4j-admin 2016-09-21 21:48:09.366135928 -0300
-@@ -21,0 +22,3 @@
-+NEO4J_CONF=/etc/neo4j
-+NEO4J_HOME=/usr/share/neo4j
-+
-diff -au0r neo4j-community-3.0.6-orig/bin/neo4j-import neo4j-community-3.0.6-mod/bin/neo4j-import
---- neo4j-community-3.0.6-orig/bin/neo4j-import 2016-09-14 11:15:28.000000000 -0300
-+++ neo4j-community-3.0.6-mod/bin/neo4j-import 2016-09-21 21:48:09.366135928 -0300
-@@ -23,0 +24,3 @@
-+NEO4J_CONF=/etc/neo4j
-+NEO4J_HOME=/usr/share/neo4j
-+
-diff -au0r neo4j-community-3.0.6-orig/bin/neo4j-shell neo4j-community-3.0.6-mod/bin/neo4j-shell
---- neo4j-community-3.0.6-orig/bin/neo4j-shell 2016-09-14 11:15:28.000000000 -0300
-+++ neo4j-community-3.0.6-mod/bin/neo4j-shell 2016-09-21 21:48:09.366135928 -0300
-@@ -23,0 +24,3 @@
-+NEO4J_CONF=/etc/neo4j
-+NEO4J_HOME=/usr/share/neo4j
-+
diff --git a/conf.patch b/conf.patch
deleted file mode 100644
index 0520cb85de5c..000000000000
--- a/conf.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -au0r neo4j-community-3.0.6-orig/conf/neo4j.conf neo4j-community-3.0.6-mod/conf/neo4j.conf
---- neo4j-community-3.0.6-orig/conf/neo4j.conf 2016-09-14 11:15:28.000000000 -0300
-+++ neo4j-community-3.0.6-mod/conf/neo4j.conf 2016-09-21 21:49:06.659469158 -0300
-@@ -9,4 +9,6 @@
--#dbms.directories.data=data
--#dbms.directories.plugins=plugins
--#dbms.directories.certificates=certificates
--#dbms.directories.logs=logs
-+dbms.directories.data=/var/lib/neo4j/data
-+dbms.directories.plugins=/usr/share/java/neo4j/plugins
-+dbms.directories.lib=/usr/share/java/neo4j
-+dbms.directories.logs=/var/log/neo4j
-+dbms.directories.run=/run/neo4j
-+dbms.directories.certificates=/var/lib/neo4j/certificates
diff --git a/neo4j.conf b/neo4j.conf
new file mode 100644
index 000000000000..80d4fca78ed8
--- /dev/null
+++ b/neo4j.conf
@@ -0,0 +1,318 @@
+#*****************************************************************
+# Neo4j configuration
+#
+# For more details and a complete list of settings, please see
+# https://neo4j.com/docs/operations-manual/current/reference/configuration-settings/
+#*****************************************************************
+
+# The name of the database to mount
+#dbms.active_database=graph.db
+
+# Paths of directories in the installation.
+dbms.directories.data=/var/lib/neo4j/data
+dbms.directories.plugins=/usr/share/java/neo4j/plugins
+dbms.directories.certificates=/etc/neo4j/certificates
+dbms.directories.logs=/var/log/neo4j
+dbms.directories.lib=/usr/share/java/neo4j
+dbms.directories.run=/run/neo4j
+
+# This setting constrains all `LOAD CSV` import files to be under the `import` directory. Remove or comment it out to
+# allow files to be loaded from anywhere in the filesystem; this introduces possible security problems. See the
+# `LOAD CSV` section of the manual for details.
+dbms.directories.import=/var/lib/neo4j/import
+
+# Whether requests to Neo4j are authenticated.
+# To disable authentication, uncomment this line
+#dbms.security.auth_enabled=false
+
+# Enable this to be able to upgrade a store from an older version.
+#dbms.allow_format_migration=true
+
+# Java Heap Size: by default the Java heap size is dynamically
+# calculated based on available system resources.
+# Uncomment these lines to set specific initial and maximum
+# heap size.
+#dbms.memory.heap.initial_size=512m
+#dbms.memory.heap.max_size=512m
+
+# The amount of memory to use for mapping the store files, in bytes (or
+# kilobytes with the 'k' suffix, megabytes with 'm' and gigabytes with 'g').
+# If Neo4j is running on a dedicated server, then it is generally recommended
+# to leave about 2-4 gigabytes for the operating system, give the JVM enough
+# heap to hold all your transaction state and query context, and then leave the
+# rest for the page cache.
+# The default page cache memory assumes the machine is dedicated to running
+# Neo4j, and is heuristically set to 50% of RAM minus the max Java heap size.
+#dbms.memory.pagecache.size=10g
+
+#*****************************************************************
+# Network connector configuration
+#*****************************************************************
+
+# With default configuration Neo4j only accepts local connections.
+# To accept non-local connections, uncomment this line:
+#dbms.connectors.default_listen_address=0.0.0.0
+
+# You can also choose a specific network interface, and configure a non-default
+# port for each connector, by setting their individual listen_address.
+
+# The address at which this server can be reached by its clients. This may be the server's IP address or DNS name, or
+# it may be the address of a reverse proxy which sits in front of the server. This setting may be overridden for
+# individual connectors below.
+#dbms.connectors.default_advertised_address=localhost
+
+# You can also choose a specific advertised hostname or IP address, and
+# configure an advertised port for each connector, by setting their
+# individual advertised_address.
+
+# Bolt connector
+dbms.connector.bolt.enabled=true
+#dbms.connector.bolt.tls_level=OPTIONAL
+#dbms.connector.bolt.listen_address=:7687
+
+# HTTP Connector. There must be exactly one HTTP connector.
+dbms.connector.http.enabled=true
+#dbms.connector.http.listen_address=:7474
+
+# HTTPS Connector. There can be zero or one HTTPS connectors.
+#dbms.connector.https.enabled=true
+#dbms.connector.https.listen_address=:7473
+
+# Number of Neo4j worker threads.
+#dbms.threads.worker_count=
+
+#*****************************************************************
+# SSL system configuration
+#*****************************************************************
+
+# Names of the SSL policies to be used for the respective components.
+
+# The legacy policy is a special policy which is not defined in
+# the policy configuration section, but rather derives from
+# dbms.directories.certificates and associated files
+# (by default: neo4j.key and neo4j.cert). Its use will be deprecated.
+
+# The policies to be used for connectors.
+#
+# N.B: Note that a connector must be configured to support/require
+# SSL/TLS for the policy to actually be utilized.
+#
+# see: dbms.connector.*.tls_level
+
+#bolt.ssl_policy=legacy
+#https.ssl_policy=legacy
+
+#*****************************************************************
+# SSL policy configuration
+#*****************************************************************
+
+# Each policy is configured under a separate namespace, e.g.
+# dbms.ssl.policy.<policyname>.*
+#
+# The example settings below are for a new policy named 'default'.
+
+# The base directory for cryptographic objects. Each policy will by
+# default look for its associated objects (keys, certificates, ...)
+# under the base directory.
+#
+# Every such setting can be overriden using a full path to
+# the respective object, but every policy will by default look
+# for cryptographic objects in its base location.
+#
+# Mandatory setting
+
+#dbms.ssl.policy.default.base_directory=certificates/default
+
+# Allows the generation of a fresh private key and a self-signed
+# certificate if none are found in the expected locations. It is
+# recommended to turn this off again after keys have been generated.
+#
+# Keys should in general be generated and distributed offline
+# by a trusted certificate authority (CA) and not by utilizing
+# this mode.
+
+#dbms.ssl.policy.default.allow_key_generation=false
+
+# Enabling this makes it so that this policy ignores the contents
+# of the trusted_dir and simply resorts to trusting everything.
+#
+# Use of this mode is discouraged. It would offer encryption but no security.
+
+#dbms.ssl.policy.default.trust_all=false
+
+# The private key for the default SSL policy. By default a file
+# named private.key is expected under the base directory of the policy.
+# It is mandatory that a key can be found or generated.
+
+#dbms.ssl.policy.default.private_key=
+
+# The private key for the default SSL policy. By default a file
+# named public.crt is expected under the base directory of the policy.
+# It is mandatory that a certificate can be found or generated.
+
+#dbms.ssl.policy.default.public_certificate=
+
+# The certificates of trusted parties. By default a directory named
+# 'trusted' is expected under the base directory of the policy. It is
+# mandatory to create the directory so that it exists, because it cannot
+# be auto-created (for security purposes).
+#
+# To enforce client authentication client_auth must be set to 'require'!
+
+#dbms.ssl.policy.default.trusted_dir=
+
+# Client authentication setting. Values: none, optional, require
+# The default is to require client authentication.
+#
+# Servers are always authenticated unless explicitly overridden
+# using the trust_all setting. In a mutual authentication setup this
+# should be kept at the default of require and trusted certificates
+# must be installed in the trusted_dir.
+
+#dbms.ssl.policy.default.client_auth=require
+
+# A comma-separated list of allowed TLS versions.
+# By default TLSv1, TLSv1.1 and TLSv1.2 are allowed.
+
+#dbms.ssl.policy.default.tls_versions=
+
+# A comma-separated list of allowed ciphers.
+# The default ciphers are the defaults of the JVM platform.
+
+#dbms.ssl.policy.default.ciphers=
+
+#*****************************************************************
+# Logging configuration
+#*****************************************************************
+
+# To enable HTTP logging, uncomment this line
+#dbms.logs.http.enabled=true
+
+# Number of HTTP logs to keep.
+#dbms.logs.http.rotation.keep_number=5
+
+# Size of each HTTP log that is kept.
+#dbms.logs.http.rotation.size=20m
+
+# To enable GC Logging, uncomment this line
+#dbms.logs.gc.enabled=true
+
+# GC Logging Options
+# see http://docs.oracle.com/cd/E19957-01/819-0084-10/pt_tuningjava.html#wp57013 for more information.
+#dbms.logs.gc.options=-XX:+PrintGCDetails -XX:+PrintGCDateStamps -XX:+PrintGCApplicationStoppedTime -XX:+PrintPromotionFailure -XX:+PrintTenuringDistribution
+
+# Number of GC logs to keep.
+#dbms.logs.gc.rotation.keep_number=5
+
+# Size of each GC log that is kept.
+#dbms.logs.gc.rotation.size=20m
+
+# Size threshold for rotation of the debug log. If set to zero then no rotation will occur. Accepts a binary suffix "k",
+# "m" or "g".
+#dbms.logs.debug.rotation.size=20m
+
+# Maximum number of history files for the internal log.
+#dbms.logs.debug.rotation.keep_number=7
+
+#*****************************************************************
+# Miscellaneous configuration
+#*****************************************************************
+
+# Enable this to specify a parser other than the default one.
+#cypher.default_language_version=3.0
+
+# Determines if Cypher will allow using file URLs when loading data using
+# `LOAD CSV`. Setting this value to `false` will cause Neo4j to fail `LOAD CSV`
+# clauses that load data from the file system.
+#dbms.security.allow_csv_import_from_file_urls=true
+
+# Retention policy for transaction logs needed to perform recovery and backups.
+dbms.tx_log.rotation.retention_policy=1 days
+
+# Enable a remote shell server which Neo4j Shell clients can log in to.
+#dbms.shell.enabled=true
+# The network interface IP the shell will listen on (use 0.0.0.0 for all interfaces).
+#dbms.shell.host=127.0.0.1
+# The port the shell will listen on, default is 1337.
+#dbms.shell.port=1337
+
+# Only allow read operations from this Neo4j instance. This mode still requires
+# write access to the directory for lock purposes.
+#dbms.read_only=false
+
+# Comma separated list of JAX-RS packages containing JAX-RS resources, one
+# package name for each mountpoint. The listed package names will be loaded
+# under the mountpoints specified. Uncomment this line to mount the
+# org.neo4j.examples.server.unmanaged.HelloWorldResource.java from
+# neo4j-server-examples under /examples/unmanaged, resulting in a final URL of
+# http://localhost:7474/examples/unmanaged/helloworld/{nodeId}
+#dbms.unmanaged_extension_classes=org.neo4j.examples.server.unmanaged=/examples/unmanaged
+
+#********************************************************************
+# JVM Parameters
+#********************************************************************
+
+# G1GC generally strikes a good balance between throughput and tail
+# latency, without too much tuning.
+dbms.jvm.additional=-XX:+UseG1GC
+
+# Have common exceptions keep producing stack traces, so they can be
+# debugged regardless of how often logs are rotated.
+dbms.jvm.additional=-XX:-OmitStackTraceInFastThrow
+
+# Make sure that `initmemory` is not only allocated, but committed to
+# the process, before starting the database. This reduces memory
+# fragmentation, increasing the effectiveness of transparent huge
+# pages. It also reduces the possibility of seeing performance drop
+# due to heap-growing GC events, where a decrease in available page
+# cache leads to an increase in mean IO response time.
+# Try reducing the heap memory, if this flag degrades performance.
+dbms.jvm.additional=-XX:+AlwaysPreTouch
+
+# Trust that non-static final fields are really final.
+# This allows more optimizations and improves overall performance.
+# NOTE: Disable this if you use embedded mode, or have extensions or dependencies that may use reflection or
+# serialization to change the value of final fields!
+dbms.jvm.additional=-XX:+UnlockExperimentalVMOptions
+dbms.jvm.additional=-XX:+TrustFinalNonStaticFields
+
+# Disable explicit garbage collection, which is occasionally invoked by the JDK itself.
+dbms.jvm.additional=-XX:+DisableExplicitGC
+
+# Remote JMX monitoring, uncomment and adjust the following lines as needed. Absolute paths to jmx.access and
+# jmx.password files are required.
+# Also make sure to update the jmx.access and jmx.password files with appropriate permission roles and passwords,
+# the shipped configuration contains only a read only role called 'monitor' with password 'Neo4j'.
+# For more details, see: http://download.oracle.com/javase/8/docs/technotes/guides/management/agent.html
+# On Unix based systems the jmx.password file needs to be owned by the user that will run the server,
+# and have permissions set to 0600.
+# For details on setting these file permissions on Windows see:
+# http://docs.oracle.com/javase/8/docs/technotes/guides/management/security-windows.html
+#dbms.jvm.additional=-Dcom.sun.management.jmxremote.port=3637
+#dbms.jvm.additional=-Dcom.sun.management.jmxremote.authenticate=true
+#dbms.jvm.additional=-Dcom.sun.management.jmxremote.ssl=false
+#dbms.jvm.additional=-Dcom.sun.management.jmxremote.password.file=/absolute/path/to/conf/jmx.password
+#dbms.jvm.additional=-Dcom.sun.management.jmxremote.access.file=/absolute/path/to/conf/jmx.access
+
+# Some systems cannot discover host name automatically, and need this line configured:
+#dbms.jvm.additional=-Djava.rmi.server.hostname=$THE_NEO4J_SERVER_HOSTNAME
+
+# Expand Diffie Hellman (DH) key size from default 1024 to 2048 for DH-RSA cipher suites used in server TLS handshakes.
+# This is to protect the server from any potential passive eavesdropping.
+dbms.jvm.additional=-Djdk.tls.ephemeralDHKeySize=2048
+
+#********************************************************************
+# Wrapper Windows NT/2000/XP Service Properties
+#********************************************************************
+# WARNING - Do not modify any of these properties when an application
+# using this configuration file has been installed as a service.
+# Please uninstall the service before modifying this section. The
+# service can then be reinstalled.
+
+# Name of the service
+dbms.windows_service_name=neo4j
+
+#********************************************************************
+# Other Neo4j system properties
+#********************************************************************
+dbms.jvm.additional=-Dunsupported.dbms.udc.source=tarball
diff --git a/neo4j.install b/neo4j.install
index b6ceecd0f58d..6ae39408e26f 100644
--- a/neo4j.install
+++ b/neo4j.install
@@ -1,15 +1,13 @@
post_install() {
assert_user_and_group_exist
-
- chown -R neo4j.neo4j /var/lib/neo4j
- chown -R neo4j.neo4j /var/log/neo4j
- chown -R neo4j.neo4j /etc/neo4j
+ directory_permissions
/usr/bin/systemd-tmpfiles --create neo4j.conf
}
post_upgrade() {
assert_user_and_group_exist
+ directory_permissions
}
post_remove() {
@@ -21,6 +19,13 @@ post_remove() {
fi
}
+directory_permissions() {
+ chown -R neo4j.neo4j /etc/neo4j/certificates
+ chown -R neo4j.neo4j /var/lib/neo4j
+ chown -R neo4j.neo4j /var/log/neo4j
+ chown -R neo4j.neo4j /etc/neo4j
+}
+
assert_user_and_group_exist() {
if ! getent group neo4j >/dev/null; then
groupadd --system neo4j