summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcel Campello Ferreira2014-07-30 11:07:53 -0300
committerMarcel Campello Ferreira2014-07-30 11:07:53 -0300
commitdc3157dc2a4c69793ee8360fc2c5083e91e0bad5 (patch)
treed80b213b62454b51859d1edb801d0c339cc07d64
parent49224f472a467d6296e1bf9cc0bc6b91ccfd5778 (diff)
downloadaur-dc3157dc2a4c69793ee8360fc2c5083e91e0bad5.tar.gz
Version 2.1.3-1.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--bin.patch56
-rw-r--r--conf.patch31
4 files changed, 60 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17dd8e16a364..4d5812c40122 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = neo4j
pkgdesc = A fully transactional graph database implemented in Java
- pkgver = 2.1.2
+ pkgver = 2.1.3
pkgrel = 1
url = http://neo4j.org/
install = neo4j.install
@@ -17,15 +17,15 @@ pkgbase = neo4j
backup = etc/neo4j/neo4j-server.properties
backup = etc/neo4j/neo4j-wrapper.conf
backup = etc/neo4j/neo4j.properties
- source = http://dist.neo4j.org/neo4j-community-2.1.2-unix.tar.gz
+ source = http://dist.neo4j.org/neo4j-community-2.1.3-unix.tar.gz
source = bin.patch
source = conf.patch
source = neo4j.install
source = neo4j.service
source = neo4j-tmpfile.conf
- sha256sums = f8bc1f1baa3d6b0ac0eace7c083ac40d737d82bc4660b15ae9ae36c4a6514d90
- sha256sums = 582e19951d2f99342ae87c902d157ae1bd9e1ee5bf0daebedaf269c0642dfd06
- sha256sums = 447690479e505b870150e5b68d62ec512b5a38e953dfc21b0391e4d2047b8d0b
+ sha256sums = 33e7dcc669b23b2398f6b8e08333b11588e11f1d8614f58dec1b23eb95f19e3d
+ sha256sums = 61e36b7695cc214d192de6d8c81c68fadd7dab90394eb2cd94fd8c916da5fc77
+ sha256sums = e5fe9c34ff9052be68bb66acbdf04cc2e3dfd18cfdc62d78d01688d72dd55773
sha256sums = 60863d1da348dd07ac7c321c51819596f73bb326cb686b85661e1165daea86e9
sha256sums = ee451a5b4ac3f733ab725bb3babeefc4d852115fe24ee29a3060922716212ad7
sha256sums = e9ecbf86072ca92129ab1889b5f91e2494b86e84248bd15a37681a3997892d7d
diff --git a/PKGBUILD b/PKGBUILD
index 085fb54da5ca..007b841e085c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Marcel Campello Ferreira <tucho.tijucano@gmail.com>
pkgname=neo4j
-pkgver=2.1.2
+pkgver=2.1.3
pkgrel=1
pkgdesc="A fully transactional graph database implemented in Java"
arch=(any)
@@ -22,9 +22,9 @@ source=(http://dist.neo4j.org/neo4j-community-$pkgver-unix.tar.gz
neo4j.install
neo4j.service
neo4j-tmpfile.conf)
-sha256sums=(f8bc1f1baa3d6b0ac0eace7c083ac40d737d82bc4660b15ae9ae36c4a6514d90
- 582e19951d2f99342ae87c902d157ae1bd9e1ee5bf0daebedaf269c0642dfd06
- 447690479e505b870150e5b68d62ec512b5a38e953dfc21b0391e4d2047b8d0b
+sha256sums=(33e7dcc669b23b2398f6b8e08333b11588e11f1d8614f58dec1b23eb95f19e3d
+ 61e36b7695cc214d192de6d8c81c68fadd7dab90394eb2cd94fd8c916da5fc77
+ e5fe9c34ff9052be68bb66acbdf04cc2e3dfd18cfdc62d78d01688d72dd55773
60863d1da348dd07ac7c321c51819596f73bb326cb686b85661e1165daea86e9
ee451a5b4ac3f733ab725bb3babeefc4d852115fe24ee29a3060922716212ad7
e9ecbf86072ca92129ab1889b5f91e2494b86e84248bd15a37681a3997892d7d)
diff --git a/bin.patch b/bin.patch
index d7bf976afe3a..21c05fc4f900 100644
--- a/bin.patch
+++ b/bin.patch
@@ -1,10 +1,23 @@
-diff -Naur neo4j-community-2.1.1-orig/bin/neo4j neo4j-community-2.1.1-mod/bin/neo4j
---- neo4j-community-2.1.1-orig/bin/neo4j 2014-05-29 13:24:28.000000000 -0300
-+++ neo4j-community-2.1.1-mod/bin/neo4j 2014-06-01 11:21:42.668017211 -0300
-@@ -46,10 +46,11 @@
- cd "$(dirname "$SCRIPT")"
- SCRIPT=`basename "$SCRIPT"`
- done
+diff -U 3 -H -d -r -N -- neo4j-community-2.1.3-orig/bin/neo4j neo4j-community-2.1.3-mod/bin/neo4j
+--- neo4j-community-2.1.3-orig/bin/neo4j 2014-07-24 10:16:30.000000000 -0300
++++ neo4j-community-2.1.3-mod/bin/neo4j 2014-07-30 09:21:58.581917663 -0300
+@@ -33,23 +33,12 @@
+ LAUNCHD_NAME="org.neo4j.server"
+
+ function findBaseDirAndCdThere {
+-# This seems to not be safe to run at any time. If that
+-# is the case, it should be fixed to be so, if possible.
+- SCRIPT=$0
+-
+- cd "`dirname "$SCRIPT"`"
+- SCRIPT=`basename "$SCRIPT"`
+-
+- while [ -L "$SCRIPT" ]
+- do
+- SCRIPT=$( readlink "$SCRIPT" )
+- cd "$(dirname "$SCRIPT")"
+- SCRIPT=`basename "$SCRIPT"`
+- done
- NEO4J_HOME=`cd $( dirname "$SCRIPT" )/.. && dirs -l +0`
- NEO4J_INSTANCE=$NEO4J_HOME
- NEO4J_CONFIG=$NEO4J_INSTANCE/conf
@@ -14,10 +27,11 @@ diff -Naur neo4j-community-2.1.1-orig/bin/neo4j neo4j-community-2.1.1-mod/bin/ne
+ NEO4J_CONFIG=/etc/neo4j
+ NEO4J_LOG=/var/log/neo4j
+ NEO4J_SHARE=/usr/share/neo4j
++ NEO4J_RUNDIR=/run/neo4j
cd "$NEO4J_HOME"
}
-@@ -67,14 +68,14 @@
+@@ -67,14 +56,14 @@
}
findBaseDirAndCdThere
@@ -30,23 +44,23 @@ diff -Naur neo4j-community-2.1.1-orig/bin/neo4j neo4j-community-2.1.1-mod/bin/ne
[ -z "${wrapper_java_maxmemory}" ] || JAVA_OPTS="$JAVA_OPTS -Xmx${wrapper_java_maxmemory}m"
-#NEO4J_SERVER_PORT=`( egrep "^org.neo4j.server.webserver.port" $NEO4J_INSTANCE/conf/neo4j-server.properties || echo 7474 ) | sed -e 's/.*=//'`
-+#NEO4J_SERVER_PORT=`( egrep "^org.neo4j.server.webserver.port" ${NEO4J_CONFIG}/neo4j-server.properties || echo 7474 ) | sed -e 's/.*=//'`
++#NEO4J_SERVER_PORT=`( egrep "^org.neo4j.server.webserver.port" $NEO4J_CONFIG/neo4j-server.properties || echo 7474 ) | sed -e 's/.*=//'`
NEO4J_SERVER_PORT=${org_neo4j_server_webserver_port:=7474}
LAUNCHD_NAME="${LAUNCHD_NAME}.${NEO4J_SERVER_PORT}"
-@@ -90,16 +91,16 @@
+@@ -90,16 +79,16 @@
# Username to propose for neo4j user, can be overridden by -u USERNAME option
DEFAULT_USER='neo4j'
-SCRIPT_NAME="${NEO4J_HOME}/bin/neo4j"
-+SCRIPT_NAME="/usr/bin/neo4j"
++SCRIPT_NAME="${NEO4J_SHARE}/bin/neo4j"
SERVICE_NAME=${wrapper_ntservice_name:=neo4j-service}
LAUNCHD_DIR=~/Library/LaunchAgents/
TIMEOUT=120
-PID_FILE=${NEO4J_INSTANCE}/data/neo4j-service.pid
-+PID_FILE=/run/neo4j/neo4j-service.pid
++PID_FILE=${NEO4J_RUNDIR}/neo4j-service.pid
buildclasspath() {
# confirm library jars
- LIBDIR="$NEO4J_HOME"/lib
@@ -54,7 +68,7 @@ diff -Naur neo4j-community-2.1.1-orig/bin/neo4j neo4j-community-2.1.1-mod/bin/ne
if [ ! -e "$LIBDIR" ] ; then
echo "Error: missing Neo4j Library, expected at $LIBDIR"
exit 1
-@@ -134,7 +135,7 @@
+@@ -134,7 +123,7 @@
CLASSPATH=${ALL_JARS}
# add useful conf stuff to classpath - always a good idea
@@ -63,7 +77,7 @@ diff -Naur neo4j-community-2.1.1-orig/bin/neo4j neo4j-community-2.1.1-mod/bin/ne
}
detectrunning() {
-@@ -289,16 +290,16 @@
+@@ -289,16 +278,16 @@
# pass in "true" for created to mark that the user was created (instead than pre-existing)
modify_user_config() {
created=${2:-"false"}
@@ -86,21 +100,21 @@ diff -Naur neo4j-community-2.1.1-orig/bin/neo4j neo4j-community-2.1.1-mod/bin/ne
fi
}
-diff -Naur neo4j-community-2.1.1-orig/bin/neo4j-shell neo4j-community-2.1.1-mod/bin/neo4j-shell
---- neo4j-community-2.1.1-orig/bin/neo4j-shell 2014-05-29 13:24:28.000000000 -0300
-+++ neo4j-community-2.1.1-mod/bin/neo4j-shell 2014-06-01 11:23:17.293095310 -0300
+diff -U 3 -H -d -r -N -- neo4j-community-2.1.3-orig/bin/neo4j-shell neo4j-community-2.1.3-mod/bin/neo4j-shell
+--- neo4j-community-2.1.3-orig/bin/neo4j-shell 2014-07-24 10:16:30.000000000 -0300
++++ neo4j-community-2.1.3-mod/bin/neo4j-shell 2014-07-30 09:39:15.685405615 -0300
@@ -86,7 +86,7 @@
if [ -z "$REPO" ]
then
- REPO="$BASEDIR"/lib
-+ REPO=/usr/share/java/neo4j/
++ REPO=/usr/share/java/neo4j
fi
LIBRARY_JARS=""
-diff -Naur neo4j-community-2.1.1-orig/bin/utils neo4j-community-2.1.1-mod/bin/utils
---- neo4j-community-2.1.1-orig/bin/utils 2014-05-29 13:24:28.000000000 -0300
-+++ neo4j-community-2.1.1-mod/bin/utils 2014-06-01 11:24:51.224800589 -0300
+diff -U 3 -H -d -r -N -- neo4j-community-2.1.3-orig/bin/utils neo4j-community-2.1.3-mod/bin/utils
+--- neo4j-community-2.1.3-orig/bin/utils 2014-07-24 10:16:30.000000000 -0300
++++ neo4j-community-2.1.3-mod/bin/utils 2014-07-30 09:42:28.360468307 -0300
@@ -324,11 +324,11 @@
# in place.
checkandrepairenv() {
diff --git a/conf.patch b/conf.patch
index bb861b5db6f3..21bca1054201 100644
--- a/conf.patch
+++ b/conf.patch
@@ -1,6 +1,6 @@
-diff -Naur neo4j-community-2.1.1-orig/conf/logging.properties neo4j-community-2.1.1-mod/conf/logging.properties
---- neo4j-community-2.1.1-orig/conf/logging.properties 2014-05-29 13:24:27.000000000 -0300
-+++ neo4j-community-2.1.1-mod/conf/logging.properties 2014-06-01 11:29:56.386956419 -0300
+diff -U 3 -H -d -r -N -- neo4j-community-2.1.3-orig/conf/logging.properties neo4j-community-2.1.3-mod/conf/logging.properties
+--- neo4j-community-2.1.3-orig/conf/logging.properties 2014-07-24 10:16:30.000000000 -0300
++++ neo4j-community-2.1.3-mod/conf/logging.properties 2014-07-30 09:44:52.691749854 -0300
@@ -51,7 +51,7 @@
# "%g" the generation number to distinguish rotated logs
# "%u" a unique number to resolve conflicts
@@ -10,9 +10,9 @@ diff -Naur neo4j-community-2.1.1-orig/conf/logging.properties neo4j-community-2.
# Specifies whether the FileHandler should append onto any existing files
# (defaults to false):
-diff -Naur neo4j-community-2.1.1-orig/conf/neo4j-http-logging.xml neo4j-community-2.1.1-mod/conf/neo4j-http-logging.xml
---- neo4j-community-2.1.1-orig/conf/neo4j-http-logging.xml 2014-05-29 13:24:27.000000000 -0300
-+++ neo4j-community-2.1.1-mod/conf/neo4j-http-logging.xml 2014-06-01 11:31:01.271469303 -0300
+diff -U 3 -H -d -r -N -- neo4j-community-2.1.3-orig/conf/neo4j-http-logging.xml neo4j-community-2.1.3-mod/conf/neo4j-http-logging.xml
+--- neo4j-community-2.1.3-orig/conf/neo4j-http-logging.xml 2014-07-24 10:16:30.000000000 -0300
++++ neo4j-community-2.1.3-mod/conf/neo4j-http-logging.xml 2014-07-30 09:45:44.372206150 -0300
@@ -21,9 +21,9 @@
-->
<configuration>
@@ -25,9 +25,9 @@ diff -Naur neo4j-community-2.1.1-orig/conf/neo4j-http-logging.xml neo4j-communit
<maxHistory>30</maxHistory>
</rollingPolicy>
-diff -Naur neo4j-community-2.1.1-orig/conf/neo4j-server.properties neo4j-community-2.1.1-mod/conf/neo4j-server.properties
---- neo4j-community-2.1.1-orig/conf/neo4j-server.properties 2014-05-29 13:24:27.000000000 -0300
-+++ neo4j-community-2.1.1-mod/conf/neo4j-server.properties 2014-06-01 11:38:24.366230654 -0300
+diff -U 3 -H -d -r -N -- neo4j-community-2.1.3-orig/conf/neo4j-server.properties neo4j-community-2.1.3-mod/conf/neo4j-server.properties
+--- neo4j-community-2.1.3-orig/conf/neo4j-server.properties 2014-07-24 10:16:30.000000000 -0300
++++ neo4j-community-2.1.3-mod/conf/neo4j-server.properties 2014-07-30 09:48:17.506884800 -0300
@@ -8,7 +8,7 @@
#***************************************************************
@@ -80,9 +80,9 @@ diff -Naur neo4j-community-2.1.1-orig/conf/neo4j-server.properties neo4j-communi
-org.neo4j.server.http.log.config=conf/neo4j-http-logging.xml
+org.neo4j.server.http.log.config=/etc/neo4j/neo4j-http-logging.xml
-diff -Naur neo4j-community-2.1.1-orig/conf/neo4j-wrapper.conf neo4j-community-2.1.1-mod/conf/neo4j-wrapper.conf
---- neo4j-community-2.1.1-orig/conf/neo4j-wrapper.conf 2014-05-29 13:24:27.000000000 -0300
-+++ neo4j-community-2.1.1-mod/conf/neo4j-wrapper.conf 2014-06-01 11:38:11.545994632 -0300
+diff -U 3 -H -d -r -N -- neo4j-community-2.1.3-orig/conf/neo4j-wrapper.conf neo4j-community-2.1.3-mod/conf/neo4j-wrapper.conf
+--- neo4j-community-2.1.3-orig/conf/neo4j-wrapper.conf 2014-07-24 10:16:30.000000000 -0300
++++ neo4j-community-2.1.3-mod/conf/neo4j-wrapper.conf 2014-07-30 10:48:48.062984108 -0300
@@ -1,6 +1,6 @@
-wrapper.java.additional=-Dorg.neo4j.server.properties=conf/neo4j-server.properties
-wrapper.java.additional=-Djava.util.logging.config.file=conf/logging.properties
@@ -102,16 +102,17 @@ diff -Naur neo4j-community-2.1.1-orig/conf/neo4j-wrapper.conf neo4j-community-2.
#wrapper.java.additional=-XX:+PrintGCDetails
#wrapper.java.additional=-XX:+PrintGCDateStamps
#wrapper.java.additional=-XX:+PrintGCApplicationStoppedTime
-@@ -32,7 +32,7 @@
+@@ -27,8 +27,7 @@
+ #********************************************************************
# Wrapper settings
#********************************************************************
- # path is relative to the bin dir
+-# path is relative to the bin dir
-wrapper.pidfile=../data/neo4j-server.pid
+wrapper.pidfile=/var/lib/neo4j/data/neo4j-server.pid
#********************************************************************
# Wrapper Windows NT/2000/XP Service Properties
-@@ -47,5 +47,5 @@
+@@ -43,5 +42,5 @@
# User account to be used for linux installs. Will default to current
# user if not set.