summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDylan Araps2016-11-01 18:10:04 +1100
committerDylan Araps2016-11-01 18:10:04 +1100
commit328654d3f6cd12fe15e30a0ed27bdc2e544111df (patch)
tree51154320e1f1d2d222bcce71f2ed9f68f6152764
parentd4961d23a894bef69b5aefb441b68e3fb5d588ca (diff)
downloadaur-328654d3f6cd12fe15e30a0ed27bdc2e544111df.tar.gz
Update to neofetch 1.9
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD18
2 files changed, 27 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86a46a821361..865d0026c84b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,35 @@
# Generated by mksrcinfo v8
-# Tue Oct 4 00:59:59 UTC 2016
+# Tue Nov 1 07:09:33 UTC 2016
pkgbase = neofetch
pkgdesc = CLI script to show your system's info and display an image using w3m.
- pkgver = 1.8.1
+ pkgver = 1.9
pkgrel = 1
url = https://github.com/dylanaraps/neofetch
arch = any
license = MIT
depends = bash
+ optdepends = amarok: Current Song
+ optdepends = banshee: Current Song
optdepends = cmus: Current Song
+ optdepends = deadbeef: Current Song
optdepends = feh: Wallpaper Display
+ optdepends = gpmdp-remote: Current Song
optdepends = imagemagick: Image cropping / Thumbnail creation
- optdepends = mpc: Current Song
optdepends = moc: Current Song
+ optdepends = mpc: Current Song
optdepends = nitrogen: Wallpaper Display
+ optdepends = rhythmbox: Current Song
optdepends = scrot: Take a screenshot
+ optdepends = spotify: Current Song
optdepends = w3m: Display Images
+ optdepends = xdotool: See https://github.com/dylanaraps/neofetch/wiki/Images-in-the-terminal
optdepends = xorg-xdpyinfo: Resolution detection (Single Monitor)
- optdepends = xorg-xrandr: Resolution detection (Multi Monitor + Refresh rates)
optdepends = xorg-xprop: Desktop Environment and Window Manager
+ optdepends = xorg-xrandr: Resolution detection (Multi Monitor + Refresh rates)
+ optdepends = xorg-xwininfo: See https://github.com/dylanaraps/neofetch/wiki/Images-in-the-terminal
conflicts = neofetch-git
- source = https://github.com/dylanaraps/neofetch/archive/1.8.1.tar.gz
- md5sums = b59c9c2c86c1863937ee866a8d70c7c8
+ source = https://github.com/dylanaraps/neofetch/archive/1.9.tar.gz
+ md5sums = 950cd551842d31e118213fdb56fbd632
pkgname = neofetch
diff --git a/PKGBUILD b/PKGBUILD
index ee2fee840fb3..65a9cd914f2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
-# Maintainer: Dylan Araps <dyl@tfwno.gf>
+# Maintainer: Dylan Araps <dylan.araps@gmail.com>
pkgname=neofetch
-pkgver=1.8.1
+pkgver=1.9
pkgrel=1
pkgdesc="CLI script to show your system's info and display an image using w3m."
arch=('any')
@@ -9,20 +9,28 @@ license=('MIT')
conflicts=(${pkgname}-git)
depends=('bash')
optdepends=(
+ 'amarok: Current Song'
+ 'banshee: Current Song'
'cmus: Current Song'
+ 'deadbeef: Current Song'
'feh: Wallpaper Display'
+ 'gpmdp-remote: Current Song'
'imagemagick: Image cropping / Thumbnail creation'
- 'mpc: Current Song'
'moc: Current Song'
+ 'mpc: Current Song'
'nitrogen: Wallpaper Display'
+ 'rhythmbox: Current Song'
'scrot: Take a screenshot'
+ 'spotify: Current Song'
'w3m: Display Images'
+ 'xdotool: See https://github.com/dylanaraps/neofetch/wiki/Images-in-the-terminal'
'xorg-xdpyinfo: Resolution detection (Single Monitor)'
- 'xorg-xrandr: Resolution detection (Multi Monitor + Refresh rates)'
'xorg-xprop: Desktop Environment and Window Manager'
+ 'xorg-xrandr: Resolution detection (Multi Monitor + Refresh rates)'
+ 'xorg-xwininfo: See https://github.com/dylanaraps/neofetch/wiki/Images-in-the-terminal'
)
source=("https://github.com/dylanaraps/${pkgname}/archive/${pkgver}.tar.gz")
-md5sums=('b59c9c2c86c1863937ee866a8d70c7c8')
+md5sums=('950cd551842d31e118213fdb56fbd632')
package() {
cd "$srcdir/$pkgname-$pkgver/"