summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDylan Araps2017-01-23 14:56:14 +1100
committerDylan Araps2017-01-23 14:56:14 +1100
commit45a2e905a1b0f18ae1fbb79e40a39c83b19e0bb2 (patch)
tree352e9969f8156710ebc3105b36636e8b342fe62f
parent09669f0df4cb4991d9203252812d8f60e2a33cc3 (diff)
downloadaur-45a2e905a1b0f18ae1fbb79e40a39c83b19e0bb2.tar.gz
General: Update neofetch to 3.0
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD32
2 files changed, 16 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb32af80bacc..b16849068504 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,42 +1,28 @@
# Generated by mksrcinfo v8
-# Wed Dec 7 01:22:18 UTC 2016
+# Mon Jan 23 03:54:16 UTC 2017
pkgbase = neofetch
pkgdesc = A CLI system information tool written in BASH that supports displaying images.
- pkgver = 2.0.2
+ pkgver = 3.0
pkgrel = 1
url = https://github.com/dylanaraps/neofetch
arch = any
license = MIT
depends = bash
- optdepends = amarok: Current Song
- optdepends = banshee: Current Song
- optdepends = clementine: Current Song
- optdepends = cmus: Current Song
- optdepends = deadbeef: Current Song
optdepends = feh: Wallpaper Display
- optdepends = gnome-music: Current Song
- optdepends = gnome-screenshot: Take a screenshot
- optdepends = gpmdp-remote: Current Song
optdepends = imagemagick: Image cropping / Thumbnail creation / Take a screenshot
- optdepends = imlib2: Take a screenshot
- optdepends = lollypop: Current Song
- optdepends = maim: Take a screenshot
- optdepends = moc: Current Song
- optdepends = mpc: Current Song
optdepends = nitrogen: Wallpaper Display
- optdepends = pragha: Current Song
- optdepends = rhythmbox: Current Song
- optdepends = scrot: Take a screenshot
- optdepends = spotify: Current Song
optdepends = w3m: Display Images
+ optdepends = catimg: Display Images
+ optdepends = jp2a: Display Images
+ optdepends = libcaca: Display Images
optdepends = xdotool: See https://github.com/dylanaraps/neofetch/wiki/Images-in-the-terminal
optdepends = xorg-xdpyinfo: Resolution detection (Single Monitor)
optdepends = xorg-xprop: Desktop Environment and Window Manager
optdepends = xorg-xrandr: Resolution detection (Multi Monitor + Refresh rates)
optdepends = xorg-xwininfo: See https://github.com/dylanaraps/neofetch/wiki/Images-in-the-terminal
conflicts = neofetch-git
- source = https://github.com/dylanaraps/neofetch/archive/2.0.2.tar.gz
- md5sums = e4e2e118cde8de6f7e208d84c62604f5
+ source = https://github.com/dylanaraps/neofetch/archive/3.0.tar.gz
+ md5sums = 2d702613da6486d1c2345f683b09d4db
pkgname = neofetch
diff --git a/PKGBUILD b/PKGBUILD
index 03e1645d6dea..fcbc73c5d1e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,21 @@
# Maintainer: Dylan Araps <dylan.araps@gmail.com>
pkgname=neofetch
-pkgver=2.0.2
+pkgver=3.0
pkgrel=1
pkgdesc="A CLI system information tool written in BASH that supports displaying images."
arch=('any')
-url="https://github.com/dylanaraps/$pkgname"
+url="https://github.com/dylanaraps/${pkgname}"
license=('MIT')
conflicts=(${pkgname}-git)
depends=('bash')
optdepends=(
- 'amarok: Current Song'
- 'banshee: Current Song'
- 'clementine: Current Song'
- 'cmus: Current Song'
- 'deadbeef: Current Song'
'feh: Wallpaper Display'
- 'gnome-music: Current Song'
- 'gnome-screenshot: Take a screenshot'
- 'gpmdp-remote: Current Song'
'imagemagick: Image cropping / Thumbnail creation / Take a screenshot'
- 'imlib2: Take a screenshot'
- 'lollypop: Current Song'
- 'maim: Take a screenshot'
- 'moc: Current Song'
- 'mpc: Current Song'
'nitrogen: Wallpaper Display'
- 'pragha: Current Song'
- 'rhythmbox: Current Song'
- 'scrot: Take a screenshot'
- 'spotify: Current Song'
'w3m: Display Images'
+ 'catimg: Display Images'
+ 'jp2a: Display Images'
+ 'libcaca: Display Images'
'xdotool: See https://github.com/dylanaraps/neofetch/wiki/Images-in-the-terminal'
'xorg-xdpyinfo: Resolution detection (Single Monitor)'
'xorg-xprop: Desktop Environment and Window Manager'
@@ -37,10 +23,10 @@ optdepends=(
'xorg-xwininfo: See https://github.com/dylanaraps/neofetch/wiki/Images-in-the-terminal'
)
source=("https://github.com/dylanaraps/${pkgname}/archive/${pkgver}.tar.gz")
-md5sums=('e4e2e118cde8de6f7e208d84c62604f5')
+md5sums=('2d702613da6486d1c2345f683b09d4db')
package() {
- cd "$srcdir/$pkgname-$pkgver/"
- make DESTDIR="${pkgdir}" install
- install -D -m644 LICENSE.md "$pkgdir/usr/share/licenses/${pkgname}/LICENSE.md"
+ cd "${srcdir}/${pkgname}-${pkgver}/"
+ make DESTDIR="$pkgdir" install
+ install -D -m644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}