summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDylan2016-03-12 17:29:09 +1100
committerDylan2016-03-12 17:29:09 +1100
commitef0d210d8ebed2c17476609b4831033d6bd8d1f1 (patch)
treed46e44759eea214a7879cdb1e66b6910f2f93996
downloadaur-ef0d210d8ebed2c17476609b4831033d6bd8d1f1.tar.gz
Added files
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD31
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89e23a853c05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Sat Mar 12 06:28:38 UTC 2016
+pkgbase = neofetch
+ pkgdesc = CLI script to show your system's info and display an image using w3m.
+ pkgver = 1.4
+ pkgrel = 1
+ url = https://github.com/dylanaraps/neofetch
+ arch = any
+ license = MIT
+ depends = bash
+ depends = xorg-xprop
+ optdepends = cmus: Current Song
+ optdepends = feh: Wallpaper Display
+ optdepends = imagemagick: Image cropping / Thumbnail creation
+ optdepends = mpc: Current Song
+ optdepends = moc: Current Song
+ optdepends = nitrogen: Wallpaper Display
+ optdepends = scrot: Take a screenshot
+ optdepends = w3m: Display Images
+ optdepends = xorg-xdpyinfo: Resolution Detection
+ provides = neofetch
+ conflicts = neofetch
+ conflicts = neofetch-git
+ source = https://github.com/dylanaraps/neofetch/archive/1.4.tar.gz
+ md5sums = 61d9a0671eec40931adbbce878d3735d
+
+pkgname = neofetch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8dcb2a30baa2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Dylan Araps <dyl@tfwno.gf>
+pkgname=neofetch
+_pkgname=neofetch
+pkgver=1.4
+pkgrel=1
+pkgdesc="CLI script to show your system's info and display an image using w3m."
+arch=('any')
+url="https://github.com/dylanaraps/$pkgname"
+license=('MIT')
+provides=($_pkgname)
+conflicts=($_pkgname ${pkgname}-git)
+depends=('bash' 'xorg-xprop')
+optdepends=(
+ 'cmus: Current Song'
+ 'feh: Wallpaper Display'
+ 'imagemagick: Image cropping / Thumbnail creation'
+ 'mpc: Current Song'
+ 'moc: Current Song'
+ 'nitrogen: Wallpaper Display'
+ 'scrot: Take a screenshot'
+ 'w3m: Display Images'
+ 'xorg-xdpyinfo: Resolution Detection'
+)
+source=("https://github.com/dylanaraps/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('61d9a0671eec40931adbbce878d3735d')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/"
+ make install
+ install -D -m644 LICENSE.md "$pkgdir/usr/share/licenses/${pkgname}/LICENSE.md"
+}