summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDylan Araps2017-07-01 21:19:19 +1000
committerDylan Araps2017-07-01 21:19:19 +1000
commit3754ad3498df1cf896a4c854bd942a87fcf6c267 (patch)
treed20d67977cd393546ccf2d4fcfb0565b3fee5a8d
parent8d651fc40bda9599462afefad353664842fcb0d2 (diff)
downloadaur-3754ad3498df1cf896a4c854bd942a87fcf6c267.tar.gz
Update PKGBUILD to use install.sh
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD21
2 files changed, 23 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13183070b210..a061bb5d2ebf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,26 @@
# Generated by mksrcinfo v8
-# Sat Mar 12 22:25:47 UTC 2016
+# Sat Jul 1 11:18:59 UTC 2017
pkgbase = neofetch-git
- pkgdesc = CLI script to show your system's info and display an image using w3m.
- pkgver = 1.0.r26.g9bde0eb
+ pkgdesc = A CLI system information tool written in BASH that supports displaying images.
+ pkgver = 3.2.0.r28.g2eca41d
pkgrel = 1
url = https://github.com/dylanaraps/neofetch
arch = any
license = MIT
makedepends = git
depends = bash
- depends = xorg-xprop
- optdepends = cmus: Current Song
optdepends = feh: Wallpaper Display
- optdepends = imagemagick: Image cropping / Thumbnail creation
- optdepends = mpc: Current Song
- optdepends = moc: Current Song
+ optdepends = imagemagick: Image cropping / Thumbnail creation / Take a screenshot
optdepends = nitrogen: Wallpaper Display
- optdepends = scrot: Take a screenshot
optdepends = w3m: Display Images
- optdepends = xorg-xdpyinfo: Resolution Detection
+ optdepends = catimg: Display Images
+ optdepends = jp2a: Display Images
+ optdepends = libcaca: Display Images
+ optdepends = xdotool: See https://github.com/dylanaraps/neofetch/wiki/Images-in-the-terminal
+ optdepends = xorg-xdpyinfo: Resolution detection (Single Monitor)
+ optdepends = xorg-xprop: Desktop Environment and Window Manager
+ optdepends = xorg-xrandr: Resolution detection (Multi Monitor + Refresh rates)
+ optdepends = xorg-xwininfo: See https://github.com/dylanaraps/neofetch/wiki/Images-in-the-terminal
provides = neofetch
conflicts = neofetch
source = neofetch-git::git+https://github.com/dylanaraps/neofetch.git
diff --git a/PKGBUILD b/PKGBUILD
index 6916e3b6485b..48103ef3b439 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
# Maintainer: Dylan Araps <dyl@tfwno.gf>
pkgname=neofetch-git
_pkgname=neofetch
-pkgver=1.0.r26.g9bde0eb
+pkgver=3.2.0.r28.g2eca41d
pkgrel=1
-pkgdesc="CLI script to show your system's info and display an image using w3m."
+pkgdesc="A CLI system information tool written in BASH that supports displaying images."
arch=('any')
-url="https://github.com/dylanaraps/neofetch"
+url="https://github.com/dylanaraps/${_pkgname}"
license=('MIT')
provides=($_pkgname)
conflicts=($_pkgname)
depends=('bash')
optdepends=(
- 'cmus: Current Song'
'feh: Wallpaper Display'
- 'imagemagick: Image cropping / Thumbnail creation'
- 'mpc: Current Song'
- 'moc: Current Song'
+ 'imagemagick: Image cropping / Thumbnail creation / Take a screenshot'
'nitrogen: Wallpaper Display'
- 'scrot: Take a screenshot'
'w3m: Display Images'
+ 'catimg: Display Images'
+ 'jp2a: Display Images'
+ 'libcaca: Display Images'
+ 'xdotool: See https://github.com/dylanaraps/neofetch/wiki/Images-in-the-terminal'
'xorg-xdpyinfo: Resolution detection (Single Monitor)'
- 'xorg-xrandr: Resolution detection (Multi Monitor + Refresh rates)'
'xorg-xprop: Desktop Environment and Window Manager'
+ 'xorg-xrandr: Resolution detection (Multi Monitor + Refresh rates)'
+ 'xorg-xwininfo: See https://github.com/dylanaraps/neofetch/wiki/Images-in-the-terminal'
)
makedepends=('git')
source=("$pkgname::git+https://github.com/dylanaraps/neofetch.git")
@@ -34,6 +35,6 @@ pkgver() {
package() {
cd $pkgname
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ./install.sh
install -D -m644 LICENSE.md "$pkgdir/usr/share/licenses/neofetch/LICENSE.md"
}