summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDylan2016-01-09 13:23:25 +1100
committerDylan2016-01-09 13:23:25 +1100
commit44cf1331f95c9bf81c4f1f73e49d99089327c132 (patch)
treefc9331643ff4c199edffa12dc0f702ac3a5ee100
downloadaur-44cf1331f95c9bf81c4f1f73e49d99089327c132.tar.gz
Added files
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD32
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0aef56ba857
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Sat Jan 9 02:19:42 UTC 2016
+pkgbase = fetch-git
+ pkgdesc = CLI script to show your system's info and display an image using w3m.
+ pkgver = 0.2.1.r88.gea3508f
+ pkgrel = 1
+ url = https://github.com/dylanaraps/fetch
+ arch = any
+ makedepends = git
+ depends = bash
+ depends = ncurses
+ optdepends = w3m: Display Images
+ optdepends = imagemagick: Image cropping / Thumbnail creation
+ optdepends = feh: Wallpaper Displau
+ optdepends = mpc: Current Song Displau
+ optdepends = xorg-xdpyinfo: Resolution Detection
+ optdepends = wmctrl: Accurate window manager detection
+ provides = fetch
+ conflicts = fetch
+ source = fetch-git::git+https://github.com/dylanaraps/fetch.git
+ md5sums = SKIP
+
+pkgname = fetch-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa8d132a4160
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Dylan Araps <dyl@tfwno.gf>
+pkgname=fetch-git
+_pkgname=fetch
+pkgver=0.2.1.r88.gea3508f
+pkgrel=1
+pkgdesc="CLI script to show your system's info and display an image using w3m."
+arch=('any')
+url="https://github.com/dylanaraps/fetch"
+provides=($_pkgname)
+conflicts=($_pkgname)
+depends=('bash' 'ncurses')
+optdepends=(
+ 'w3m: Display Images'
+ 'imagemagick: Image cropping / Thumbnail creation'
+ 'feh: Wallpaper Displau'
+ 'mpc: Current Song Displau'
+ 'xorg-xdpyinfo: Resolution Detection'
+ 'wmctrl: Accurate window manager detection'
+)
+makedepends=('git')
+source=("$pkgname::git+https://github.com/dylanaraps/fetch.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags --long | sed -r -e 's,^[^0-9]*,,;s,([^-]*-g),r\1,;s,[-_],.,g'
+}
+
+package() {
+ cd $pkgname
+ install -Dm755 "fetch" "$pkgdir/usr/bin/fetch"
+}