summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDylan2016-02-28 11:52:30 +1100
committerDylan2016-02-28 11:52:30 +1100
commit89f58ed4ba426be1b500c97fd82bc7d5971d6781 (patch)
tree9537b9f007aefb31cc64b9fe2b119ad818b62154
parente843e181839f13c746437ea9fa55bd0c56041cdb (diff)
downloadaur-89f58ed4ba426be1b500c97fd82bc7d5971d6781.tar.gz
Rename fetch to neofetch
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD13
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de7a84258079..9cbda3c54031 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,28 @@
# Generated by mksrcinfo v8
-# Wed Feb 17 07:10:27 UTC 2016
-pkgbase = fetch-git
+# Sun Feb 28 00:52:05 UTC 2016
+pkgbase = neofetch-git
pkgdesc = CLI script to show your system's info and display an image using w3m.
pkgver = 1.0.r26.g9bde0eb
pkgrel = 1
- url = https://github.com/dylanaraps/fetch
+ url = https://github.com/dylanaraps/neofetch
arch = any
license = MIT
makedepends = git
depends = bash
- depends = ncurses
depends = xorg-xprop
optdepends = cmus: Current Song
optdepends = feh: Wallpaper Display
optdepends = imagemagick: Image cropping / Thumbnail creation
optdepends = mpc: Current Song
+ optdepends = moc: Current Song
optdepends = nitrogen: Wallpaper Display
optdepends = scrot: Take a screenshot
optdepends = w3m: Display Images
optdepends = xorg-xdpyinfo: Resolution Detection
- provides = fetch
- conflicts = fetch
- source = fetch-git::git+https://github.com/dylanaraps/fetch.git
+ provides = neofetch
+ conflicts = neofetch
+ source = neofetch-git::git+https://github.com/dylanaraps/neofetch.git
md5sums = SKIP
-pkgname = fetch-git
+pkgname = neofetch-git
diff --git a/PKGBUILD b/PKGBUILD
index 2fd447e8a8fc..af431da9325d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
# Maintainer: Dylan Araps <dyl@tfwno.gf>
-pkgname=fetch-git
-_pkgname=fetch
+pkgname=neofetch-git
+_pkgname=neofetch
pkgver=1.0.r26.g9bde0eb
pkgrel=1
pkgdesc="CLI script to show your system's info and display an image using w3m."
arch=('any')
-url="https://github.com/dylanaraps/fetch"
+url="https://github.com/dylanaraps/neofetch"
license=('MIT')
provides=($_pkgname)
conflicts=($_pkgname)
-depends=('bash' 'ncurses' 'xorg-xprop')
+depends=('bash' 'xorg-xprop')
optdepends=(
'cmus: Current Song'
'feh: Wallpaper Display'
'imagemagick: Image cropping / Thumbnail creation'
'mpc: Current Song'
+ 'moc: Current Song'
'nitrogen: Wallpaper Display'
'scrot: Take a screenshot'
'w3m: Display Images'
'xorg-xdpyinfo: Resolution Detection'
)
makedepends=('git')
-source=("$pkgname::git+https://github.com/dylanaraps/fetch.git")
+source=("$pkgname::git+https://github.com/dylanaraps/neofetch.git")
md5sums=('SKIP')
pkgver() {
@@ -32,5 +33,5 @@ pkgver() {
package() {
cd $pkgname
make DESTDIR="$pkgdir" install
- install -D -m644 LICENSE.md "$pkgdir/usr/share/licenses/fetch/LICENSE.md"
+ install -D -m644 LICENSE.md "$pkgdir/usr/share/licenses/neofetch/LICENSE.md"
}