summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDylan2016-01-31 16:52:15 +1100
committerDylan2016-01-31 16:52:15 +1100
commitf1cdb4b6915390272d95f7b0a6e6d7cf21721cb7 (patch)
tree0b7c3db4cc23ed470d893cfbff1dd48207e16e5a
parent4166d886b66f299ba2f87d27b796623a339de185 (diff)
downloadaur-f1cdb4b6915390272d95f7b0a6e6d7cf21721cb7.tar.gz
Swap to using the makefile
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD23
2 files changed, 11 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7098a8f1f0d6..75de013893de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Jan 30 09:03:51 UTC 2016
+# Sun Jan 31 05:52:01 UTC 2016
pkgbase = fetch-git
pkgdesc = CLI script to show your system's info and display an image using w3m.
pkgver = 1.0.r26.g9bde0eb
diff --git a/PKGBUILD b/PKGBUILD
index 90b397b91983..d6e7bd313b48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,15 +11,15 @@ provides=($_pkgname)
conflicts=($_pkgname)
depends=('bash' 'ncurses')
optdepends=(
- 'cmus: Current Song'
- 'feh: Wallpaper Display'
- 'imagemagick: Image cropping / Thumbnail creation'
- 'mpc: Current Song'
- 'nitrogen: Wallpaper Display'
- 'scrot: Take a screenshot'
- 'w3m: Display Images'
- 'wmctrl: Accurate window manager detection'
- 'xorg-xdpyinfo: Resolution Detection'
+ 'cmus: Current Song'
+ 'feh: Wallpaper Display'
+ 'imagemagick: Image cropping / Thumbnail creation'
+ 'mpc: Current Song'
+ 'nitrogen: Wallpaper Display'
+ 'scrot: Take a screenshot'
+ 'w3m: Display Images'
+ 'wmctrl: Accurate window manager detection'
+ 'xorg-xdpyinfo: Resolution Detection'
)
makedepends=('git')
source=("$pkgname::git+https://github.com/dylanaraps/fetch.git")
@@ -32,9 +32,6 @@ pkgver() {
package() {
cd $pkgname
- install -D -m755 fetch "$pkgdir/usr/bin/fetch"
+ make DESTDIR="$pkgdir" install
install -D -m644 LICENSE.md "$pkgdir/usr/share/licenses/fetch/LICENSE.md"
- install -D -m755 config "$pkgdir/usr/share/fetch/config"
- install -d -m755 ascii/distro/ "$pkgdir/usr/share/fetch/ascii/distro"
- install -D -m755 ascii/distro/* "$pkgdir/usr/share/fetch/ascii/distro/"
}