summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Carter2016-11-29 09:37:00 +0000
committerMark Carter2016-11-29 09:37:00 +0000
commitcf7f60a8e0021eebcf1d0392a93cacbd11c2419e (patch)
treecade6fe80af44b86bb76bfb3c22e2a58d3d7bfcf
downloadaur-cf7f60a8e0021eebcf1d0392a93cacbd11c2419e.tar.gz
neoleo added as a new package
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dbc062a608a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = neoleo
+ pkgdesc = Fork of the GNU oleo lightweight spreadsheet
+ pkgver = 3.0.1
+ pkgrel = 1
+ url = https://github.com/blippy/neoleo
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = https://github.com/blippy/neoleo/releases/download/v3.0.1/neoleo-3.0.1.tar.gz
+ md5sums = 802229a004de2c4a4b0efea78355f655
+
+pkgname = neoleo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ca52e618bdf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Mark Carter <alt.mcarter@gmail.com>
+pkgname=neoleo
+pkgver=3.0.1
+pkgrel=1
+pkgdesc="Fork of the GNU oleo lightweight spreadsheet"
+arch=('i686' 'x86_64')
+url="https://github.com/blippy/neoleo"
+license=('GPL')
+source=("https://github.com/blippy/neoleo/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
+md5sums=('802229a004de2c4a4b0efea78355f655')
+
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}