summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrostworx2023-12-04 16:15:20 +0100
committerfrostworx2023-12-04 16:15:20 +0100
commit233fb3453fa3ff5548f34b07f0b128e2de180187 (patch)
treefaf12a49b63a780e24a8af7358fe19fc32788359
parent807a509e20ced009d4434cc50748bf88580af522 (diff)
downloadaur-233fb3453fa3ff5548f34b07f0b128e2de180187.tar.gz
new upstream, new maint
-rw-r--r--PKGBUILD26
-rw-r--r--neolink.service4
-rw-r--r--neolink.toml56
3 files changed, 17 insertions, 69 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc45c69e4518..544afc22c3de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
-# Maintainer: Gleb Sinyavskiy <zhulik.gleb@gmail.com>
+# Maintainer: Marcel Unbehaun <f.rostze.ux at gmail dot com>
pkgname=neolink-git
_pkgname=neolink
-pkgver=0.3.0.cf54129
+pkgver=0.6.3.rc.1.r1.g4a94a2d
pkgrel=1
pkgdesc="An RTSP bridge to Reolink IP cameras."
arch=('x86_64')
-url="https://github.com/thirtythreeforty/$_pkgname"
+url="https://github.com/QuantumEntangledAndy/${_pkgname}"
license=('AGPL3')
-depends=('gst-rtsp-server')
+depends=('gst-rtsp-server' 'gst-plugins-bad' 'gst-plugins-base' 'gst-plugins-good')
makedepends=('git' 'rust')
-source=("git+https://github.com/thirtythreeforty/$_pkgname.git"
- "$_pkgname.toml"
+source=("git+https://github.com/QuantumEntangledAndy/$_pkgname.git"
"$_pkgname.sysusers"
"$_pkgname.service")
sha256sums=("SKIP"
@@ -18,7 +17,12 @@ sha256sums=("SKIP"
"27d0ecc90731e703228efd1c922421cab01c6495943b6f07a97a8c20518c8a17"
"2316a242dede941daf121261652a67ae69bc1922415b6c2238f558cd584dda4a")
-backup=("etc/$_pkgname.toml")
+backup=("etc/${_pkgname}.toml")
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
build() {
cd "$_pkgname"
@@ -26,8 +30,8 @@ build() {
}
package() {
- install -Dm755 "$_pkgname/target/release/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
- install -Dm644 "$_pkgname.toml" "$pkgdir/etc/$_pkgname.toml"
- install -Dm 644 "$_pkgname.sysusers" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
- install -Dm 644 "$_pkgname.service" -t "${pkgdir}/usr/lib/systemd/system"
+ install -Dm755 "${_pkgname}/target/release/${_pkgname}" "$pkgdir/usr/bin/${_pkgname}"
+ install -Dm644 "${_pkgname}/sample_config.toml" "$pkgdir/etc/${_pkgname}.toml"
+ install -Dm 644 "${_pkgname}.sysusers" "${pkgdir}/usr/lib/sysusers.d/${_pkgname}.conf"
+ install -Dm 644 "${_pkgname}.service" -t "${pkgdir}/usr/lib/systemd/system"
}
diff --git a/neolink.service b/neolink.service
index a9a0c21339e7..2ee5dcc7abcc 100644
--- a/neolink.service
+++ b/neolink.service
@@ -1,14 +1,14 @@
[Install]
-After=network.target network-online.target nss-lookup.target
WantedBy=multi-user.target
[Unit]
Description=An RTSP bridge to Reolink IP cameras.
+After=network.target network-online.target nss-lookup.target
[Service]
Type=simple
User=neolink
Group=neolink
-ExecStart=/usr/bin/neolink --config /etc/neolink.toml
+ExecStart=/usr/bin/neolink rtsp --config=/etc/neolink.toml
Restart=always
diff --git a/neolink.toml b/neolink.toml
deleted file mode 100644
index cbe4fa244048..000000000000
--- a/neolink.toml
+++ /dev/null
@@ -1,56 +0,0 @@
-# A bind value of 0.0.0.0 means any network this computer can access
-# You can chage this to a specfic network e.g. "192.168.1.101" here
-# Or to no networks e.g. this computer only "127.0.0.1"
-bind = "0.0.0.0"
-
-# Default port is 8554 but you can change it by uncommenting the following
-# bind_port = 8554
-
-# Uncomment the following and supply a path to a valid PEM
-# to activate TLS encryption.
-# The PEM should contain the certificate and the private key
-# If TLS is activated you must connect with "rtsps://" and not "rtsp://"
-# certificate = "/path/to/pem/with/cert/and/key"
-
-# Choose if the client is required to provide a certificate signed by the server's CA.
-# none|requested|required - default none
-# tls_client_auth = "required"
-
-# You can password protect the rtsp server mount points by adding users
-# like the following me and someone. If you do not add [[users]]
-# then anyone can connect without a password or username
-# To access such a stream try using a url such as "rtsp://me:mepass@192.168.1.101/driveway"
-
-# [[users]]
-# name = "me"
-# pass = "mepass"
-#
-# [[users]]
-# name = "someone"
-# pass = "someonepass"
-
-
-[[cameras]]
-name = "driveway"
-username = "admin"
-password = "12345678"
-address = "192.168.1.187:9000"
-
-# By default any of the users can connect (or anyone at all if no users are specfied)
-# You can uncomment the following to permit only specfic users
-# permitted_users = [ "me" ]
-
-# By default "both" "mainStream" and "subStream" are connected
-# If your device has user connection limits try a single stream instead.
-# stream = "mainStream"
-
-
-[[cameras]]
-name = "storage shed"
-username = "admin"
-password = "987654321"
-address = "192.168.1.245:9000"
-
-# By default channel_id = 0. Eg the first connected camera on the device
-# Note this counts from 0. An 8 channel NVR would have channels 0 through 7
-# channel_id = 1