aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2019-12-08 08:16:45 +0100
committerKlaus Alexander Seistrup2019-12-08 08:16:45 +0100
commit112c0a2ccea1f5984960c7160d4228281ce59363 (patch)
tree0ae1f1d381a00e6e68ba29d86b7080c3d1450e2d
parentaca5e191358ca08547f711767fdedc50e3cab4c3 (diff)
downloadaur-112c0a2ccea1f5984960c7160d4228281ce59363.tar.gz
deleted fix-vfolder-segfault.patch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--fix-vfolder-segfault.patch39
3 files changed, 2 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd6b78716beb..60452bf97399 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = neomutt-autocrypt
pkgdesc = A version of community/neomutt with added autocrypt
pkgver = 20191129
- pkgrel = 5
+ pkgrel = 6
url = https://neomutt.org/
arch = x86_64
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index 7285851823bf..60fbb23deb13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ _srcname=neomutt
# This package should mirror community/neomutt,
# except for added autocrypt
pkgver=20191129
-pkgrel=5
+pkgrel=6
pkgdesc='A version of community/neomutt with added autocrypt'
url='https://neomutt.org/'
license=('GPL')
diff --git a/fix-vfolder-segfault.patch b/fix-vfolder-segfault.patch
deleted file mode 100644
index d21fdc2bbd9d..000000000000
--- a/fix-vfolder-segfault.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From e22f6a1ad4f83942a7ea2240337b99a2ee9a3e89 Mon Sep 17 00:00:00 2001
-From: Richard Russon <rich@flatcap.org>
-Date: Mon, 2 Dec 2019 13:02:49 +0000
-Subject: [PATCH] fix: crash resizing notmuch mailbox
-
-Fixes: #2014
----
- mx.c | 2 +-
- notmuch/mutt_notmuch.c | 4 ++--
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/mx.c b/mx.c
-index 4a5c1c55b..1e13fd78a 100644
---- a/mx.c
-+++ b/mx.c
-@@ -1181,7 +1181,7 @@ void mx_alloc_memory(struct Mailbox *m)
- m->emails = mutt_mem_calloc(m->email_max, sizeof(struct Email *));
- m->v2r = mutt_mem_calloc(m->email_max, sizeof(int));
- }
-- for (int i = m->msg_count; i < m->email_max; i++)
-+ for (int i = m->email_max - 25; i < m->email_max; i++)
- {
- m->emails[i] = NULL;
- m->v2r[i] = -1;
-diff --git a/notmuch/mutt_notmuch.c b/notmuch/mutt_notmuch.c
-index 1078d4432..2c98d07c4 100644
---- a/notmuch/mutt_notmuch.c
-+++ b/notmuch/mutt_notmuch.c
-@@ -1980,8 +1980,8 @@ static int nm_mbox_check_stats(struct Mailbox *m, int flags)
-
- /* all emails */
- m->msg_count = count_query(db, db_query, limit);
-- m->email_max = MAX(m->email_max, m->msg_count);
-- mx_alloc_memory(m);
-+ while (m->email_max < m->msg_count)
-+ mx_alloc_memory(m);
-
- // holder variable for extending query to unread/flagged
- char *qstr = NULL;