summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Harding2024-03-23 15:34:11 -0700
committerTim Harding2024-03-23 15:34:11 -0700
commit1f2619fd6108a6891fe0f95f0f1e2b0e633283ae (patch)
tree8fc6a6141644f3b47861923252a9e48d534de66a
downloadaur-1f2619fd6108a6891fe0f95f0f1e2b0e633283ae.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2eba5b07dcc1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = neophyte-bin
+ pkgdesc = A WebGPU-rendered Neovim GUI
+ pkgver = 0.2.4
+ pkgrel = 1
+ url = https://github.com/tim-harding/neophyte
+ arch = x86_64
+ license = MIT
+ provides = neophyte=0.2.4
+ conflicts = neophyte
+ conflicts = neophyte-git
+ source = neophyte::https://github.com/tim-harding/neophyte/releases/download/0.2.4/neophyte-bin-linux
+ source = README.md::https://github.com/tim-harding/neophyte
+ sha256sums = SKIP
+
+pkgname = neophyte-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b35c3113c3fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Tim Harding <tim@timharding.co>
+
+pkgname='neophyte-bin'
+pkgver='0.2.4'
+pkgrel=1
+pkgdesc="A WebGPU-rendered Neovim GUI"
+arch=('x86_64')
+url="https://github.com/tim-harding/neophyte"
+license=('MIT')
+provides=("neophyte=$pkgver")
+conflicts=('neophyte' 'neophyte-git')
+source=(
+ "neophyte::$url/releases/download/$pkgver/$pkgname-linux"
+ "README.md::$url"
+)
+sha256sums=('SKIP') # TODO: Add checksums
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim: ts=4 sts=4 sw=4 et