summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Harding2024-03-23 16:20:01 -0700
committerTim Harding2024-03-23 16:20:01 -0700
commit960d2f1ab8a256e34905eec97ed555b744d146b4 (patch)
tree08b10c95b8afc937835363257b343b566bb493ed
parentd3aa755e6b468a06cfaf0aacee2cc1f22ff98554 (diff)
downloadaur-960d2f1ab8a256e34905eec97ed555b744d146b4.tar.gz
Fixed MIT license placement
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD29
2 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18a32dc77fdc..fd613a6d8613 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = neophyte-git
pkgdesc = A WebGPU-rendered Neovim GUI
- pkgver = 0.2.4.r0.gc62a622
+ pkgver = 0.2.5.r0.g9b5e62f
pkgrel = 1
url = https://github.com/tim-harding/neophyte
arch = x86_64
@@ -13,7 +13,7 @@ pkgbase = neophyte-git
depends = freetype2
depends = gcc-libs
depends = glibc
- provides = neophyte=0.2.4.r0.gc62a622
+ provides = neophyte=0.2.5.r0.g9b5e62f
conflicts = neophyte-bin
conflicts = neophyte
source = neophyte::git+https://github.com/tim-harding/neophyte.git
diff --git a/PKGBUILD b/PKGBUILD
index c4e0f42b70cd..308cae921b4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tim Harding <tim@timharding.co>
pkgname='neophyte-git'
-pkgver=0.2.4.r0.gc62a622
+pkgver=0.2.5.r0.g9b5e62f
pkgrel=1
pkgdesc='A WebGPU-rendered Neovim GUI'
arch=('x86_64' 'i686' 'aarch64')
@@ -14,6 +14,12 @@ conflicts=('neophyte-bin' 'neophyte')
source=("neophyte::git+$url.git")
sha256sums=('SKIP')
+# See for best practices:
+# https://wiki.archlinux.org/title/Rust_package_guidelines
+#
+# Test in a clean chroot with `namcap PKGBUILD && extra-x86_64-build`:
+# https://wiki.archlinux.org/title/DeveloperWiki:Building_in_a_clean_chroot
+
# From https://wiki.archlinux.org/title/VCS_package_guidelines#Package_naming
pkgver() {
cd "neophyte"
@@ -53,15 +59,20 @@ package() {
-D --target-directory="$pkgdir/usr/share/applications/" \
assets/neophyte.desktop
- install \
- --mode=0644 \
- -D --target-directory="$pkgdir/usr/share/licenses/neophyte/" \
- LICENSE
+ # Installing to both locations because makepkg complains about uncommon
+ # license identifier MIT needing a license file in neophyte-git
+ for dst in neophyte $pkgname
+ do
+ install \
+ --mode=0644 \
+ -D --target-directory="$pkgdir/usr/share/licenses/$dst/" \
+ LICENSE
- install \
- --mode=0644 \
- -D --target-directory="$pkgdir/usr/share/doc/neophyte/" \
- README.md
+ install \
+ --mode=0644 \
+ -D --target-directory="$pkgdir/usr/share/doc/$dst/" \
+ README.md
+ done
}
# vim: ts=4 sts=4 sw=4 et