summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Robinson2020-12-21 14:59:20 -0500
committerNathan Robinson2020-12-21 14:59:20 -0500
commit85f1bdd32756e66e81e50e002c4bcd7cb09df6da (patch)
treea09ed3ffa9c7f12714cb609af852e509b2e40ec7
parent5e5bd495e2e04090fddc935f4502f4612d1024b3 (diff)
downloadaur-85f1bdd32756e66e81e50e002c4bcd7cb09df6da.tar.gz
use optdepends, hopefully works better with yay at 14:59 of 2020-12-21
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 348e733d22f7..d86ab48586b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = neopo-git
pkgdesc = A lightweight solution for local Particle development.
- pkgver = r262.aff8b64
+ pkgver = r265.650bb7c
pkgrel = 1
url = https://github.com/nrobinson2000/neopo
arch = x86_64
@@ -15,9 +15,9 @@ pkgbase = neopo-git
provides = neopo
source = git+https://github.com/nrobinson2000/neopo.git
md5sums = SKIP
- depends_x86_64 = lib32-glibc
- depends_aarch64 = dfu-util
- depends_aarch64 = nodejs
+ optdepends_x86_64 = lib32-glibc: gcc-arm 5.3.1 support
+ optdepends_aarch64 = dfu-util: flash devices with DFU
+ optdepends_aarch64 = nodejs: support for particle-cli
pkgname = neopo-git
diff --git a/PKGBUILD b/PKGBUILD
index 79cde2d984c4..0db1255dfe14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=neopo-git
_gitname="neopo"
-pkgver=r262.aff8b64
+pkgver=r265.650bb7c
pkgrel=1
pkgdesc="A lightweight solution for local Particle development."
arch=('x86_64' 'aarch64')
@@ -13,8 +13,10 @@ source=('git+https://github.com/nrobinson2000/neopo.git')
md5sums=('SKIP')
makedepends=('python-setuptools')
depends=('python' 'vim' 'git' 'perl-archive-zip' 'libusb')
-depends_x86_64=('lib32-glibc')
-depends_aarch64=('dfu-util' 'nodejs')
+
+optdepends_x86_64=('lib32-glibc: gcc-arm 5.3.1 support')
+optdepends_aarch64=('dfu-util: flash devices with DFU'
+ 'nodejs: support for particle-cli')
pkgver() {
cd "$_gitname"