summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Brassat2021-07-30 11:59:47 +0200
committerChristian Brassat2021-07-30 11:59:47 +0200
commite7ef61d72adfb96e4e6bd1190bfd099637e95de7 (patch)
treed943bae6796290f8be0acb3353eddc42e890f338
downloadaur-e7ef61d72adfb96e4e6bd1190bfd099637e95de7.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
-rw-r--r--neoray.desktop9
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..705af08b3e10
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = neoray-git
+ pkgdesc = Go GUI for neovim
+ pkgver = r295.04af3e7
+ pkgrel = 1
+ url = https://github.com/hismailbulut/neoray
+ arch = any
+ license = MIT
+ depends = go
+ source = git+https://github.com/hismailbulut/neoray.git
+ source = neoray.desktop
+ md5sums = SKIP
+ md5sums = f10c9d8fdbf4e7b468770d23b3fb53a3
+
+pkgname = neoray-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..450506e884d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Christian Brassat <christian.brassat@gmail.com>
+
+_pkgbase=neoray
+pkgname=${_pkgbase}-git
+pkgver=r295.04af3e7
+pkgrel=1
+pkgdesc="Go GUI for neovim"
+arch=('any')
+url="https://github.com/hismailbulut/neoray"
+license=('MIT')
+depends=('neovim')
+makedepends=('go')
+conflicts=()
+source=('git+https://github.com/hismailbulut/neoray.git'
+ 'neoray.desktop')
+md5sums=('SKIP'
+ 'f10c9d8fdbf4e7b468770d23b3fb53a3')
+
+pkgver() {
+ cd $_pkgbase
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $_pkgbase
+ make release
+}
+
+package() {
+ install -Dm 644 ${_pkgbase}/LICENSE ${pkgdir}/usr/share/licenses/${_pkgbase}/LICENSE
+ install -Dm 644 ${_pkgbase}.desktop ${pkgdir}/usr/share/applications/${_pkgbase}.desktop
+ install -Dm 755 ${_pkgbase}/bin/neoray ${pkgdir}/usr/bin/${_pkgbase}
+}
diff --git a/neoray.desktop b/neoray.desktop
new file mode 100644
index 000000000000..a09054d22b46
--- /dev/null
+++ b/neoray.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Exec=neoray %F
+Icon=nvim
+Name=Neoray (nvim)
+Keywords=Text;Editor;
+Categories=Utility;TextEditor;
+Comment=A Go GUI client for Neovim
+MimeType=text/english;text/plain;text/x-makefile;text/x-c++hdr;text/x-c++src;text/x-chdr;text/x-csrc;text/x-java;text/x-moc;text/x-pascal;text/x-tcl;text/x-tex;application/x-shellscript;text/x-c;text/x-c++;