summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEggbertx2021-12-15 21:23:49 -0800
committerEggbertx2021-12-15 21:23:49 -0800
commit320000d8ea961a8623e2453f84a88b981684239b (patch)
tree662ef70bf73202eb98a69036f8422fca66107971
parent8b6b2f5f50ab957811823ce58e66d177d1e09911 (diff)
downloadaur-320000d8ea961a8623e2453f84a88b981684239b.tar.gz
update to v5.7.0, rename pkg to neosphere
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rwxr-xr-xPKGBUILD15
3 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f79f7caea11e..4d5ba6a677eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
-pkgbase = minisphere
+pkgbase = neosphere
pkgdesc = A fast, lightweight implementation of the Sphere game engine
- pkgver = 5.6.3
+ pkgver = 5.7.0
pkgrel = 1
- url = https://github.com/fatcerberus/sphere
- arch = i686
+ url = https://github.com/fatcerberus/neosphere
arch = x86_64
license = BSD
depends = allegro
depends = libmng
depends = libChakraCore.so
- source = https://github.com/fatcerberus/minisphere/archive/v5.6.3.tar.gz
- sha256sums = 09b573552ed7f1410e432043ed75f75aa6909486ed5cadc8d5799dc1dac9a85e
+ replaces = minisphere
+ source = https://github.com/fatcerberus/neosphere/archive/v5.7.0.tar.gz
+ sha256sums = 5a8284fdedd3a57edb9c9ab12a7d1483f317919992802ca49efa434c125e3f16
-pkgname = minisphere
+pkgname = neosphere
diff --git a/.gitignore b/.gitignore
index ad398d229220..3226270dbdef 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
pkg/
src/
minisphere-*
+neosphere-*
v*
diff --git a/PKGBUILD b/PKGBUILD
index a23118e19151..83cf0d43e585 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: Joshua Merrell <joshuamerrell@gmail.com>
-pkgname=minisphere
-pkgver=5.6.3
+pkgname=neosphere
+pkgver=5.7.0
pkgrel=1
pkgdesc="A fast, lightweight implementation of the Sphere game engine"
-arch=('i686' 'x86_64')
-url="https://github.com/fatcerberus/sphere"
+arch=('x86_64')
+url="https://github.com/fatcerberus/neosphere"
license=('BSD')
depends=('allegro' 'libmng' 'libChakraCore.so')
+replaces=('minisphere')
source=(https://github.com/fatcerberus/$pkgname/archive/v$pkgver.tar.gz)
-sha256sums=('09b573552ed7f1410e432043ed75f75aa6909486ed5cadc8d5799dc1dac9a85e')
+sha256sums=('5a8284fdedd3a57edb9c9ab12a7d1483f317919992802ca49efa434c125e3f16')
build() {
- cd sphere-$pkgver
+ cd neosphere-$pkgver
make
}
package() {
- cd "sphere-$pkgver"
+ cd "neosphere-$pkgver"
make DESTDIR="$pkgdir" install
}