summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpeeweep2021-03-05 16:49:53 +0000
committerpeeweep2021-03-06 00:49:53 +0800
commit2eef519d9906867add0a9d2e39aa639347c7b3a1 (patch)
tree9ad420f822f9421abb9a329371ea33f7b69da632
parent80b5b3a6857dfddb1cfe50adea272b1a459944c1 (diff)
downloadaur-2eef519d9906867add0a9d2e39aa639347c7b3a1.tar.gz
bump version 0.7.0
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Remove-unnecessary-braces-around-if-condition.patch30
-rw-r--r--PKGBUILD11
3 files changed, 7 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3d7a5f7a232..678df2729129 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = neovide
pkgdesc = No Nonsense Neovim Client in Rust
- pkgver = 0.6.0
- pkgrel = 8
+ pkgver = 0.7.0
+ pkgrel = 1
url = https://github.com/Kethku/neovide
arch = x86_64
license = MIT
@@ -18,10 +18,8 @@ pkgbase = neovide
optdepends = vulkan-intel: vulkan support for intel
provides = neovide
conflicts = neovide-git
- source = neovide-0.6.0.tar.gz::https://github.com/Kethku/neovide/archive/0.6.0.tar.gz
- source = 0001-Remove-unnecessary-braces-around-if-condition.patch
+ source = neovide-0.7.0.tar.gz::https://github.com/Kethku/neovide/archive/0.7.0.tar.gz
sha256sums = 4daaad6ff527c299b9fa3db677bc1320b9596efbc27853ed730a57df6c1568fd
- sha256sums = 53c28f4f6d9f0dee319188d1dc733ace0500f8c616941110936967e962e605dc
pkgname = neovide
diff --git a/0001-Remove-unnecessary-braces-around-if-condition.patch b/0001-Remove-unnecessary-braces-around-if-condition.patch
deleted file mode 100644
index 2eb29daee44e..000000000000
--- a/0001-Remove-unnecessary-braces-around-if-condition.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff --git a/src/bridge/ui_commands.rs b/src/bridge/ui_commands.rs
-index 77f6774..79767b1 100644
---- a/src/bridge/ui_commands.rs
-+++ b/src/bridge/ui_commands.rs
-@@ -42,7 +42,7 @@ impl UiCommand {
- action,
- position: (grid_x, grid_y),
- } => {
-- if { EDITOR.lock().mouse_enabled } {
-+ if EDITOR.lock().mouse_enabled {
- nvim.input_mouse("left", &action, "", 0, grid_y as i64, grid_x as i64)
- .await
- .expect("Mouse Input Failed");
-@@ -52,14 +52,14 @@ impl UiCommand {
- direction,
- position: (grid_x, grid_y),
- } => {
-- if { EDITOR.lock().mouse_enabled } {
-+ if EDITOR.lock().mouse_enabled {
- nvim.input_mouse("wheel", &direction, "", 0, grid_y as i64, grid_x as i64)
- .await
- .expect("Mouse Scroll Failed");
- }
- }
- UiCommand::Drag(grid_x, grid_y) => {
-- if { EDITOR.lock().mouse_enabled } {
-+ if EDITOR.lock().mouse_enabled {
- nvim.input_mouse("left", "drag", "", 0, grid_y as i64, grid_x as i64)
- .await
- .expect("Mouse Drag Failed");
diff --git a/PKGBUILD b/PKGBUILD
index 898d09351975..506601a96bdc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: peeweep <peeweep at 0x0 dot ee>
pkgname=neovide
-pkgver=0.6.0
-pkgrel=8
+pkgver=0.7.0
+pkgrel=1
pkgdesc='No Nonsense Neovim Client in Rust'
arch=('x86_64')
url='https://github.com/Kethku/neovide'
@@ -12,14 +12,11 @@ makedepends=('rust' 'gtk3' 'cmake' 'sdl2' 'make')
optdepends=("vulkan-intel: vulkan support for intel")
provides=("neovide")
conflicts=("neovide-git")
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz"
- "0001-Remove-unnecessary-braces-around-if-condition.patch")
-sha256sums=('4daaad6ff527c299b9fa3db677bc1320b9596efbc27853ed730a57df6c1568fd'
- '53c28f4f6d9f0dee319188d1dc733ace0500f8c616941110936967e962e605dc')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('59a4bc94348d1e71b402a6202f6dfaba7248d1d5f4bbeeaff6965a7c421afc40')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p1 < "${srcdir}/0001-Remove-unnecessary-braces-around-if-condition.patch"
sed -i 's/debug = true/opt-level = 3\ndebug = false/' Cargo.toml
sed -i 's/Icon=neovide/Icon=nvim/' assets/neovide.desktop
}