summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJack Frost2020-08-22 16:25:51 +0000
committerJack Frost2020-08-22 16:25:51 +0000
commit12ab23faef47de9a7b0294339eb40a6236df38f1 (patch)
tree9ef9a8c368b982043b1c1c17b1ef60b04d2d1813
parentde78899a90f84fc4f4783b324cde9f1185336b83 (diff)
downloadaur-12ab23faef47de9a7b0294339eb40a6236df38f1.tar.gz
update maintainers
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1fea331db9f6..5296bdb20fd1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,6 +16,7 @@ pkgbase = neovide-git
depends = freetype2
depends = libglvnd
depends = sndio
+ depends = noto-fonts
provides = neovide
conflicts = neovide
source = neovide-git::git+https://github.com/Kethku/neovide
diff --git a/PKGBUILD b/PKGBUILD
index 11408e09a2c5..99f2b2b52fab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,6 @@
-# Maintainer: peeweep <peeweep at 0x0 dot ee>
+# Maintainer: j4qfrost <j4qfrost at gmail dot com>
+# Maintainer: ptolemy753 <dsconce at protonmail dot com>
+# Contributor: peeweep <peeweep at 0x0 dot ee>
pkgname=neovide-git
pkgver=0.6.0.r15.gd406cf6
@@ -7,7 +9,7 @@ pkgdesc='No Nonsense Neovim Client in Rust'
arch=('x86_64')
url='https://github.com/Kethku/neovide'
license=('MIT')
-depends=('neovim' 'fontconfig' 'freetype2' 'libglvnd' 'sndio')
+depends=('neovim' 'fontconfig' 'freetype2' 'libglvnd' 'sndio' 'noto-fonts')
makedepends=('git' 'rust' 'gtk3' 'cmake' 'sdl2' 'make')
provides=("neovide")
conflicts=("neovide")
@@ -28,7 +30,7 @@ prepare() {
build() {
cd "${srcdir}/${pkgname}"
export CARGO_HOME="${srcdir}/${pkgname}/CARGO"
- export CFLAGS="-fcommon -fPIE"
+ export CFLAGS="-fcommon"
cargo build --release
}
@@ -38,4 +40,4 @@ package() {
install -Dm644 ${srcdir}/${pkgname}/assets/neovide.desktop ${pkgdir}/usr/share/applications/neovide.desktop
}
-# vim: ts=2 sw=2 et:
+# vim: ts=2 sw=2 et: \ No newline at end of file