summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhangjinqiang2021-04-04 01:34:56 +0800
committerzhangjinqiang2021-04-04 01:34:56 +0800
commitfbfdb5b70f786d731f8220f3959bb6533b868c6b (patch)
tree226955904a2ea88700f4b0f445555e7f8a0e435c
parent12ab23faef47de9a7b0294339eb40a6236df38f1 (diff)
downloadaur-fbfdb5b70f786d731f8220f3959bb6533b868c6b.tar.gz
Revert "update maintainers"
This reverts commit 12ab23faef47de9a7b0294339eb40a6236df38f1.
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD10
2 files changed, 4 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5296bdb20fd1..1fea331db9f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,7 +16,6 @@ pkgbase = neovide-git
depends = freetype2
depends = libglvnd
depends = sndio
- depends = noto-fonts
provides = neovide
conflicts = neovide
source = neovide-git::git+https://github.com/Kethku/neovide
diff --git a/PKGBUILD b/PKGBUILD
index 99f2b2b52fab..11408e09a2c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,4 @@
-# Maintainer: j4qfrost <j4qfrost at gmail dot com>
-# Maintainer: ptolemy753 <dsconce at protonmail dot com>
-# Contributor: peeweep <peeweep at 0x0 dot ee>
+# Maintainer: peeweep <peeweep at 0x0 dot ee>
pkgname=neovide-git
pkgver=0.6.0.r15.gd406cf6
@@ -9,7 +7,7 @@ pkgdesc='No Nonsense Neovim Client in Rust'
arch=('x86_64')
url='https://github.com/Kethku/neovide'
license=('MIT')
-depends=('neovim' 'fontconfig' 'freetype2' 'libglvnd' 'sndio' 'noto-fonts')
+depends=('neovim' 'fontconfig' 'freetype2' 'libglvnd' 'sndio')
makedepends=('git' 'rust' 'gtk3' 'cmake' 'sdl2' 'make')
provides=("neovide")
conflicts=("neovide")
@@ -30,7 +28,7 @@ prepare() {
build() {
cd "${srcdir}/${pkgname}"
export CARGO_HOME="${srcdir}/${pkgname}/CARGO"
- export CFLAGS="-fcommon"
+ export CFLAGS="-fcommon -fPIE"
cargo build --release
}
@@ -40,4 +38,4 @@ package() {
install -Dm644 ${srcdir}/${pkgname}/assets/neovide.desktop ${pkgdir}/usr/share/applications/neovide.desktop
}
-# vim: ts=2 sw=2 et: \ No newline at end of file
+# vim: ts=2 sw=2 et: