summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorswz-git2022-09-13 00:22:44 +0200
committerswz-git2022-09-13 00:30:48 +0200
commitb40e7be8218415b6351ecfa9b58ab34fdacafcb3 (patch)
tree36f069bc1d4dd2b0139f104e53d4ef83ed5b989f
downloadaur-b40e7be8218415b6351ecfa9b58ab34fdacafcb3.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD22
-rw-r--r--neovide-lunarvim.desktop9
-rw-r--r--script.sh7
5 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6bc74ddc0fc0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = neovide-lunarvim
+ pkgdesc = neovide binary and .desktop file that launches with lunarvim
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/neovide/neovide
+ arch = x86_64
+ license = custom
+ depends = neovide
+ optdepends = lunarvim-git: if not installed with shell script
+ source = neovide-lunarvim.desktop
+ source = script.sh
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = neovide-lunarvim
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8a46be03ce3b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src
+pkg
+*.tar.* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d37c1bf712b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Simon <contact at swz dot works>
+pkgname=neovide-lunarvim
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="neovide binary and .desktop file that launches with lunarvim"
+arch=("x86_64")
+url="https://github.com/neovide/neovide"
+conflicts=()
+
+depends=("neovide")
+optdepends=("lunarvim-git: if not installed with shell script")
+
+license=("custom")
+
+source=("neovide-lunarvim.desktop" "script.sh")
+sha512sums=(SKIP SKIP)
+
+package() {
+ bindir="~/.local/bin"
+ install -Dm755 "script.sh" "${pkgdir}/$HOME/.local/bin/${pkgname}"
+ install -Dm755 "${pkgname}.desktop" "${pkgdir}/$HOME/.local/share/applications/${pkgname}.desktop"
+}
diff --git a/neovide-lunarvim.desktop b/neovide-lunarvim.desktop
new file mode 100644
index 000000000000..e93853158744
--- /dev/null
+++ b/neovide-lunarvim.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Exec=/bin/sh -c "$HOME/.local/bin/neovide-lunarvim %F"
+Icon=neovide
+Name=Neovide (lunarvim)
+Keywords=Text;Editor;
+Categories=Utility;TextEditor;
+Comment=No Nonsense Neovim Client in Rust
+MimeType=text/english;text/plain;text/x-makefile;text/x-c++hdr;text/x-c++src;text/x-chdr;text/x-csrc;text/x-java;text/x-moc;text/x-pascal;text/x-tcl;text/x-tex;application/x-shellscript;text/x-c;text/x-c++;
diff --git a/script.sh b/script.sh
new file mode 100644
index 000000000000..b08e4469b028
--- /dev/null
+++ b/script.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+export LUNARVIM_CONFIG_DIR="${LUNARVIM_CONFIG_DIR:-$HOME/.config/lvim}"
+export LUNARVIM_RUNTIME_DIR="${LUNARVIM_RUNTIME_DIR:-$HOME/.local/share/lunarvim}"
+export LUNARVIM_CACHE_DIR="${LUNARVIM_CACHE_DIR:-$HOME/.cache/lvim}"
+
+exec neovide -- -u "$LUNARVIM_RUNTIME_DIR/lvim/init.lua" "$@" \ No newline at end of file